Version 1.42.0 of the Okapi Libraries and Applications has been released

36 views
Skip to first unread message

Mihai Nita

unread,
Oct 30, 2021, 8:51:46 PM10/30/21
to okapi-users

Hi everyone,

Version 1.42.0 of the Okapi Libraries and Tools has been released

You can find the binaries here:
https://okapiframework.org/binaries/main/1.42.0/

The Maven artifacts are in Maven Central, as usual:
https://repo.maven.apache.org/maven2/net/sf/okapi/
It will take a while until they show in searches at https://search.maven.org and https://mvnrepository.com.
(updating the search indexes can take several hours)
But you should be able to use them in your maven builds.

There are many changes in this new release, too many to really list them all.
But here is a summary:
* Major refactor of all core Okapi resources to consistently handle Properties and IAnnotations.
* macOS: added build for aarch64 (ARM 64 bit, Apple M1 chip)
* Many fixes for the OpenXML filter
* Many improvements in the XLIFF2 filter
* Improved segmentation
*  Pensieve TM now uses Lucene 8.8 libraries, huge jump from 3.3
   Slight changes in the TM behavior are expected but the TM should largely behave similarly.
   Testing before production use is strongly encouraged.

You can see all the changes in the Changes Log here:
http://okapiframework.org/snapshots/changes.html

Many thanks to all the contributors who are making this possible.
Thanks to the companies supporting this effort through the time of their developers.

Thank you Aaron for building and signing the Mac OS distribution (soon to come :-)

Also soon to come are the releases of Longhorn and OmegaT_Plugin.

Cheers,
Mihai

Yves Savourel

unread,
Oct 31, 2021, 2:25:59 AM10/31/21
to okapi-users

Hi everyone,

 

The new version of the OmegaT plugin for Okapi Filters has been released.

It now uses the updated filters of the 1.42.0 Okapi library.

 

The ZIP file is here:

https://okapiframework.org/binaries/omegat-plugin/okapiFiltersForOmegaT-1.10-1.42.0-dist.zip

 

Cheers,

-yves

--
You received this message because you are subscribed to the Google Groups "okapi-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to okapi-users...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/okapi-users/CAK69zbkEx6UsEVm7UYoh0Jxuoz42_e5ivx%3DUVL307HVdR%3D1%2Bgg%40mail.gmail.com.

marco.cevoli

unread,
Jan 3, 2022, 6:19:20 AMJan 3
to okapi-users
Hi,

If I go to https://okapiframework.org/binaries/omegat-plugin/ I don't see the 1.42 version (nor the 1.43, if it's been already compiled and distributed...)

TIA,

yves.s...@gmail.com

unread,
Jan 3, 2022, 7:57:25 AMJan 3
to marco.cevoli, okapi-users

It’s there, but sorted above 1.9-1.41 because of the 1.10.

(You had be baffled for two seconds… I couldn’t see it either)

 

 

Cheers,

-yves

image001.png

marco.cevoli

unread,
Jan 3, 2022, 8:00:00 AMJan 3
to okapi-users
Sorry guys (gracias, Manuel), too many hours in front of the computer...

BTW, when will the 1.43 be available?

Reply all
Reply to author
Forward
0 new messages