SWT issues on M2 macs?

2 views
Skip to first unread message

Chase Tingley

unread,
Sep 15, 2022, 4:55:56 PMSep 15
to Group: okapi-devel
Hi all,

We have a user running an M2 mac who is having trouble running any of the SWT-based apps on it.  I had her testing on the official 1.44.0 release (https://okapiframework.org/binaries/main/1.44.0/okapi-apps_cocoa-macosx-aarch64_1.44.0.dmg), and it worked for her on an M1 mac, but not an M2.

The error she saw from Rainbow was 
java.lang.UnsatisfiedLinkError: Could not load SWT library.

Has anyone else seen or heard of this?  I am confused, as I thought M1 and M2 architecture was similar, and when I was looking at SWT stuff on github I didn't see a separate binary component for M2.  

yves.s...@gmail.com

unread,
Sep 15, 2022, 10:21:55 PMSep 15
to okapi...@googlegroups.com

Hi Chase,

 

FWIW, it seems to be a directory problem. Maybe the swt libraries are in a directory with an M2 specific name.

A lot of the solutions I see out there for this type of this error seems to be by creating a sym link to the expected directory name.

 

Cheers,

-ys

--
You received this message because you are subscribed to the Google Groups "okapi-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to okapi-devel...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/okapi-devel/CAGRYq4jD22atOh_Y0khiLdX79s_NZ_JKzJ9D88n7SU3_i5%2BrHQ%40mail.gmail.com.

Aaron Madlon-Kay

unread,
Sep 16, 2022, 9:42:15 PMSep 16
to Group: okapi-devel
I’ve seen weird SWT/architecture-related problems solved by blowing away ~/.swt.

I think what happens is

1. On an arm64 machine you run an x64 SWT and ~/.swt gets populated with x64 binaries
2. Later you run arm64 SWT, and it gets angry about the existing contents of ~/.swt

It seems like a problem that SWT should be smart enough to solve, but who knows.

-Aaron


Reply all
Reply to author
Forward
0 new messages