UPDATE to 11.1.1.5.0

397 views
Skip to first unread message

Michael Wilcke

unread,
May 9, 2011, 1:22:01 PM5/9/11
to OBIEE Enterprise Methodology Group
Hi all,

just installed 11.1.1.5.0, but I could not update my existing
installation, I had to specify a new Middlewarehome i.e. did a new
installation.

There is a hint in the intallation guide that moving from 11.1.1.3.0
to 11.1.1.5.0 would be supported by the general middleware patching
mechanisms.

But in the document being pointed to, I found just hints on how to
INSTALL (i.e. a back-link) and some hints to patch some middleware
products EXCLUDING OBIEE.

grmpffgph...

Any other hints/info?

Michael

Mark Rittman

unread,
May 9, 2011, 2:11:43 PM5/9/11
to obiee-enterpri...@googlegroups.com
Michael

There's a comment at the end of this blog post:


that describes how Oracle say an upgrade should work. I haven't tried it myself yet, but I'll run through the process (should it work) at next week's BI Forum masterclass.

regards

Mark

--
You received this message because you are subscribed to the Google
Groups "OBIEE Enterprise Methodology Group" group.
To post to this group, send email to
obiee-enterpri...@googlegroups.com
To unsubscribe from this group, send email to
obiee-enterprise-met...@googlegroups.com
For more options, visit this group at
http://groups.google.com/group/obiee-enterprise-methodology?hl=en

All content to the OBIEE EMG lies under the Creative Commons Attribution 3.0 Unported License (http://creativecommons.org/licenses/by/3.0/).  Any content sourced must be attributed back to the OBIEE EMG with a link to the Google Group (http://groups.google.com/group/obiee-enterprise-methodology).



--
Mark Rittman
Director
M:+44 (0) 7866 568 246
F: +44 (0) 1273 784 960
E: mark.r...@rittmanmead.com

Winners of the UKOUG Business Intelligence Partner of the Year Award 2010/11

www.rittmanmead.com

Registered Office : Preston Park House, South Road, Brighton, East Sussex, BN1 6SB, United KingdomCompany No. : 6032852
VAT No. : 900 3839 48

Please note that this email communication is intended only for the addressee and may contain confidential or privileged information. The contents of this email may be circulated internally within your organisation only and may not be communicated to third parties without the prior written permission of Rittman Mead Consulting.  This email is not intended nor should it be taken to create any legal relations, contractual or otherwise.

JoelAcha

unread,
May 9, 2011, 5:30:27 PM5/9/11
to OBIEE Enterprise Methodology Group
Mark/Michael

We ran into this problem earlier today and documentation isn't
apparent but you need to choose the software only install option and
this will actually upgrade your existing OBIEE installation.

There are a number of post installation tasks that need to be carried
out but I don't have the documentation on me tonight. Also, there are
some pre installation task including upgrading WLS to 10.3.5

On May 9, 7:11 pm, Mark Rittman <mark.ritt...@rittmanmead.com> wrote:
> Michael
>
> There's a comment at the end of this blog post:
>
> http://www.rittmanmead.com/2011/05/whats-new-in-obiee-11-1-1-5-ps1/
>
> that describes how Oracle say an upgrade should work. I haven't tried it
> myself yet, but I'll run through the process (should it work) at next week's
> BI Forum masterclass.
>
> regards
>
> Mark
>
> E: mark.ritt...@rittmanmead.com

Santosh Krishnan

unread,
May 9, 2011, 9:12:17 PM5/9/11
to obiee-enterpri...@googlegroups.com
Hello All,

I tried installing 11.1.1.5.0 by specifying a new Middleware home (since I already have 11.1.1.3 installed on the same image and everything looks good except the following:

1) I cant get the Enterprise manager to work (http://localhost:7001/em)  - I get the following error:

From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
10.4.5 404 Not Found

The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent

Please note that I can successfully log into the Weblogic Administration console (http://localhost:7001/console)

2) It does not show any session logs.

Did anyone else run into these issues?

Please let me know

Thanks & regards
Santosh



Joel Acha

unread,
May 11, 2011, 6:13:22 PM5/11/11
to obiee-enterpri...@googlegroups.com, obiee-enterpri...@googlegroups.com
It is possible to apply 11.1.1.5 as a patch on top of an existing 11.1.1.3 OBIEE Installation. See documentation URL:


Regards
Joel 

Sent from my iPad

Santosh Krishnan

unread,
May 12, 2011, 10:48:33 AM5/12/11
to obiee-enterpri...@googlegroups.com
Thanks Joel. Will give this a shot.

Regards
Santosh

luis gálvez

unread,
May 12, 2011, 9:38:10 AM5/12/11
to obiee-enterpri...@googlegroups.com
Hi, those are a good news.

The documentation talks about up to 11.1.1.4 generic version.
Did you already try it?

Regards,

Luis.

Joel Acha

unread,
May 13, 2011, 12:43:32 AM5/13/11
to obiee-enterpri...@googlegroups.com, obiee-enterpri...@googlegroups.com
Hi Luis

You basically need to follow instructions in document and it definitely upgraded our 11.1.1.3 to 11.1.1.5

Regards
Joel

Sent from my iPad

Santosh Krishnan

unread,
May 13, 2011, 4:07:32 PM5/13/11
to obiee-enterpri...@googlegroups.com
Hello Joel,

I been struggling to get 11.1.1.3 patched to 11.1.1.5. I am on step 5 out of 7.  I got the weblogic server upgraded to 10.3.5 and was also successful but when I try to upgrade the system components by running the script nelow: it fails...


cd ORACLE_HOME\opmn\bin
upgradenonj2eeapp.bat -oracleInstance C:\Oracle\\MiddelwareHome\instances\instance1 -adminHost localhost -adminPort 7001 -adminUsername weblogic
I am on step :

3.7.2 Post-Patching Tasks If Your Starting Point is Release 11.1.1.3.0



I did a simple install of 11.1.1.3 so do I have to go through all the steps as listed in that table or would only sections 3.7.4.1, 3.7.5.1, 3.7.5.2 , 3.7.10.1, 3.7.10.2 and 3.7.10.3 apply?

Any inputs / suggestions/ comments/ brickbats would be highly appreciated.

Santosh Krishnan

unread,
May 13, 2011, 6:49:43 PM5/13/11
to obiee-enterpri...@googlegroups.com
Hello All,

I followed a very detailed blog by Mark but it didnt work for my upgrade..


Fails at step 5 for me. 

When I run the command (detailed in step 5 of the blog) , it is successful in unregistering the instance but it fails to reddeploy NonJ2EEManagement.ear 

Looked at the provison.log and this is what I see:

SEVERE: Command failed:
oracle.as.config.utl.DeployerException: NonJ2EEManagement Applicationdeployment failed.
at oracle.as.config.utl.Deployer.deployApplication(Deployer.java:97)
at oracle.as.config.utl.Deployer.redeploy(Deployer.java:57)
at oracle.as.config.impl.RuntimeServiceConnection.redeployNonj2eeApplication(RuntimeServiceConnection.java:306)
at oracle.as.config.impl.RuntimeServiceConnection.redeploy(RuntimeServiceConnection.java:265)
at oracle.as.config.provisioner.commands.RedeployCommand.execute(RedeployCommand.java:25)
at oracle.as.config.provisioner.InstallerCmdLine.run(InstallerCmdLine.java:146)
at oracle.as.config.provisioner.InstallerCmdLine.main(InstallerCmdLine.java:46)
Caused by: java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at oracle.as.config.utl.Deployer.deployApplication(Deployer.java:95)
... 6 more
Caused by: weblogic.management.ManagementException: [Deployer:149163]The domain edit lock is owned by another session in non-exclusive mode - this deployment operation requires exclusive access to the edit lock and hence cannot proceed. If you are using "Automatically Aquire Lock and Activate Changes" in the console, then the lock will expire shortly so retry this operation.

Do y'all any idea or any suggestions as to why this is happening and how I could get around this error?

Please let me know.

Thanks & regards
Santosh

Santosh Krishnan

unread,
May 13, 2011, 7:10:26 PM5/13/11
to obiee-enterpri...@googlegroups.com
Found the solution:

Login to Admin console at http://localhost:7001/console and be sure you click either Activate Changes or Release Configuration in the Change Center and then rerun the deploy task

and then run the command opmnctl redeploy -oracleInstance C:\oracle\Middleware\instances\instance1 -adminHost localhost -adminPort 7001 -adminUsername weblogic

(Adjust for your envrionments)

Mark Rittman

unread,
May 14, 2011, 2:16:02 AM5/14/11
to OBIEE Enterprise Methodology Group
Hi All

As Santosh mentioned, I did the update on Friday and wrote up the
steps here:

http://www.rittmanmead.com/2011/05/in-place-upgrading-of-obiee-11-1-1-3-to-11-1-1-5/

A couple of points / observations on top of this.

1. It's really important that the WebLogic upgrade goes OK. I ran it
once before, and it failed at about 50% due to components still being
used elsewhere; basically, beasvc.exe was still running even after I
ran the scripts to shutdown my WLS administration and managed
services. After I shut beasvc.exe down, I re-ran the update installer,
it completed fine, but several steps down the line I couldn't start
WLST.cmd, and therefore couldn't complete the upgrade.

2. There is a step detailed in the docs that says you should run the
updateOpss() WLST command. I did this, but then found it was
duplicated in an OBEE-specific script (bi-upgrade.py) that the docs
ask you to run afterwards, so I left updateOpss() off of my
instructions.

3. There is also a step at the end where you are asked (in the docs)
to update the BIAdministrator principal - this is the application
policy that determines Java permissions for the BIAdministrator
application role. Unfortunately when I amended the policy using the
instructions, EM reported an error, and so given that the new
permissions relate solely to RTD, and I don't intend to use RTD, I
skipped this step, and another one afterwards that was specific to
RTD.

So overall, the process works, but what Oracle really need to produce
an upgrade option in the Universal Installer, rather than just have
you do a software-only install into the existing middleware home and
then make all the configuration changes yourself. What the upgrade
installer should do is:

- upgrade WLS for you (and also therefore avoid you needing to go to
metalink and get the software - this will catch all "unsupported"
users out)
- Amend the WLS environment script to make use of the new JRockit JVM
- Upgrade the software in the middleware home
- Have a configuration stage that runs through all the processes that
we have to do manually in my blog post

Hopefully this is something they will consider at some point, as at
present, it's far easier for a customer to do an out-of-place upgrade
and manually migrate the RPD, catalog objects over afterwards.

regards, Mark

On May 14, 12:10 am, Santosh Krishnan <imsant...@gmail.com> wrote:
> Found the solution:
>
> Login to Admin console athttp://localhost:7001/consoleand be sure you
> click either Activate Changes or Release Configuration in the Change Center
> and then rerun the deploy task
>
> and then run the command opmnctl redeploy -oracleInstance
> C:\oracle\Middleware\instances\instance1 -adminHost localhost -adminPort
> 7001 -adminUsername weblogic
>
> (Adjust for your envrionments)
>
> On Fri, May 13, 2011 at 6:49 PM, Santosh Krishnan <imsant...@gmail.com>wrote:
>
>
>
>
>
>
>
> > Hello All,
>
> > I followed a very detailed blog by Mark but it didnt work for my upgrade..
>
> >http://www.rittmanmead.com/2011/05/in-place-upgrading-of-obiee-11-1-1...
> > sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImp l.java:25)
> > at java.lang.reflect.Method.invoke(Method.java:597)
> >  at oracle.as.config.utl.Deployer.deployApplication(Deployer.java:95)
> > ... 6 more
> > Caused by: weblogic.management.ManagementException: [Deployer:149163]The
> > domain edit lock is owned by another session in non-exclusive mode - this
> > deployment operation requires exclusive access to the edit lock and hence
> > cannot proceed. If you are using "Automatically Aquire Lock and Activate
> > Changes" in the console, then the lock will expire shortly so retry this
> > operation.
>
> > Do y'all any idea or any suggestions as to why this is happening and how I
> > could get around this error?
>
> > Please let me know.
>
> > Thanks & regards
> > Santosh
>
> > On Fri, May 13, 2011 at 4:07 PM, Santosh Krishnan <imsant...@gmail.com>wrote:
>
> >> Hello Joel,
>
> >> I been struggling to get 11.1.1.3 patched to 11.1.1.5. I am on step 5 out
> >> of 7.  I got the weblogic server upgraded to 10.3.5 and was also successful
> >> but when I try to upgrade the system components by running the script nelow:
> >> it fails...
>
> >> *
>
> >> cd ORACLE_HOME\opmn\bin
> >> upgradenonj2eeapp.bat -oracleInstance C:\Oracle\\MiddelwareHome\instances\instance1 -adminHost localhost -adminPort 7001 -adminUsername weblogic
>
> >> *I am on step :
> >> 3.7.2 Post-Patching Tasks If Your Starting Point is Release 11.1.1.3.0
>
> >>http://download.oracle.com/docs/cd/E21764_01/doc.1111/e16793/patch_se...
>
> >> I did a simple install of 11.1.1.3 so do I have to go through all the
> >> steps as listed in that table or would only sections 3.7.4.1, 3.7.5.1,
> >> 3.7.5.2 , 3.7.10.1, 3.7.10.2 and 3.7.10.3 apply?
>
> >> Any inputs / suggestions/ comments/ brickbats would be highly appreciated.
>
> >> On Fri, May 13, 2011 at 12:43 AM, Joel Acha <eluti...@gmail.com> wrote:
>
> >>> Hi Luis
>
> >>> You basically need to follow instructions in document and it definitely
> >>> upgraded our 11.1.1.3 to 11.1.1.5
>
> >>> Regards
> >>> Joel
>
> >>> Sent from my iPad
>
> >>> On 12 May 2011, at 14:38, luis gálvez <lx.gal...@gmail.com> wrote:
>
> >>> Hi, those are a good news.
>
> >>> The documentation talks about up to 11.1.1.4 generic version.
> >>> Did you already try it?
>
> >>> Regards,
>
> >>> Luis.
>
> >>> On Wed, May 11, 2011 at 4:13 PM, Joel Acha < <eluti...@gmail.com>
> >>> eluti...@gmail.com> wrote:
>
> >>>> It is possible to apply 11.1.1.5 as a patch on top of an existing
> >>>> 11.1.1.3 OBIEE Installation. See documentation URL:
>
> >>>> <http://download.oracle.com/docs/cd/E21764_01/doc.1111/e16793/patch_se...>
> >>>>http://download.oracle.com/docs/cd/E21764_01/doc.1111/e16793/patch_se...
>
> >>>> Regards
> >>>> Joel
>
> >>>> Sent from my iPad
>
> >>>> On 10 May 2011, at 02:12, Santosh Krishnan < <imsant...@gmail.com>
> >>>> imsant...@gmail.com> wrote:
>
> >>>> Hello All,
>
> >>>> I tried installing 11.1.1.5.0 by specifying a new Middleware home (since
> >>>> I already have 11.1.1.3 installed on the same image and everything looks
> >>>> good except the following:
>
> >>>> 1) I cant get the Enterprise manager to work (<http://localhost:7001/em><http://localhost:7001/em>
> >>>>http://localhost:7001/em)  - I get the following error:
>
> >>>> From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
> >>>> 10.4.5 404 Not Found
>
> >>>> The server has not found anything matching the Request-URI. No
> >>>> indication is given of whether the condition is temporary or permanent
>
> >>>> Please note that I can successfully log into the Weblogic Administration
> >>>> console ( <http://localhost:7001/console><http://localhost:7001/console>
> >>>>http://localhost:7001/console)
>
> >>>> 2) It does not show any session logs.
>
> >>>> Did anyone else run into these issues?
>
> >>>> Please let me know
>
> >>>> Thanks & regards
> >>>> Santosh
>
> >>>> On Mon, May 9, 2011 at 1:22 PM, Michael Wilcke <<michael.wil...@gmail.com><michael.wil...@gmail.com>
> >>>> michael.wil...@gmail.com> wrote:
>
> >>>>> Hi all,
>
> >>>>> just installed 11.1.1.5.0, but I could not update my existing
> >>>>> installation, I had to specify a new Middlewarehome i.e. did a new
> >>>>> installation.
>
> >>>>> There is a hint in the intallation guide that moving from 11.1.1.3.0
> >>>>> to 11.1.1.5.0 would be supported by the general middleware patching
> >>>>> mechanisms.
>
> >>>>> But in the document being pointed to, I found just hints on how to
> >>>>> INSTALL (i.e. a back-link) and some hints to patch some middleware
> >>>>> products EXCLUDING OBIEE.
>
> >>>>> grmpffgph...
>
> >>>>> Any other hints/info?
>
> >>>>> Michael
>
> >>>>> --
> >>>>> You received this message because you are subscribed to the Google
> >>>>> Groups "OBIEE Enterprise Methodology Group" group.
> >>>>> To post to this group, send email to
> >>>>>  <obiee-enterpri...@googlegroups.com><obiee-enterprise-methodolog y...@googlegroups.com>
> >>>>> obiee-enterpri...@googlegroups.com
> >>>>> To unsubscribe from this group, send email to
> >>>>>  <obiee-enterprise-methodology%2Bunsu...@googlegroups.com><obiee-enterpr ise-methodolo...@googlegroups.com>
> >>>>> obiee-enterprise-met...@googlegroups.com
> >>>>> For more options, visit this group at
> >>>>>  <http://groups.google.com/group/obiee-enterprise-methodology?hl=en><http://groups.google.com/group/obiee-enterprise-methodology?hl=en>
> >>>>>http://groups.google.com/group/obiee-enterprise-methodology?hl=en
>
> >>>>> All content to the OBIEE EMG lies under the Creative Commons
> >>>>> Attribution 3.0 Unported License (<http://creativecommons.org/licenses/by/3.0/><http://creativecommons.org/licenses/by/3.0/>
> >>>>>http://creativecommons.org/licenses/by/3.0/).  Any content sourced
> >>>>> must be attributed back to the OBIEE EMG with a link to the Google Group (<http://groups.google.com/group/obiee-enterprise-methodology><http://groups.google.com/group/obiee-enterprise-methodology>
> >>>>>http://groups.google.com/group/obiee-enterprise-methodology).
>
> >>>>  --
> >>>> You received this message because you are subscribed to the Google
> >>>> Groups "OBIEE Enterprise Methodology Group" group.
> >>>> To post to this group, send email to
> >>>>  <obiee-enterpri...@googlegroups.com><obiee-enterprise-methodolog y...@googlegroups.com>
> >>>> obiee-enterpri...@googlegroups.com
> >>>> To unsubscribe from this group, send email to
> >>>>  <obiee-enterprise-met...@googlegroups.com><obiee-enterpris e-methodolog...@googlegroups.com>
> >>>> obiee-enterprise-met...@googlegroups.com
> >>>> For more options, visit this group at
> >>>>  <http://groups.google.com/group/obiee-enterprise-methodology?hl=en><http://groups.google.com/group/obiee-enterprise-methodology?hl=en>
> >>>>http://groups.google.com/group/obiee-enterprise-methodology?hl=en
>
> >>>> All content to the OBIEE EMG lies under the Creative Commons Attribution
> >>>> 3.0 Unported License ( <http://creativecommons.org/licenses/by/3.0/><http://creativecommons.org/licenses/by/3.0/>
> >>>>http://creativecommons.org/licenses/by/3.0/). Any content sourced must
> >>>> be attributed back to the OBIEE EMG with a link to the Google Group (<http://groups.google.com/group/obiee-enterprise-methodology><http://groups.google.com/group/obiee-enterprise-methodology>
> >>>>http://groups.google.com/group/obiee-enterprise-methodology).
>
> >>>>  --
> >>>> You received this message because you are subscribed to the Google
> >>>> Groups "OBIEE Enterprise Methodology Group" group.
> >>>> To post to this group, send email to
> >>>>  <obiee-enterpri...@googlegroups.com>
> >>>> obiee-enterpri...@googlegroups.com
> >>>> To unsubscribe from this group, send email to
> >>>>  <obiee-enterprise-methodology%2Bunsu...@googlegroups.com>
> ...
>
> read more »

Santosh Krishnan

unread,
May 14, 2011, 12:08:19 PM5/14/11
to obiee-enterpri...@googlegroups.com
I agree with Mark. Oracle needs to come up with some upgrade tool or installer to make this process much more easier. Right now its a PITA! I have been struggling with the upgrade for a while but I am so close to the finish line here !

Stuck at the step wherein i have to run wlst command ----> upgradeWSMPolicyRepository

Get the following error:

Connecting to t3://localhost:7001 with userid weblogic ...
Successfully connected to Admin Server 'AdminServer' that belongs to domain 'bifoundation_domain'.

Warning: An insecure protocol was used to connect to the
server. To ensure on-the-wire security, the SSL port or
Admin port should be used instead.

wls:/bifoundation_domain/serverConfig> upgradeWSMPolicyRepository()
Traceback (innermost last):
  File "<console>", line 1, in ?
NameError: upgradeWSMPolicyRepository
wls:/bifoundation_domain/serverConfig>

So close, yet so far!

Any suggestions?

All content to the OBIEE EMG lies under the Creative Commons Attribution 3.0 Unported License (http://creativecommons.org/licenses/by/3.0/).  Any content sourced must be attributed back to the OBIEE EMG with a link to the Google Group (http://groups.google.com/group/obiee-enterprise-methodology).

Reply all
Reply to author
Forward
0 new messages