Nexus-DR-X Raspbian Update error updating libc6

7 views
Skip to first unread message

Steve Magnuson

unread,
Sep 7, 2021, 7:53:35 PM9/7/21
to nwwdigi
A libc6 update released today for the Raspbian OS isn’t compatible with the custom AX25 packages the Nexus uses. Running the Nexus Updater and selecting ‘raspbian’ will fail with an error similar to:

You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libc6-dev : Depends: libc6 (= 2.28-10+rpi1) but 2.28-10+rpt1+rpi1 is installed
Depends: libc-dev-bin (= 2.28-10+rpi1) but 2.28-10+rpt1+rpi1 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

See these instructions to fix: https://github.com/NexusDR-X/images/blob/master/README.md#september-7-2021-libc6-update-error

Steve
AG7GN

Gayland Gump

unread,
Sep 21, 2021, 12:06:49 PM9/21/21
to nww...@googlegroups.com
Steve,

I am finally getting around to checking out nexusdrxpi_20210813RC2.img.  The first issue encountered is one you may never have encountered since I started up the image sans keyboard and occurred while another computer of mine was booting too which I initially attributed the issue.  In short, the Pi folks have added a new audio prompt to their install setup.

I am currently sitting here waiting for the Update Software process of my initial OS setup to complete.  It's taking its own sweet time it is finished downloading and installing, starting around 0805 and finished at 0814.  The process said system was up to date so I performed the restart.

Before I did anything else I was going to address the libax25 issue you'd reported but when I ran "sudo apt -r libax25 and ax25-tools ax25-apps" none of them were installed and the /usr/local/src/nexus/nexus-rmsgw directory was missing.  

I then went looking for the Raspberry > Hamradio and it was absent.  I've got to run now but will start over from the very beginning and will re-download and decompress the xy compresse image and install to a new card unless I hear something different from you before then.

Gayland
KG7GCF


--
You received this message because you are subscribed to the Google Groups "Northwest Washington Digital Amateur Radio" group.
To unsubscribe from this group and stop receiving emails from it, send an email to nwwdigi+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/nwwdigi/282493EA-5E1D-4C77-98C6-087643666F39%40gmail.com.
Reply all
Reply to author
Forward
0 new messages