Re: [nw.js] Build Error nw-51 ( ../Release_GN_x64/obj/buildtools/third_party/libc++/libcpp.lib': no such file or directory

24 views
Skip to first unread message
Message has been deleted

Roger Wang

unread,
May 3, 2021, 10:11:56 AM5/3/21
to rushil mahajan, nw.js
You can check the official build configuration here:


The environment variables and command can be seen in 'stdio' links of each steps.

Roger

On Mon, May 3, 2021 at 5:00 AM rushil mahajan <rushilm...@gmail.com> wrote:
node-nw picked - https://github.com/nwjs/node/tree/nw51 

Upgrading my  WINDOWS chromium and node setup from Chromium-74(3729), Node(nw38)
to  chromium-88 (4324 build) and node-nwjs (nw51)

Chromium args.gn - 
chrome_pgo_phase=0, clang_use_chrome_plugins=false, enable_background_mode=false, enable_basic_printing=true, enable_nacl=false, enable_print_preview=true, enable_resource_allowlist_generation=false, enable_widevine=true,fmpeg_branding="Chrome", forbid_non_component_debug_builds=false,is_component_build=false, is_debug=false,, is_official_build=true, optimize_webui=true, proprietary_codecs=true, target_cpu="x64", is_official_build=true, ffmpeg_branding="Chrome", proprietary_codecs=true, use_allocator_shim=false

with this, I was successfully able to build in ../Release_GN_x64


Difficulties faced while building node - 

Node-nw building arguments for node-nw38 setup 
set GYP_DEFINES=target_arch=x64 host_arch=x64 nwjs_sdk=1 disable_nacl=0 buildtype=Official  clang=0 
Everything builds fine with this (nw38) setup,

While for nw-51, errors - 
1. Gyp is missing, tried copying node/tools/gyp to chromium/tools/ but got an error ( Unknown AST node at key path '" + ".".join(keypath) + "': " + repr(node TypeError: Unknown AST node at key path 'variables.v8_use_siphash%': <_ast.Num object at 0x0000000003404C88> while reading node.gyp) to resolve this issue I used older gyp (got from my previous node(nw-38)/tools.

ran ninja -C out/Release_x64 node - 

further issues - 
2. Related to GCC (__attribute__) (i.e. - crc_folding.c(46): error C2143: syntax error: missing ')' before '(' ),  fix done from my side -  I enabled clang=1 and building_nw=1

3. icudt.dll is missing, for that I added icu_use_data_file_flag=1  

After 3, my -  GYP_Defines arguments -  
set GYP_DEFINES=target_arch=x64 host_arch=x64 nwjs_sdk=1 disable_nacl=0 buildtype=Official icu_use_data_file_flag=1 clang=1 building_nw=1 

4. In nw-51 we have an additional dependency  of libcpp.lib-  so got an error of - (../Release_GN_x64/obj/buildtools/third_party/libc++/libcpp.lib': no such file or directory) tried muting this line in node.gyp as it is in present earlier in nw-38 

After step-4 - I'm still getting some error which I assume is related to this libcpp (I have the attached the error's message in conversation)

Need help in this whole node building procedure, can you suggest where could be the issue.

Thanks,
Rushil

--
You received this message because you are subscribed to the Google Groups "nw.js" group.
To unsubscribe from this group and stop receiving emails from it, send an email to nwjs-general...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/nwjs-general/121e62f1-66cc-4b95-8a2a-3254bbede727n%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages