v0.2.3

3 views
Skip to first unread message

Dru Sellers

unread,
Sep 2, 2010, 8:28:25 AM9/2/10
to nu-...@googlegroups.com
new gem pushed. should fix the active support issue
-d

Brendan Erwin

unread,
Sep 2, 2010, 8:59:52 AM9/2/10
to nu-...@googlegroups.com
There might be a problem with that gem:

$ gem install nu
ERROR: While executing gem ... (Zlib::GzipFile::Error)
not in gzip format

Brendan Erwin

unread,
Sep 2, 2010, 9:07:11 AM9/2/10
to nu-...@googlegroups.com
Scratch that, no problem.

Stupid content filter at the office....

Brendan Erwin

unread,
Sep 2, 2010, 9:12:59 AM9/2/10
to nu-...@googlegroups.com
And, that version DOES have another problem.

The original fix for the active_support dependency specified version 3, which doesn't work right.

This fixes it by specifying the version that does work:

http://github.com/nu/nu/issues#issue/9

On Sep 2, 2010, at 8:28 AM, Dru Sellers wrote:

Matt Michielsen

unread,
Sep 2, 2010, 9:22:27 AM9/2/10
to nu-...@googlegroups.com
Hmm, version 3 worked on my machine (on ruby 1.9.1).

Brendan Erwin

unread,
Sep 2, 2010, 9:25:49 AM9/2/10
to nu-...@googlegroups.com
Do gem list activesupport

If it has 2.3.5 in it then it will work on your machine. 

Sent from my iPad

Brendan Erwin

unread,
Sep 2, 2010, 9:28:34 AM9/2/10
to nu-...@googlegroups.com
Wait, that version of nu doesn't specify the precise version of active_support it wants, so it would use the highest version I think.

http://github.com/nu/nu/blob/v0.2.3/lib/nu/json_shim.rb

The fix I have specifies a lower version than 3.0 since the to_json method isn't in 3.0:

http://github.com/brendanjerwin/nu/blob/35eb656623fddc6675094dd89efae1cf69479864/lib/nu/json_shim.rb

Matt Michielsen

unread,
Sep 2, 2010, 9:28:58 AM9/2/10
to nu-...@googlegroups.com
Nope:

C:\Users\mmichielsen>gem list activesupport

*** LOCAL GEMS ***

activesupport (3.0.0)

I discovered the dependency by having the same error message.

Brendan Erwin

unread,
Sep 2, 2010, 9:30:40 AM9/2/10
to nu-...@googlegroups.com
Are you trying with the --json switch?

Sent from my iPad

Matt Michielsen

unread,
Sep 2, 2010, 9:33:01 AM9/2/10
to nu-...@googlegroups.com
No, I sure didn't.  Should have tested a little more thoroughly.  Thanks for the explanation.

Brendan Erwin

unread,
Sep 2, 2010, 9:49:47 AM9/2/10
to nu-...@googlegroups.com
That's funny. The problem isn't that you should have tested better. It's that I should have written my specs for the new functionality. 

Sent from my iPad

Dru Sellers

unread,
Sep 2, 2010, 9:53:16 AM9/2/10
to nu-...@googlegroups.com
do we just want to fix

  s.add_dependency('activesupport','>= 3.0.0')

to

  s.add_dependency('activesupport','= 2.3.5')

?

-d

Brendan Erwin

unread,
Sep 2, 2010, 10:19:38 AM9/2/10
to nu-...@googlegroups.com
The pull request has the fix and clarifies the exception if the version still happens to be wrong. 

Sent from my iPad

Brendan Erwin

unread,
Sep 2, 2010, 10:20:32 AM9/2/10
to nu-...@googlegroups.com
That's this one, to be clear: http://github.com/nu/nu/issues#issue/9

Dru Sellers

unread,
Sep 2, 2010, 10:44:08 AM9/2/10
to nu-...@googlegroups.com
Ok. think this is all up top and happy.
-d
Reply all
Reply to author
Forward
0 new messages