one click ruby installer

332 views
Skip to first unread message

Dru Sellers

unread,
Aug 25, 2010, 11:16:25 AM8/25/10
to nu-...@googlegroups.com
Don't forget if you need to install ruby its dead simple

Download this and run
http://rubyforge.org/frs/download.php/72085/rubyinstaller-1.8.7-p302.exe

tah-dah!

Maybe someone could get this up on the wiki?

-d

Will Green

unread,
Aug 27, 2010, 8:10:20 PM8/27/10
to nu-net
The 1.9.2 release is substantially faster on Windows, since they
switched compilers to GCC 4.5

http://rubyinstaller.org/news/2010/08/23/rubyinstaller-1-9-2-p0-and-new-devkits-released/

==
Will

On Aug 25, 11:16 am, Dru Sellers <d...@drusellers.com> wrote:
> Don't forget if you need to install ruby its dead simple
>
> Download this and runhttp://rubyforge.org/frs/download.php/72085/rubyinstaller-1.8.7-p302.exe

Dru Sellers

unread,
Aug 27, 2010, 8:10:51 PM8/27/10
to nu-...@googlegroups.com
Yeah but the ruby community (from what I understand) has largely not moved past 1.8.7

-d

Simser, Bil

unread,
Aug 27, 2010, 8:16:49 PM8/27/10
to nu-...@googlegroups.com
Is there a compatibility problem with >1.8.7? Why does it matter what version anyone runs as long as it works. If it works faster, all the better.

Dru Sellers

unread,
Aug 27, 2010, 9:12:06 PM8/27/10
to nu-...@googlegroups.com
You would have to look into it deeper than I have but my understanding is that newer versions of ruby contain some level of breaking change. Again not sure it effects us but we should look around.

-d

Simser, Bil

unread,
Aug 27, 2010, 9:14:38 PM8/27/10
to nu-...@googlegroups.com
Just downloaded it and have a new gem in my backlog to build so I'll try a build/push tonight to see if there's any issue. Thanks.

Justin Rudd

unread,
Aug 27, 2010, 10:49:46 PM8/27/10
to nu-...@googlegroups.com
You probably won't have any problems with gems.  Most of the problems occur when a library was written for 1.8.x, and the library monkey patched a core class.  In 1.9.x, a lot of those various monkey patches (the more popular ones anyway) are now in the core classes.  And hence the monkey patch steps on the new code's toes.

That's what I ran into with DataMapper early on.  I think a lot of them have been fixed.

Dru Sellers

unread,
Aug 28, 2010, 6:34:36 PM8/28/10
to nu-...@googlegroups.com
Excellent news.
-d

Spolto

unread,
Sep 2, 2010, 4:31:39 AM9/2/10
to nu-net
I've just come to look at Nu as the promise of it appears to be great,
having suffered from various dependency conflicts. I just installed
ruby 1.9.2 and there appears to be a breaking change relating to "."
being removed from the LOAD_PATH. Now I'm stubbornly trying to get
this working despite being a complete ruby noob.

I've downloaded the source and modified line bin/nu:
-require 'nu'
+require '../lib/nu'

I found that activesupport was missing so installed it:
> gem install activesupport

Now I'm getting an error that I'm not sure how to resolve when I try
to run it:

C:\github\nu.git\bin>ruby nu -h
C:/github/nu.git/lib/nu/api.rb:76:in `version_string': undefined
method `version' for nil:NilClass (NoMethodError)
from C:/github/nu.git/lib/nu/app.rb:173:in `output_version'
from C:/github/nu.git/lib/nu/app.rb:162:in `output_help'
from C:/github/nu.git/lib/nu/app.rb:74:in `block (2 levels) in
initialize'
from C:/github/nu.git/lib/nu/app.rb:78:in `call'
from C:/github/nu.git/lib/nu/app.rb:78:in `rescue in
initialize'
from C:/github/nu.git/lib/nu/app.rb:36:in `initialize'
from nu:7:in `new'
from nu:7:in `<main>'

Any one able to help please?

Thanks
Spolto

On Aug 28, 11:34 pm, Dru Sellers <d...@drusellers.com> wrote:
> Excellent news.
> -d
>
> On Aug 27, 2010, at 9:49 PM, Justin Rudd wrote:
>
>
>
> > You probably won't have any problems with gems.  Most of the problems occur when a library was written for 1.8.x, and the library monkey patched a core class.  In 1.9.x, a lot of those various monkey patches (the more popular ones anyway) are now in the core classes.  And hence the monkey patch steps on the new code's toes.
>
> > That's what I ran into with DataMapper early on.  I think a lot of them have been fixed.
>
> > On Fri, Aug 27, 2010 at 6:14 PM, Simser, Bil <Bil.Sim...@fortisalberta.com> wrote:
> > Just downloaded it and have a new gem in my backlog to build so I'll try a build/push tonight to see if there's any issue. Thanks.
>
> > -----Original Message-----
> > From: nu-...@googlegroups.com [mailto:nu-...@googlegroups.com] On Behalf Of Dru Sellers
> > Sent: Friday, August 27, 2010 7:12 PM
> > To: nu-...@googlegroups.com
> > Subject: Re: one click ruby installer
>
> > You would have to look into it deeper than I have but my understanding is that newer versions of ruby contain some level of breaking change. Again not sure it effects us but we should look around.
>
> > -d
>
> > On Aug 27, 2010, at 7:16 PM, "Simser, Bil" <Bil.Sim...@fortisalberta.com> wrote:
>
> > > Is there a compatibility problem with >1.8.7? Why does it matter what version anyone runs as long as it works. If it works faster, all the better.
>
> > > -----Original Message-----
> > > From: nu-...@googlegroups.com [mailto:nu-...@googlegroups.com] On
> > > Behalf Of Dru Sellers
> > > Sent: Friday, August 27, 2010 6:11 PM
> > > To: nu-...@googlegroups.com
> > > Subject: Re: one click ruby installer
>
> > > Yeah but the ruby community (from what I understand) has largely not
> > > moved past 1.8.7
>
> > > -d
>

Dru Sellers

unread,
Sep 2, 2010, 8:24:02 AM9/2/10
to nu-...@googlegroups.com
As I have not tested it on 1.9.x my first suggestion is 1.8.7 of ruby. Try that first.
indeed there is an active support issue that I will be addressing today.
to run the program you just type 'nu' not 'ruby nu'

-d

Matt Michielsen

unread,
Sep 2, 2010, 8:29:17 AM9/2/10
to nu-...@googlegroups.com
My one-liner commit that has been merged in solves the activesupport thing.  I'm running fine on 1.9.1, but I haven't upgraded to 1.9.2 yet.  I'll test on 1.9.2 later today to see if I can get the same thing to happen.

Dru Sellers

unread,
Sep 2, 2010, 8:35:57 AM9/2/10
to nu-...@googlegroups.com
And your commit is in the newest gem I just pushed. :)

-d

Brendan Erwin

unread,
Sep 2, 2010, 9:03:18 AM9/2/10
to nu-...@googlegroups.com
I use 1.9.2 on my windows machine and it has been working fine.

This error looks like something is wrong with the gem. The version command asks for the Gem::Specification for nu and reports the .version property. This error says that the Gem::Specification is nil.

Spolto,

Did you upgrade to 1.9.2 from 1.8.*? I did and had problems with gem thinking the gem cache was still under the 1.8 directory structure. Had to rename my entire ruby 1.8 directory to make it happy.

Spolto

unread,
Sep 2, 2010, 2:56:54 PM9/2/10
to nu-net
Updating the nu gem resolved the issue, thank you very much!


On Sep 2, 2:03 pm, Brendan Erwin <brendanjer...@gmail.com> wrote:
> I use1.9.2on my windows machine and it has been working fine.
>
> This error looks like something is wrong with the gem. The version command asks for the Gem::Specification for nu and reports the .version property. This error says that the Gem::Specification is nil.
>
> Spolto,
>
>         Did you upgrade to1.9.2from 1.8.*? I did and had problems with gem thinking the gem cache was still under the 1.8 directory structure. Had to rename my entire ruby 1.8 directory to make it happy.
>
> On Sep 2, 2010, at 8:24 AM, Dru Sellers wrote:
>
>
>
> > As I have not tested it on 1.9.x my first suggestion is 1.8.7 of ruby. Try that first.
> > indeed there is an active support issue that I will be addressing today.
> > to run the program you just type 'nu' not 'ruby nu'
>
> > -d
>
> > On Thu, Sep 2, 2010 at 3:31 AM, Spolto <chris.spol...@gmail.com> wrote:
> > I've just come to look at Nu as the promise of it appears to be great,
> > having suffered from various dependency conflicts. I just installed
> > ruby1.9.2and there appears to be a breaking change relating to "."
> > > > >> The1.9.2release is substantially faster on Windows, since they
Reply all
Reply to author
Forward
0 new messages