Build for Android Linux

8 views
Skip to first unread message

jcor...@gmail.com

unread,
Jun 16, 2021, 10:49:35 PMJun 16
to Notecase Pro
Hi Miro,

I was trying to get the desktop version of Notecase installed on my Android tablet to be able have all the features available (rather than just the Android version).

By using the app UserLAnd, I was able to get a Linux distro (ARM64) installed on my tablet and it can run various apps, such as Libre Office.

I then installed the RaspberryPi verison of Notecase Pro, which the Linux distribution did successfully.

The problem is that when I try to run Notecase, I get:
notecase: error while loading shared libraries: /usr/lib/aarch64-linux-gnu/libc.sl: invalid ELF header

I'm assuming that this is because the underlying glibc libraries are different between the Arm64 distribution on my tablet and the RaspberryPi distro.

Do you have any suggestions for how I can bridge this gap to get it up and running?

Thanks,

John

Ps:  BTW, I was recently able to get Notecase Pro up and running under Linux on an AMD64 (X86-64) based Chromebook, but it did take some work to get all of the dependencies installed.  Ultimately, the Chromebook wasn't the solution I needed, but it was satisfying to see Notecase running on it.

jcor...@gmail.com

unread,
Jun 16, 2021, 11:08:54 PMJun 16
to Notecase Pro
Note:

I typed the actual error message in by hand, and I see (at least) one typo.  In the error message, it was lib.so, not libc.sl.

John

Miroslav Rajcic

unread,
Jun 18, 2021, 11:52:49 PMJun 18
to Notecase Pro
Hi John,

unfortunately, it can be very hard to detect and support correct build for this unknown ARM distro.
To illustrate, to support latest Raspberry Pi (64-bit) I've spent a lot of time with Qemu emulator without success, so ultimately only the real HW helped to create a build for it.

Regards,
Miro


From: noteca...@googlegroups.com <noteca...@googlegroups.com> on behalf of jcor...@gmail.com <jcor...@gmail.com>
Sent: Thursday, June 17, 2021 5:08 AM
To: Notecase Pro <noteca...@googlegroups.com>
Subject: Re: Build for Android Linux
 
--
You received this message because you are subscribed to the Google Groups "Notecase Pro" group.
To unsubscribe from this group and stop receiving emails from it, send an email to notecase-pro...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/notecase-pro/80e65efb-5403-4c3f-9365-646e1ee3e3afn%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages