Trouble Installing Connect on Ubuntu

41 views
Skip to first unread message

Daniel Davies

unread,
Aug 26, 2014, 12:19:10 AM8/26/14
to nonoli...@googlegroups.com
Hi Guys,
I've had a couple problems installing connect on my linux systems.
When I run the suggested commands
( sudo add-apt-repository ppa:nonolith/connect \ && sudo apt-get update \ && sudo apt-get install nonolith-connect nonolith-pixelpulse-launcher \ && sudo service udev restart )
I get the following error:

 More info: https://launchpad.net/~nonolith/+archive/ubuntu/connect
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmppdjkx4g2/secring.gpg' created
gpg: keyring `/tmp/tmppdjkx4g2/pubring.gpg' created
gpg: requesting key EA1BAE73 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmppdjkx4g2/trustdb.gpg: trustdb created
gpg: key EA1BAE73: public key "Launchpad PPA for Nonolith Labs" imported
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)
OK
Ign http://dl.google.com stable InRelease
Hit http://dl.google.com stable Release.gpg
Hit http://dl.google.com stable Release
Ign http://ppa.launchpad.net trusty InRelease
Ign http://archive.ubuntu.com trusty InRelease
Hit http://dl.google.com stable/main amd64 Packages
Ign http://archive.canonical.com trusty InRelease
Hit http://dl.google.com stable/main i386 Packages
Ign http://ppa.launchpad.net trusty Release.gpg
Ign http://archive.ubuntu.com trusty-updates InRelease
Hit http://archive.canonical.com trusty Release.gpg
Ign http://ppa.launchpad.net trusty Release
Ign http://archive.ubuntu.com trusty-security InRelease
Ign http://dl.google.com stable/main Translation-en
Hit http://archive.canonical.com trusty Release
Hit http://archive.ubuntu.com trusty Release.gpg
Hit http://archive.canonical.com trusty/partner amd64 Packages
Get:1 http://archive.ubuntu.com trusty-updates Release.gpg [933 B]
Hit http://archive.canonical.com trusty/partner i386 Packages
Get:2 http://archive.ubuntu.com trusty-security Release.gpg [933 B]
Hit http://archive.ubuntu.com trusty Release
Get:3 http://archive.ubuntu.com trusty-updates Release [59.7 kB]
Ign http://archive.canonical.com trusty/partner Translation-en
Get:4 http://archive.ubuntu.com trusty-security Release [59.7 kB]
Hit http://archive.ubuntu.com trusty/main Sources
Err http://ppa.launchpad.net trusty/main amd64 Packages
404 Not Found
Hit http://archive.ubuntu.com trusty/restricted Sources
Err http://ppa.launchpad.net trusty/main i386 Packages
404 Not Found
Hit http://archive.ubuntu.com trusty/universe Sources
Ign http://ppa.launchpad.net trusty/main Translation-en
Hit http://archive.ubuntu.com trusty/multiverse Sources
Hit http://archive.ubuntu.com trusty/main amd64 Packages
Hit http://archive.ubuntu.com trusty/restricted amd64 Packages
Hit http://archive.ubuntu.com trusty/universe amd64 Packages
Hit http://archive.ubuntu.com trusty/multiverse amd64 Packages
Hit http://archive.ubuntu.com trusty/main i386 Packages
Hit http://archive.ubuntu.com trusty/restricted i386 Packages
Hit http://archive.ubuntu.com trusty/universe i386 Packages
Hit http://archive.ubuntu.com trusty/multiverse i386 Packages
Hit http://archive.ubuntu.com trusty/main Translation-en
Hit http://archive.ubuntu.com trusty/multiverse Translation-en
Hit http://archive.ubuntu.com trusty/restricted Translation-en
Hit http://archive.ubuntu.com trusty/universe Translation-en
Get:5 http://archive.ubuntu.com trusty-updates/main Sources [110 kB]
Get:6 http://archive.ubuntu.com trusty-updates/restricted Sources [1408 B]
Get:7 http://archive.ubuntu.com trusty-updates/universe Sources [76.6 kB]
Get:8 http://archive.ubuntu.com trusty-updates/multiverse Sources [3230 B]
Get:9 http://archive.ubuntu.com trusty-updates/main amd64 Packages [297 kB]
Get:10 http://archive.ubuntu.com trusty-updates/restricted amd64 Packages [5820 B]
Get:11 http://archive.ubuntu.com trusty-updates/universe amd64 Packages [184 kB]
Get:12 http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages [8221 B]
Get:13 http://archive.ubuntu.com trusty-updates/main i386 Packages [293 kB]
Get:14 http://archive.ubuntu.com trusty-updates/restricted i386 Packages [5820 B]
Get:15 http://archive.ubuntu.com trusty-updates/universe i386 Packages [185 kB]
Get:16 http://archive.ubuntu.com trusty-updates/multiverse i386 Packages [8437 B]
Hit http://archive.ubuntu.com trusty-updates/main Translation-en
Hit http://archive.ubuntu.com trusty-updates/multiverse Translation-en
Hit http://archive.ubuntu.com trusty-updates/restricted Translation-en
Hit http://archive.ubuntu.com trusty-updates/universe Translation-en
Get:17 http://archive.ubuntu.com trusty-security/main Sources [41.3 kB]
Get:18 http://archive.ubuntu.com trusty-security/restricted Sources [14 B]
Get:19 http://archive.ubuntu.com trusty-security/universe Sources [11.3 kB]
Get:20 http://archive.ubuntu.com trusty-security/multiverse Sources [699 B]
Get:21 http://archive.ubuntu.com trusty-security/main amd64 Packages [132 kB]
Get:22 http://archive.ubuntu.com trusty-security/restricted amd64 Packages [14 B]
Get:23 http://archive.ubuntu.com trusty-security/universe amd64 Packages [46.7 kB]
Get:24 http://archive.ubuntu.com trusty-security/multiverse amd64 Packages [1154 B]
Get:25 http://archive.ubuntu.com trusty-security/main i386 Packages [128 kB]
Get:26 http://archive.ubuntu.com trusty-security/restricted i386 Packages [14 B]
Get:27 http://archive.ubuntu.com trusty-security/universe i386 Packages [46.7 kB]
Get:28 http://archive.ubuntu.com trusty-security/multiverse i386 Packages [1398 B]
Hit http://archive.ubuntu.com trusty-security/main Translation-en
Hit http://archive.ubuntu.com trusty-security/multiverse Translation-en
Hit http://archive.ubuntu.com trusty-security/restricted Translation-en
Hit http://archive.ubuntu.com trusty-security/universe Translation-en
Fetched 1708 kB in 8s (199 kB/s)
W: Failed to fetch http://ppa.launchpad.net/nonolith/connect/ubuntu/dists/trusty/main/binary-amd64/Packages 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/nonolith/connect/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.







I tried this on two computers running ubuntu 14.04..
When I tried to build from source I was unable to receiving the following error:

libusb/libusb/os/linux_usbfs.c:35:21: fatal error: libudev.h: No such file or directory
# include <libudev.h>

Before I spend more time trying to fix these issues I was wondering if anyone had encountered this before and had a fix for it?

Best,
Dan D

Kevin Mehall

unread,
Aug 26, 2014, 1:04:03 AM8/26/14
to nonoli...@googlegroups.com
Hi Dan,

To build from source, you'll need to `sudo apt-get install libboost-all-dev libudev-dev`. 

The first error is because the PPA hasn't been updated for 14.04.

-- Kevin


--
You received this message because you are subscribed to the Google Groups "Nonolith Labs CEE" group.
To unsubscribe from this group and stop receiving emails from it, send an email to nonolith-cee...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Daniel Davies

unread,
Aug 26, 2014, 1:15:05 PM8/26/14
to nonoli...@googlegroups.com
Thanks for the quick response. I encountered another error:


scons: Reading SConscript files ...
scons: done reading SConscript files.
scons: Building targets ...
g++ -o nonolith-connect -fstack-protector-all device.o event.o rest_service.o server.o url.o usb.o version.o websocket_service.o streaming_device/output_source.o streaming_device/rest_api.o streaming_device/stream_listener.o streaming_device/streaming_device.o streaming_device/ws_api.o cee/cee.o bootloader/bootloader.o -L. libusb_nonolith.a libwebsocketpp.a libjson.a -ludev -lpthread -lrt -lboost_system-mt -lboost_regex-mt -lboost_thread-mt
/usr/bin/ld: cannot find -lboost_system-mt
/usr/bin/ld: cannot find -lboost_regex-mt
/usr/bin/ld: cannot find -lboost_thread-mt

looking online this seems to be because the newer versions of the boost packages (obtained by sudo apt-get install libboost-all-dev) no longer support the -mt (multi thread). I tried to search through the connect repository to remove the -mt. I only found it in the SConstruct and removed it from there but still received the same error.

any ideas on what I could try next?
--
Daniel Davies
Mechanical and Aerospace Engineering
Princeton University '14

Daniel Davies

unread,
Aug 26, 2014, 5:02:59 PM8/26/14
to nonoli...@googlegroups.com
Solved that issue by adding a symlink to where the the libboost stuff was actually installed.

sudo ln -s /usr/lib/x86_64-linux-gnu/libboost_system{,-mt}.so
sudo ln -s /usr/lib/x86_64-linux-gnu/libboost_thread{,-mt}.so
sudo ln -s /usr/lib/x86_64-linux-gnu/libboost_regex{,-mt}.so

running scons i received the message:

user@chrubuntu:~/connect$ scons -j5

scons: Reading SConscript files ...
scons: done reading SConscript files.
scons: Building targets ...
scons: `.' is up to date.
scons: done building targets.

Going further through the README I found that I don't have a '/etc/init.d/nonolith-connect ' file or folder so am stuck again.
I will keep trying but further assistance would be greatly appreciated.

Thanks,

Dan D

Kevin Mehall

unread,
Aug 26, 2014, 5:28:24 PM8/26/14
to nonoli...@googlegroups.com
You can run `./nonolith-connect` to run the server from the build directory without installing it as a service. (This is actually how I use it). You do still need the udev rules installed to give your user account permission to access the device: put


SUBSYSTEM=="usb", ATTR{idVendor}=="59e3", ATTR{idProduct}=="cee1", MODE="0666"
SUBSYSTEM=="usb", ATTR{idVendor}=="59e3", ATTR{idProduct}=="bbbb", MODE="0666"
in /etc/udev/rules.d/60-nonolith-connect.rules, and `sudo udevadm control --reload-rules`

The `/etc/init.d/nonolith-connect` script installed by the package to start the server on boot comes from https://github.com/nonolith/connect/blob/master/debian/nonolith-connect.init, which expects the nonolith-connect executable to be installed to /usr/bin/nonolith-connect.

Commenting out the ` boostlibs = [i+'-mt' for i in boostlibs]` line seems to fix the `-mt` error for me. I can try to build an Ubuntu 14.04 package later this week, but hopefully running it from the build directory works as a temporary solution.

-- Kevin


Daniel Davies

unread,
Aug 26, 2014, 9:41:26 PM8/26/14
to nonoli...@googlegroups.com
Thanks! Everything seems to be working well. Will let you know if i need package but I should be ok.

Thanks for the quick replies and rapid help.

Dan D
Reply all
Reply to author
Forward
0 new messages