Where did the 0.10 development headers go?

96 views
Skip to first unread message

Nabeel S.

unread,
Mar 19, 2013, 12:12:04 PM3/19/13
to nod...@googlegroups.com
The make install did not install them. There's no mention of them being moved anywhere. node-gyp does not install them in any system directory, and the node-gyp configure and install do not find them either (though, a `find /` shows them in my home directory... ???). There are no notes on this anywhere. Also, no notes that the apt package has removed the npm package, and also the node-dev packages have been removed.

There's nothing in the migration guide about this. Nothing in the changelog, nothing in the C++ Modules section in the docs. Nothing on the node-gyp page or changelog. How are we supposed to find out about this basic information? This make me quite nervous as to what else has been omitted from the migration guide. I don't care if things have been changed about, but having to hunt down and figure out exactly what has changed, and where it's gone, is quite frustrating, and wasting everyone's time.

Can someone shed some insight?
Thanks

Ben Noordhuis

unread,
Mar 19, 2013, 12:27:39 PM3/19/13
to nod...@googlegroups.com
On Tue, Mar 19, 2013 at 5:12 PM, Nabeel S. <nsha...@gmail.com> wrote:
> The make install did not install them. There's no mention of them being
> moved anywhere. node-gyp does not install them in any system directory, and
> the node-gyp configure and install do not find them either (though, a `find
> /` shows them in my home directory... ???). There are no notes on this
> anywhere. Also, no notes that the apt package has removed the npm package,
> and also the node-dev packages have been removed.

The debian/ubuntu packages are not maintained by us.

> There's nothing in the migration guide about this. Nothing in the changelog,
> nothing in the C++ Modules section in the docs. Nothing on the node-gyp page
> or changelog. How are we supposed to find out about this basic information?

By reading the v0.8.0 release notes, that's when node-gyp was introduced.

Nabeel S.

unread,
Mar 19, 2013, 12:44:05 PM3/19/13
to nod...@googlegroups.com
Right, I've read through the release notes, and there's no mention of the development headers being removed from the make install (and I don't understand why)

I've been using node-gyp to build and compile. 0.8 installed the development headers in the proper system paths. node-gyp is not doing that, and none of the development headers are being found. I do the `sudo node-gyp install`, which is supposedly installing the headers, but... it's not. I'm checking this on a clean system, and it's not placing them.



--
--
Job Board: http://jobs.nodejs.org/
Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
You received this message because you are subscribed to the Google
Groups "nodejs" group.
To post to this group, send email to nod...@googlegroups.com
To unsubscribe from this group, send email to
nodejs+un...@googlegroups.com
For more options, visit this group at
http://groups.google.com/group/nodejs?hl=en?hl=en

---
You received this message because you are subscribed to a topic in the Google Groups "nodejs" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/nodejs/CCCgFSFGUiU/unsubscribe?hl=en.
To unsubscribe from this group and all its topics, send an email to nodejs+un...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.



Nathan Rajlich

unread,
Mar 20, 2013, 12:14:35 AM3/20/13
to nod...@googlegroups.com
Can you 1. delete your ~/.node-gyp directory, and then 2. gist the output of `npm install --verbose`?

Frankly, I've been getting a lot of strange error reports from people about the node-gyp header installation process not working correctly on v0.10.0, including myself :\ Hopefully I'll have some time to look into soon, it but it's a bug in node-core I'm afraid to admit.

You received this message because you are subscribed to the Google Groups "nodejs" group.
To unsubscribe from this group and stop receiving emails from it, send an email to nodejs+un...@googlegroups.com.

Nabeel S.

unread,
Mar 20, 2013, 12:33:55 AM3/20/13
to nod...@googlegroups.com
Sure can, thanks. I haven't been able to find out why the headers were also removed from the make install... that just seems like a strange decision to me, esp since other projects do that. For now, I just copied the headers manually into a local directory. Less than ideal, but need to get things going.


Let me know how I can help


Nathan Rajlich

unread,
Mar 21, 2013, 2:52:45 PM3/21/13
to nod...@googlegroups.com
I mean it looks like things worked normally in your gist. There's no errors happening...

FWIW, please try out v0.10.1 and see if it's more reliable.
Reply all
Reply to author
Forward
0 new messages