Filters not working

68 views
Skip to first unread message

David Foster

unread,
Jul 26, 2020, 9:10:31 PM7/26/20
to ngx-pagespeed-discuss
I've compiled NGINX with Pagespeed and have it running on my server, and I when I run curl on my webpage I see the Pagespeed headers, but none of the filters I've set on my server work.

Following along the FAQ I run the command curl -D- 'http://example.com?ModPagespeed=on&ModPagespeedFilters=collapse_whitespace' | less but the outpage from my page is not trimming whitespaces like it should.

I'm able to log into the admin panel and in /config I see the filters in place in the attached screenshot.

Annotation 2020-07-26 200844.png

Longinos

unread,
Jul 27, 2020, 10:16:25 AM7/27/20
to ngx-pagespeed-discuss


To enable/disable filters must be preceded by the +/- sing.
you can use ?ModPagespeed=on&ModPageSpeedFilters=+debug and take a look at the html code.
I don´t know id collpse_whitespace runs in the url as parameter, not all filters work here.

David Foster

unread,
Jul 28, 2020, 6:17:04 PM7/28/20
to ngx-pagespeed-discuss
I'm able to use other filters as you suggested, like remove_comments, as a querystring and I see the result in the HTML. collapse_whitespace for some reason does not work, even though it's described in the FAQ.

The rewrite_images filter, which is the one I'm most interested in using, does not work as a querystring. At least, when I try running Chrome's Lighthouse tool on mysite.com/?ModPagespeed=on&ModPagespeedFilters=rewrite_images I see no noticeable difference in image load times.

Otto van der Schaaf

unread,
Jul 28, 2020, 6:23:01 PM7/28/20
to ngx-pagesp...@googlegroups.com
You might have to retry a couple of times with insights, because the module may respond with intermediate results initially. It might take some time to settle on fully optimized output - per user agent.

Otto

--
You received this message because you are subscribed to the Google Groups "ngx-pagespeed-discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ngx-pagespeed-di...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ngx-pagespeed-discuss/0317d7b4-a10c-41ca-bb1d-403421eb8a1fo%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages