motus version issues

12 views
Skip to first unread message

Yu-Jen Chang

unread,
Oct 16, 2021, 2:51:40 AM10/16/21
to ngl...@googlegroups.com
Dear Luis,
I used your refined script to run ngless, but got a weird error.

the header: local import "motus" version "2.5"
seems to be the casual factor to show this warning below:

I spent some time to read the language and rules of your tool, and didn't find a good solution.
hope you can understand and help me.

and tried to remove the "local" in the beginning of this command, but still failed.

All the best,
Yu-Jen
image.png

Luis Pedro Coelho

unread,
Oct 17, 2021, 10:08:59 AM10/17/21
to Yu-Jen Chang, NGLess List
Dear Yu-Jen et al.

This is arguably (as the issue you point out says) a usability bug in that we had an internal module named "motus" and then later, switched it to be an external module (which must be installed differently and imported with "local import").

The example script at https://github.com/ngless-toolkit/ngless-contrib/tree/master/motus.ngm should work after you have downloaded that directory to your local computer. You need to do this manually (this is what it means for motus to now be an external as opposed to an internal module).

Best
Luis

Luis Pedro Coelho | Fudan University | http://luispedro.org
--
You received this message because you are subscribed to the Google Groups "NGLess" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ngless+un...@googlegroups.com.


Attachments:
  • image.png

Yu-Jen Chang

unread,
Oct 17, 2021, 9:52:45 PM10/17/21
to ngl...@googlegroups.com
Dear Luis,
I found that the linkage ( https://github.com/motu-tool/mOTUs_v2/archive/ 2.5.0.tar.gz  ) was out of use, same as 2.1.0.
I only could find 3.0.1 in [ https://github.com/motu-tool/mOTUs ], and failed to install 2.5.0.
I think that you might update the motus version with your shell script.

Best regard,
Yu-Jen

ullo...@googlemail.com

unread,
Oct 18, 2021, 6:32:29 AM10/18/21
to NGLess
Dear Luis,
since now there is a motus version 3 (I wasn't even aware of it), would you be willing to provide the 3.0.1.ngm ?

Yours sincerely,
Ulrike

Luis Pedro Coelho

unread,
Oct 22, 2021, 11:48:43 AM10/22/21
to Ulrike Löber, NGLess List
I was also not aware of motus 3 until your email :)

I think this does go on our TODO list, though

Best
Luis 

Luis Pedro Coelho | Fudan University | http://luispedro.org


--
You received this message because you are subscribed to the Google Groups "NGLess" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ngless+un...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages