Latest version

Skip to first unread message

Antoine D

Aug 1, 2023, 10:09:15 AM8/1/23
to NetLogoR users

I tried to download the package using "install.packages("NetLogoR")". It says
" package ‘NetLogoR’ is not available for this version of R".

I also tried "install_version("NetLogoR", "0.3.11")", but it also generates errors (below).

Any suggestion on how to use it ? (sorry I am not an expert in R packages). 

Thank you !!!


Downloading package from url:
* installing *source* package ‘NetLogoR’ ...
** package ‘NetLogoR’ successfully unpacked and MD5 sums checked
** using staged installation
** R
** inst
** byte-compile and prepare package for lazy loading
Error: class ".quickPlottables" is not exported by 'namespace:quickPlot'
Execution halted
ERROR: lazy loading failed for package ‘NetLogoR’
* removing ‘/Library/Frameworks/R.framework/Versions/4.2/Resources/library/NetLogoR’
Warning message:
In i.p(...) :
  installation of package ‘/var/folders/0d/wfwb0lvn2rs8cp9kv77syp2w0000gr/T//RtmpgtqBvk/remotesad7b490f0e36/NetLogoR’ had non-zero exit status 

Alex Chubaty

Aug 1, 2023, 10:51:42 PM8/1/23
to NetLogoR users
We will be submitting a fixed version to CRAN as soon as possible - in the mean time you can install from GitHub or from our r-universe repo:

## from GitHub (source install)

## from r-universe (binaries available)
install.packages("NetLogoR", repos = c("", getOption("repos")))
Reply all
Reply to author
0 new messages