Bug in uumail V 3.0 `opath' or `getpath'?

10 views
Skip to first unread message

Greg Earle

unread,
Oct 24, 1986, 12:17:48 AM10/24/86
to
I'm having trouble with uumail munging addresses which consist of a site(s)
which is not in the UUCP map connected to one that is; i.e. a path to it
would look like
mysite!foo!bar!...!a!b![c!d!]spudbrain
where `a' is a known site, with an optimized path available; and `b' (and
every succeeding site, all unknown to the UUCP map) is not known to the
UUCP map. Every time I try to mail in this situation, `Getpath' returns
the valid path to the last known site (OK here) `a', but `Opath' returns
just `spudbrain' attached to Getpath's path-to-`a', thus I end up with
all mail in these circumstances headed for us...@last-known-mapsite.UUCP.

Here's some relevant data:
- Running uumail with sendmail, on Sun OS 2.2.
- sendmail.cf entry for uumail:
># use fancy path expanding UUCP frontend.
>Muucp, P=/usr/lib/mail/uumail, F=sCDFMSU, S=13, R=23, M=65535,
> A=uumail -h -oc -f$g $h!$u
[So `$u' is getting munged.]

Here's a sample session, with `-d6' installed to prevent real delivery:
# mail -v cogent!sl...@ptsfa.UUCP
~s Test of uumail bug
Test; ignore
EOT
cogent!sl...@ptsfa.UUCP... Connecting to ptsfa.uucp...
Version $Header: uumail.c,v 3.0 86/03/14 12:05:00 sob RELEASE_3 $
Mail from smeagol!root
Temp file is /tmp/.uum019168
In getpath: Sysname = cogent, Pathfile = /usr/lib/mail/uucp.hosts /* getpath#1
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Starting uuname
Neighbor # 1: udon'tcare
Neighbor # 2: etc. etc.
In getpath: Sysname = ptsfa, Pathfile = /usr/lib/mail/uucp.hosts /* Why here */
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ /* twice? */
Getpath returns: elroy!cit-vax!topaz!nike!ptsfa
Opath returns elroy!cit-vax!topaz!nike!ptsfa!slime /* WHOOPS! where's */
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ /* `cogent' gone?? */
Path = elroy!cit-vax!topaz!nike!ptsfa!slime
p = elroy!cit-vax!topaz!nike!ptsfa!slime local = 0
p = cit-vax!topaz!nike!ptsfa!slime sys = elroy fname =
elroy!cit-vax!topaz!nike!ptsfa!slime
Command is /usr/bin/uux - -r -gC elroy!rmail
\(cit-vax!topaz!nike!ptsfa!slime\)
cogent!sl...@ptsfa.UUCP... Sent

(End of sample session; in case you're wondering, `mail -v ptsfa!cogent!slime'
gives exact same result)

- my OPTIONS line in uumail's Makefile:
>OPTIONS= -DOPATH -DGETHOSTNAME -DNOALIAS -DLOG -DDBM -DDEBUG -DRFC976 -DOPTIMIZE

---------------------
I tried to mail to Stan Barber about this, but got no response.

Hasn't anyone else been bitten by this? I'd like to assume it's a problem
somewhere in my configuration, but I can't find it anywhere ...

--

Greg Earle UUCP: sdcrdcf!smeagol!earle; attmail!earle
JPL ARPA: elroy!smeagol!ea...@csvax.caltech.edu
smeagol!ea...@usc-oberon.usc.edu
AT&T: +1 818 354 0876

Yow! Did something bad happen or am I in a drive-in movie??

Reply all
Reply to author
Forward
0 new messages