Nemo output not formatted properly in Jupyter / IJulia

Skip to first unread message

Mao Zeng

Mar 15, 2021, 7:00:40 AM3/15/21
to nemo-devel
If I run the following code

using Nemo
Ring, (x,y) = PolynomialRing(ZZ, ["x", "y"])

in the shell terminal, the output is simply "x//y". But if I run it in the Jupyter notebook, I get a raw LaTeX string "\frac{x}{y}" that is not rendered as an actual math formula.

Is it possible to force Jupyter to behave like the terminal instead, and simply show me "x//y" by default? It would also be useful to fix the LaTeX rendering (when I use SymPy.jl in Jupyter, I get nice displayed math), though for larger expression I would prefer not to have the LaTeX rendering overhead.

Bill Hart

Mar 16, 2021, 4:09:27 AM3/16/21
to Mao Zeng, nemo-devel
Can you open a new issue on the official GitHub account of the Nemo
project [1] so that this issue gets more attention.



> --
> You received this message because you are subscribed to the Google Groups "nemo-devel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to
> To view this discussion on the web, visit

Mar 16, 2021, 6:01:53 AM3/16/21
to nemo-devel
Reply all
Reply to author
0 new messages