Unsupported session type: unix-xdm

Skip to first unread message


Apr 10, 2011, 1:47:41 PM4/10/11
to ne...@googlegroups.com
I've been struggling to get neatx working. I installed neatx on an
openvz debian (lenny) container, using this page as a guide:

I then installed gnome. Apparently that was a bad choice for an
OpenVZ container. Gnome is a beast. I'm not sure that gnome ever got
installed well enough among the errors.

So I installed something more lightweight: xdm and xfce4. Now when I
try to connect, I can connect and authenticate okay, but the error
"Unsupported session type: unix-xdm" stops the show. This is the
detailed output:

NX> 203 NXSSH running with pid: 5642
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: x.x.x.x on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 3.3.0 - GPL
NX> 105 Hello nxclient - version 3.3.0
NX> 134 Accepted protocol: 3.3.0
NX> 105 Login
NX> 101 User: eddie
NX> 102 Password: *****
NX> 103 Welcome to: stampede user: eddie
NX> 105 Listsession --user="eddie" --status="suspended,running" --geometry="1440x900x24+render" --type="unix-xdm"
NX> 127 Session list of user 'eddie':
Display Type Session ID Options Depth Screen Status Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------

NX> 148 Server capacity: not reached for user: eddie
NX> 105 Start session with: --xdm_type="list" --xdm_host="localhost" --xdm_port="177" --link="wan" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --shmem="1" --shpix="1" --strict="0" --composite="1" --media="0" --session="fl-eddie" --type="unix-xdm" --geometry="1440x900" --client="linux" --keyboard="pc102/us" --screeninfo="1440x900x24+render"
NX> 500 Unsupported session type: unix-xdm
NX> 999 Bye.
NX> 280 Exiting on signal: 15

Any ideas?


Apr 11, 2011, 2:18:47 PM4/11/11
to neatx
Try setting session gnome in the client, XDM does not seem to be

On Apr 10, 12:47 pm, cognitive.libertarian...@gmail.com wrote:
> I've been struggling to get neatx working.  I installed neatx on an
> openvz debian (lenny) container, using this page as a guide:http://blog.mc-thias.org/?title=neatx-on-linux-mint-debian&more=1&c=1...


Apr 12, 2011, 2:45:57 PM4/12/11
to neatx
* mrajbrown <mraj...@gmail.com> [2011-04-11 20:47]:

> Try setting session gnome in the client, XDM does not seem to be
> running.

Thanks for the suggestion, but I have already tried that. It was the
first thing I tried after installing gnome. Gnome has a different
problem.. it times out. I'm not sure if it's because my gnome
installation was very rough and never completed successfully, or if
it's because gnome is too heavy for my connection.

I switched to xdm and xfce4 because they seemed to be more lean and

Janusz Syrytczyk

Apr 18, 2011, 8:11:09 AM4/18/11
to ne...@googlegroups.com
2011/4/12 <cognitive.li...@gmail.com>:

LXDE is what works very well. I have an appliance with 2 openvz
containers with "deduplication" (ro mounts squashed on squsqfs placed
on flash device). Containers have LXDE, Firefox, Flash and Java
plugins as well as some more general networking tools.

Both have also neatx installed and works very well since January 20,
2010. I'm using one of them daily. The only thing I had to tweak with
neatx was to put a script to delete sessions on startup.

If you read Polish by any chance, I can deliver quite nice documentation.

Reply all
Reply to author
0 new messages