NaCl not working on Cr-48 ChromeOS

Skip to first unread message


Aug 22, 2011, 10:34:24 AM8/22/11
to Native-Client-Discuss

I am the proud recipient of Cr-48 since December 2010. As an
accomplished developer, please try to imagine my profound
disappointment when I cannot get the NaCl to work on this happy
platform. I have tried various things to "make it go".

I am using Beta channel chromeOS:
Google Chrome 14.0.835.98
Platform 811.47 (Official Build) dev-channel x86-mario
Firmware Mario.03.60.1120.0038G5.0018d

Yes, I have turned-"ON" the "About:flags" => [Native Client / Enable
support for Native Client. / Disable] // reboot.

Yes, I have even tried the "dev-channel" with chrome-15, but I am now
back to 14.

But, when I go to the NaCl-sdk's Examples-page, [http://nacl-] it asserts the sad message:
WARNING: Native Client is not enabled in Google Chrome. To enable
Native Client, type about:flags in the address bar, scroll down to
"Native Client," and click the "Enable" link. Then scroll down to the
bottom of the page and click the "Relaunch Now" button (all browser
windows will restart when you relaunch Chrome). If the examples still
do not work, type about:plugins in the address bar and make sure that
"Native Client" is enabled. For additional information see running
Native Client applications.

None of my own NaCl test apps will operate either.

Since I have NOT found much interest in trying NaCl on Chrome laptops,
I hereby assert my own story for all to see, and to inspire comments
and stories of their own.... Anybody out there?

David Michael

Aug 22, 2011, 11:13:18 AM8/22/11
Sorry, ChromeOS does not currently support NaCl. We intend to add support 'soon' (for some unspecified value of soon).

You received this message because you are subscribed to the Google Groups "Native-Client-Discuss" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at


Aug 22, 2011, 12:01:41 PM8/22/11
to Native-Client-Discuss
Great! There is a nearly instantaneous responses on this issue. I just
received an email from someone (name hidden: k*** who
wrote to me:


As you can see the bug is closed. NaCl works with ToT ChromeOS, but
I'm not sure when fix will reach dev channel...

This looks to me like this unfortunate status shall remain for a
It looks like a non-trivial architectural change shall have to
be implemented in order to facilitate a reliable functional
sandbox environment to support NaCl. There are some experimental
hacks which establish that it will be possible to enable ChromeOS
to run native app's.

Still there may be a way to do this...

Ivan Krasin

Aug 22, 2011, 12:48:03 PM8/22/11
Hi Jonovos, was about
inability of Chrome OS to run NaCl modules because of the security
feature of Chrome OS: /dev/shm is not executable.
This issue has been recently fixed by introducing a new kernel functionality.

Now, Chrome OS should include NaCl plugin into the distribution again.
It would take some time that is hard to predict.

In short,

1. Chrome OS will receive NaCl support 'soon'. 'Soon' is undefined
2. It's possible to build a custom build of Chrome OS with NaCl
support (but it's rather hard)


Brad Chen

Aug 22, 2011, 2:29:13 PM8/22/11
There are a couple other outstanding issues, relating to ATOM performance, and address space fragmentation on 32-bit Linux. Work is underway for both of these so hopefully they will be resolved soon.

Reply all
Reply to author
0 new messages