Django Version

85 views
Skip to first unread message

Jeremy Finke

unread,
May 27, 2015, 3:39:05 PM5/27/15
to munki-w...@googlegroups.com
As Django 1.5.1 is unsupported and has security issues, has anyone tried using MWA with the newer versions of Django?

I know that there was a dependence on 1.5.1 for a while, but I was not sure if that was still true or not.

Thanks!

Matt Childress

unread,
May 28, 2015, 11:58:57 AM5/28/15
to munki-w...@googlegroups.com
The django-admin.py in the munkiwebadmin (Steven Kueng's version of the interface) is reporting django 1.7.2 ...

From https://www.djangoproject.com/download/ the current versions of Django for the 1.7 series is 1.7.8, so SKMWA is also out of date, and 1.7 LTS went out of mainstream support in April (anticipated end of security/data-loss bug support in October 2015 when 1.9 comes out)

So it looks like 1.8.2 is the one to start playing with, as it is currently released and the LTS for security/data-loss bugs is April of 2018

But I'm far from knowing anything about Django... so if anyone else chimes in that knows more...

M@

Jeremy Finke

unread,
May 29, 2015, 12:43:40 PM5/29/15
to munki-w...@googlegroups.com
Thanks for the pointers, Matt!  I may have to upgrade / sidegrade to Steven's version.  I had seen that he had gone further than MWA.  I just remember there was a big deal with staying at django 1.5.1 when I set everything up originally.
Reply all
Reply to author
Forward
0 new messages