Videos autoplaying when previewed

9 views
Skip to first unread message

Cruz, Jaime

unread,
Mar 8, 2021, 9:45:45 AMMar 8
to mozilla-suppo...@lists.mozilla.org
Okay, this is just plain OBNOXIOUS. Just got an E-Mail from Norwegian
Cruise Lines that contained an embedded video, and as soon as the
preview window loaded it started to play. This is annoying at home but
it will be especially vile in an office cubicle environment. I looked
for an option to turn off "Auto Play" in "Preferences" but I couldn't
find anything. Is there a hidden option somewhere that I can disable
this nonsense??

--
Jaime A. Cruz

Nassau Wings Motorcycle Club
http://www.nassauwings.org/

AMA District 34
https://www.amad34.org/

Sjouke Burry

unread,
Mar 8, 2021, 9:56:24 AMMar 8
to mozilla-suppo...@lists.mozilla.org
On 08.03.21 15:45, Cruz, Jaime wrote:
> Okay, this is just plain OBNOXIOUS. Just got an E-Mail from Norwegian
> Cruise Lines that contained an embedded video, and as soon as the
> preview window loaded it started to play. This is annoying at home but
> it will be especially vile in an office cubicle environment. I looked
> for an option to turn off "Auto Play" in "Preferences" but I couldn't
> find anything. Is there a hidden option somewhere that I can disable
> this nonsense??
>
Dont use html viewing?

Nobody

unread,
Mar 8, 2021, 11:20:57 AMMar 8
to mozilla-suppo...@lists.mozilla.org
On Mon, 8 Mar 2021 09:45:34 -0500, "Cruz, Jaime" <Spam...@Bite.Me>
wrote:

>Okay, this is just plain OBNOXIOUS. Just got an E-Mail from Norwegian
>Cruise Lines that contained an embedded video, and as soon as the
>preview window loaded it started to play. This is annoying at home but
>it will be especially vile in an office cubicle environment. I looked
>for an option to turn off "Auto Play" in "Preferences" but I couldn't
>find anything. Is there a hidden option somewhere that I can disable
>this nonsense??

What version of TB?

Win 10 TB 78.8.0 and it doesn't happen for me.

Tools = Options = General = scroll w-a-y down to about:config. Say
pretty please... and search on 'autoplay'.

For me, 'media.autoplay.enabled' is set by default as 'false'.

Cruz, Jaime

unread,
Mar 8, 2021, 1:28:21 PMMar 8
to mozilla-suppo...@lists.mozilla.org
I have the same version of Thunderbird on Linux. When I select "Tools,"
however, I do not see an "Options" selection... I see "Developer
Options" but there is no "General" selection there.

Wolf K

unread,
Mar 8, 2021, 1:35:48 PMMar 8
to mozilla-suppo...@lists.mozilla.org
On 2021-03-08 09:45, Cruz, Jaime wrote:
> Okay, this is just plain OBNOXIOUS.  Just got an E-Mail from Norwegian
> Cruise Lines that contained an embedded video, and as soon as the
> preview window loaded it started to play.  This is annoying at home but
> it will be especially vile in an office cubicle environment.  I looked
> for an option to turn off "Auto Play" in "Preferences" but I couldn't
> find anything.  Is there a hidden option somewhere that I can disable
> this nonsense??
>

Tools - Options - Advanced - Config Editor - search for autoplay.

The default setting allow autoplay.

--
Wolf K
"You know, doing what is right is easy. The problem is knowing what is
right." Lyndon B. Johnson

😉 Good Guy 😉

unread,
Mar 8, 2021, 1:36:06 PMMar 8
to mozilla-suppo...@lists.mozilla.org
On 08/03/2021 14:45, Cruz, Jaime wrote:
Okay, this is just plain OBNOXIOUS.  Just got an E-Mail from Norwegian Cruise Lines that contained an embedded video, and as soon as the preview window loaded it started to play.  This is annoying at home but it will be especially vile in an office cubicle environment.  I looked for an option to turn off "Auto Play" in "Preferences" but I couldn't find anything.  Is there a hidden option somewhere that I can disable this nonsense??

Try settings button in this picture and make sure you have the default set to block audio and video.

[ Block media ]
--

With over 1.2 billion devices now running Windows 10, customer satisfaction is higher than any previous version of windows.

John Weiss

unread,
Mar 8, 2021, 1:37:17 PMMar 8
to mozilla-suppo...@lists.mozilla.org
On 03/08/21 10:28, Cruz, Jaime wrote:
>>
>> Tools = Options = General = scroll w-a-y down to about:config.  Say
>> pretty please... and search on 'autoplay'.
>>
>> For me, 'media.autoplay.enabled' is set by default as 'false'.
>>
> I have the same version of Thunderbird on Linux.  When I select "Tools,"
> however, I do not see an "Options" selection...  I see "Developer
> Options" but there is no "General" selection there.

In my v78 for Win, "Options" is 3 lines below "Developer Tools" in the
Tools menu.

"\"Re...@home.com

unread,
Mar 8, 2021, 1:57:40 PMMar 8
to mozilla-suppo...@lists.mozilla.org
On my Mac (OP has Linux) it's at Preferences > Advanced > Config Editor
(at bottom right of panel)

Cruz, Jaime

unread,
Mar 8, 2021, 3:10:51 PMMar 8
to mozilla-suppo...@lists.mozilla.org
Okay, found it... and media.autoplay.enabled was set to "False"

I also see:
dom.media.autoplay.autoplay-policy-api --> false
media.autoplay.allow-extentionbackground -- true
media.autoplay.block-event.enabled --> false
media.autoplay.block-webaudio --> true (changed from false)
media.autoplay.blocking_policy --> integer 0
media.autoplay.default --> integer 0
media.autoplay.enabled --> false

Chris Ramsden

unread,
Mar 8, 2021, 3:18:26 PMMar 8
to mozilla-suppo...@lists.mozilla.org
On Mon, 2021-03-08 at 13:28 -0500, Cruz, Jaime wrote:

> > >
> > I have the same version of Thunderbird on Linux. When I select "Tools,"
> > however, I do not see an "Options" selection... I see "Developer
> > Options" but there is no "General" selection there.
> >
>

Try Edit|Preferences

http://kb.mozillazine.org/Menu_differences

--
Chris

Millwood

unread,
Mar 8, 2021, 3:37:10 PMMar 8
to mozilla-suppo...@lists.mozilla.org
For what it's worth my Firefox settings are:

dom.media.autoplay.autoplay-policy-api false
media.autoplay.allow-extension-background-pages false
media.autoplay.block-event.enabled true
media.autoplay.block-webaudio true
media.autoplay.blocking_policy 0
media.autoplay.default 5
media.autoplay.enabled false
services.sync.prefs.sync.media.autoplay.default true

WaltS48

unread,
Mar 8, 2021, 3:41:26 PMMar 8
to mozilla-suppo...@lists.mozilla.org
On 3/8/21 1:00 PM, 😉 Good Guy 😉 wrote:
> On 08/03/2021 14:45, Cruz, Jaime wrote:
>> Okay, this is just plain OBNOXIOUS.  Just got an E-Mail from
>> Norwegian Cruise Lines that contained an embedded video, and as soon
>> as the preview window loaded it started to play.  This is annoying at
>> home but it will be especially vile in an office cubicle
>> environment.  I looked for an option to turn off "Auto Play" in
>> "Preferences" but I couldn't find anything.  Is there a hidden option
>> somewhere that I can disable this nonsense??
>>
> Try settings button in this picture and make sure you have the default
> set to block audio and video.
>
> [ Block media ] <https://i.imgur.com/otGZM3s.png>
>
Doesn't look like any Thunderbird preferences I've used.

--
OS: Fedora 33 Workstation - Gnome Desktop
https://www.thunderbird.net/en-US/get-involved/


😉 Good Guy 😉

unread,
Mar 8, 2021, 4:14:25 PMMar 8
to mozilla-suppo...@lists.mozilla.org
On 08/03/2021 20:41, WaltS48 wrote:
On 3/8/21 1:00 PM, 😉 Good Guy 😉 wrote:
On 08/03/2021 14:45, Cruz, Jaime wrote:
Okay, this is just plain OBNOXIOUS.  Just got an E-Mail from Norwegian Cruise Lines that contained an embedded video, and as soon as the preview window loaded it started to play.  This is annoying at home but it will be especially vile in an office cubicle environment.  I looked for an option to turn off "Auto Play" in "Preferences" but I couldn't find anything.  Is there a hidden option somewhere that I can disable this nonsense??

Try settings button in this picture and make sure you have the default set to block audio and video.

[ Block media ] <https://i.imgur.com/otGZM3s.png>

Doesn't look like any Thunderbird preferences I've used.

I assumed he was asking about FF but it looks like you may be right.  The image is from FF

I don't have TB playing videos so what am I missing?  Do you get TB playing videos?

BillH

unread,
Mar 8, 2021, 4:14:40 PMMar 8
to mozilla-suppo...@lists.mozilla.org
On 3/8/2021 12:41 PM, WaltS48 wrote:
> On 3/8/21 1:00 PM, 😉 Good Guy 😉 wrote:
>> On 08/03/2021 14:45, Cruz, Jaime wrote:
>>> Okay, this is just plain OBNOXIOUS.  Just got an E-Mail from
>>> Norwegian Cruise Lines that contained an embedded video, and as soon
>>> as the preview window loaded it started to play.  This is annoying at
>>> home but it will be especially vile in an office cubicle
>>> environment.  I looked for an option to turn off "Auto Play" in
>>> "Preferences" but I couldn't find anything.  Is there a hidden option
>>> somewhere that I can disable this nonsense??
>>>
>> Try settings button in this picture and make sure you have the default
>> set to block audio and video.
>>
>> [ Block media ] <https://i.imgur.com/otGZM3s.png>
>>
> Doesn't look like any Thunderbird preferences I've used.
>

These look like Firefox settings, not Thunderbird settings.

Bill

--
If you want to send me an email, you must remove "NOSPAM" from my email
address before replying.

Frank-Rainer Grahl

unread,
Mar 8, 2021, 5:35:53 PMMar 8
to mozilla-suppo...@lists.mozilla.org
WaltS48 wrote:
> On 3/8/21 1:00 PM, 😉 Good Guy 😉 wrote:
>> On 08/03/2021 14:45, Cruz, Jaime wrote:
>>> Okay, this is just plain OBNOXIOUS.  Just got an E-Mail from Norwegian
>>> Cruise Lines that contained an embedded video, and as soon as the preview
>>> window loaded it started to play.  This is annoying at home but it will be
>>> especially vile in an office cubicle environment.  I looked for an option
>>> to turn off "Auto Play" in "Preferences" but I couldn't find anything.  Is
>>> there a hidden option somewhere that I can disable this nonsense??
>>>
>> Try settings button in this picture and make sure you have the default set
>> to block audio and video.
>>
>> [ Block media ] <https://i.imgur.com/otGZM3s.png>
>>
> Doesn't look like any Thunderbird preferences I've used.
>

media.autoplay.enabled is gone from later releases. I think there was no
direct replacement but can be wrong.
Still set here but dead code.
https://searchfox.org/comm-esr78/source/mail/app/profile/all-thunderbird.js#566


FRG

WaltS48

unread,
Mar 8, 2021, 6:00:33 PMMar 8
to mozilla-suppo...@lists.mozilla.org
On 3/8/21 4:14 PM, 😉 Good Guy 😉 wrote:
> On 08/03/2021 20:41, WaltS48 wrote:
>> On 3/8/21 1:00 PM, 😉 Good Guy 😉 wrote:
>>> On 08/03/2021 14:45, Cruz, Jaime wrote:
>>>> Okay, this is just plain OBNOXIOUS. Just got an E-Mail from
>>>> Norwegian Cruise Lines that contained an embedded video, and as
>>>> soon as the preview window loaded it started to play.  This is
>>>> annoying at home but it will be especially vile in an office
>>>> cubicle environment.  I looked for an option to turn off "Auto
>>>> Play" in "Preferences" but I couldn't find anything.  Is there a
>>>> hidden option somewhere that I can disable this nonsense??
>>>>
>>> Try settings button in this picture and make sure you have the
>>> default set to block audio and video.
>>>
>>> [ Block media ] <https://i.imgur.com/otGZM3s.png>
>>>
>> Doesn't look like any Thunderbird preferences I've used.
>>
> I assumed he was asking about FF but it looks like you may be right. 
> The image is from FF
>
> I don't have TB playing videos so what am I missing?  Do you get TB
> playing videos?
>
>
I would be happy to try with the offending email from Norwegian Cruise
Lines, but I never get any from them.

Cruz, Jaime

unread,
Mar 8, 2021, 6:09:54 PMMar 8
to mozilla-suppo...@lists.mozilla.org
I would be happy to forward it to you if you provided a valid E-Mail
address for me to send it to...

Nobody

unread,
Mar 8, 2021, 7:20:38 PMMar 8
to mozilla-suppo...@lists.mozilla.org
On Mon, 8 Mar 2021 18:00:26 +0000, ? Good Guy ? <Hello...@aim.com>
wrote:

>On 08/03/2021 14:45, Cruz, Jaime wrote:
>> Okay, this is just plain OBNOXIOUS.  Just got an E-Mail from Norwegian
>> Cruise Lines that contained an embedded video, and as soon as the
>> preview window loaded it started to play.  This is annoying at home
>> but it will be especially vile in an office cubicle environment.  I
>> looked for an option to turn off "Auto Play" in "Preferences" but I
>> couldn't find anything.  Is there a hidden option somewhere that I can
>> disable this nonsense??
>>
>Try settings button in this picture and make sure you have the default
>set to block audio and video.
>
>[ Block media ] <https://i.imgur.com/otGZM3s.png>


Huh? In what operating system/TB version do you have to generate that
pitcher?

I "think" you'll find those are the settings/controls for FIREFOX, not
TB.

Nobody

unread,
Mar 8, 2021, 7:28:05 PMMar 8
to mozilla-suppo...@lists.mozilla.org
On Mon, 8 Mar 2021 13:28:10 -0500, "Cruz, Jaime" <Spam...@Bite.Me>
wrote:

>On 3/8/21 11:20 AM, Nobody wrote:
>> On Mon, 8 Mar 2021 09:45:34 -0500, "Cruz, Jaime" <Spam...@Bite.Me>
>> wrote:
>>
>>> Okay, this is just plain OBNOXIOUS. Just got an E-Mail from Norwegian
>>> Cruise Lines that contained an embedded video, and as soon as the
>>> preview window loaded it started to play. This is annoying at home but
>>> it will be especially vile in an office cubicle environment. I looked
>>> for an option to turn off "Auto Play" in "Preferences" but I couldn't
>>> find anything. Is there a hidden option somewhere that I can disable
>>> this nonsense??
>>
>> What version of TB?
>>
>> Win 10 TB 78.8.0 and it doesn't happen for me.
>>
>> Tools = Options = General = scroll w-a-y down to about:config. Say
>> pretty please... and search on 'autoplay'.
>>
>> For me, 'media.autoplay.enabled' is set by default as 'false'.
>>
>I have the same version of Thunderbird on Linux. When I select "Tools,"
>however, I do not see an "Options" selection... I see "Developer
>Options" but there is no "General" selection there.

<mumble><mumble> Which is why I've lurned to identify my opsys...

Cruz, Jaime

unread,
Mar 10, 2021, 12:03:35 PMMar 10
to mozilla-suppo...@lists.mozilla.org
Figured you guys were sharp enough to check my message headers...

Reply all
Reply to author
Forward
0 new messages