Please support mozplugger!

31 views
Skip to first unread message

Que Quotion

unread,
Mar 26, 2017, 5:14:18 AM3/26/17
to dev-tech...@lists.mozilla.org
Just yesterday I finally figured out what was wrong with MIDI playback
in mozplugger:
https://www.mozdev.org/bugs/show_bug.cgi?id=26355

Then an upgrade today strips the whole plugin out?!!?!?!

Unless firefox is going to support MIDI naively, we need plugin support for it.

I know it's niche but it is important to some of us to have this.

Benjamin Smedberg

unread,
Mar 27, 2017, 12:58:27 PM3/27/17
to Que Quotion, dev-tech...@lists.mozilla.org
Removal of plugin support was announced in 2015
https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
- this is not a decision that we are going to reverse.

I encourage you to work on having MIDI support via a Firefox addon. There
are two opportunities here:
1. Ship the MIDI support via a native binary and use native messaging to
communicate (can be done today)
2. Ship a MIDI API via webextensions in the browser itself (would require
core Firefox hacking)

I recommend starting with #1 and gradually moving towards #2 if the
webextensions team agrees that this is a valuable API surface.

--BDS
> _______________________________________________
> dev-tech-plugins mailing list
> dev-tech...@lists.mozilla.org
> https://lists.mozilla.org/listinfo/dev-tech-plugins
>
Reply all
Reply to author
Forward
0 new messages