Google Groups no longer supports new Usenet posts or subscriptions. Historical content remains viewable.
Dismiss

Discussion: "Allow Now" or "Allow For Now"?

21 views
Skip to first unread message

Selim Şumlu

unread,
Apr 20, 2014, 9:02:23 AM4/20/14
to
When activating a plugin, there are two strings that affect the outcome:
<!ENTITY pluginActivateNow.label "Allow Now">
<!ENTITY pluginActivateAlways.label "Allow and Remember">

Choosing "Allow Now" activates the plugin for that single page and does not remember your choice even after you load the same page in the future. Therefore, I believe that this string should be called "Allow For Now" instead, and that's how I translate it into Turkish.

Since my native language isn't English, I wanted to get some opinions before reporting this as a bug. Which one do you think would be more appropriate?

Axel Hecht

unread,
Apr 20, 2014, 10:20:52 AM4/20/14
to Matej Novak
Looping in Matej explicitly.

For now, I'd say that "for now" means "starting now, and until revoked or changed, which is likely".

More explicit would be "once" in this context, though that might imply that it'll be denied next time, and not just asked again, which is what the code does.

But English isn't my mother tongue, too, so this is only now, until Matej changes the truth :-)

Axel

Francesco Lodolo [:flod]

unread,
Apr 20, 2014, 10:59:59 AM4/20/14
to dev-...@lists.mozilla.org
Il 20/04/14 15:02, Selim Şumlu ha scritto:
> Choosing "Allow Now" activates the plugin for that single page and does not remember your choice even after you load the same page in the future. Therefore, I believe that this string should be called "Allow For Now" instead, and that's how I translate it into Turkish.
I think that the plugin is enabled for the session, so it remains
enabled after a reload.
https://bugzilla.mozilla.org/show_bug.cgi?id=880735
http://lxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/browser.properties#146

> This button will enable the plugin in the current session for a short
time
> (about an hour), auto-renewed if the site keeps using the plugin.

Having said that, I found "Allow now" confusing too, "Allow for session"
or similar would be a lot clearer.

Francesco

Chris Hofmann

unread,
Apr 20, 2014, 2:37:08 PM4/20/14
to Axel Hecht, dev-...@lists.mozilla.org, Matej Novak
On 4/20/14 7:20 AM, Axel Hecht wrote:
> I think that the plugin is enabled for the session, so it remains
> enabled after a reload.
> https://bugzilla.mozilla.org/show_bug.cgi?id=880735
> http://lxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/browser.properties#146
>
>
> > This button will enable the plugin in the current session for a
> short time
> > (about an hour), auto-renewed if the site keeps using the plugin.
>
> Having said that, I found "Allow now" confusing too, "Allow for
> session" or similar would be a lot clearer.
>
> Francesco


Or is the meaning "Allow this page to load [now, just for this one
time]"? Probably need benjamin to confirm what the behavior actually is
to get the wording improved.

"Allow Now" might take on the context of Axel's first definition if isolated by itself, but when the two options are combined it has more the meaning

"Allow Now" [once]
[as opposed to]
"Allow and Remember" [forever or until changed]


-chofmann

Robert Kaiser

unread,
Apr 21, 2014, 10:42:02 AM4/21/14
to
Chris Hofmann schrieb:
> Or is the meaning "Allow this page to load [now, just for this one
> time]"? Probably need benjamin to confirm what the behavior actually is
> to get the wording improved.

It allows plugins from the page to load for the next 60 minutes.
Any time another plugin of this type on that site is loaded on this site
within those 60 minutes, the 60-minute-expiration is reset and a new 60
minutes start. This is a better proxy for "session" as it persists when
people restart for a crash, update, or add-on installation and expires
when people have the browser open for long periods.

> "Allow and Remember" [forever or until changed]

That one actually allows for 90 days. The same rule of resetting the
timer and starting a new 90 day period applies here - so on any page
that the user visits semi-regularly, it equals to "forever", on pages
only visited once or very rarely, we restore the heightened security of
click-to-play, though.

KaiRo

Matej Novak

unread,
Apr 22, 2014, 4:51:13 PM4/22/14
to chof...@mozilla.org, Axel Hecht, dev-...@lists.mozilla.org, Chris Hofmann
It would definitely be helpful to know what the exact behaviour is.

If it is indeed just allowing it for the session, I would say something like "Allow this time" (both "Allow now" and "Allow for now" are ambiguous).


Matej Novak • Copy Director • Mozilla

+1.416.356.1926 • @matejnovak • matejnovak.com

On 20 April, 2014 at 2:37:09 PM, Chris Hofmann (chof...@mozilla.com) wrote:

On 4/20/14 7:20 AM, Axel Hecht wrote:
I think that the plugin is enabled for the session, so it remains enabled after a reload.
https://bugzilla.mozilla.org/show_bug.cgi?id=880735
http://lxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/browser.properties#146

> This button will enable the plugin in the current session for a short time
> (about an hour), auto-renewed if the site keeps using the plugin.

Having said that, I found "Allow now" confusing too, "Allow for session" or similar would be a lot clearer.

Francesco


Or is the meaning "Allow this page to load [now, just for this one time]"?  Probably need benjamin to confirm what the behavior actually is to get the wording improved.

"Allow Now" might take on the context of Axel's first definition if isolated by itself, but when the two options are combined it has more the meaning

"Allow Now" [once]
[as opposed to]
"Allow and Remember" [forever or until changed]

-chofmann

Chris Hofmann

unread,
Apr 22, 2014, 5:27:48 PM4/22/14
to Matej Novak, Axel Hecht, dev-...@lists.mozilla.org, Chris Hofmann, Robert Kaiser
On 4/22/14 1:51 PM, Matej Novak wrote:
> It would definitely be helpful to know what the exact behaviour is.
>
> If it is indeed just allowing it for the session, I would say
> something like "Allow this time" (both "Allow now" and "Allow for now"
> are ambiguous).
>

Thought I saw Kairo reply with exact behavior that is implimented, and
it would be something like

Allow for the next hour.
and
Allow for the next 90 days


Seems like the intended friendlier sounding version of the exact
implementation is

Allow for today
and
Allow for ever

these are a bit less wordy , but also less exact....

-chofmann



> —
> Matej Novak • Copy Director • Mozilla
>
> +1.416.356.1926 • @matejnovak • matejnovak.com
>
> On 20 April, 2014 at 2:37:09 PM, Chris Hofmann (chof...@mozilla.com
> <mailto:chof...@mozilla.com>) wrote:
>
>> On 4/20/14 7:20 AM, Axel Hecht wrote:

Sebastian

unread,
Apr 23, 2014, 5:59:28 AM4/23/14
to dev-...@lists.mozilla.org, l...@mozilla.com
CCing lco on recommendation from gfritzsche.

Whole thread at
https://groups.google.com/forum/#!topic/mozilla.dev.l10n/QXtWjSXMtxg

-------- Original-Nachricht --------
Betreff: Discussion: "Allow Now" or "Allow For Now"?
Von: Selim Şumlu <se...@sum.lu>
An: dev-...@lists.mozilla.org
Datum: 2014-04-20 15:02
> appropriate? _______________________________________________ dev-l10n
> mailing list dev-...@lists.mozilla.org
> https://lists.mozilla.org/listinfo/dev-l10n
>

Matej Novak

unread,
Apr 23, 2014, 11:18:02 AM4/23/14
to chof...@mozilla.org, Axel Hecht, dev-...@lists.mozilla.org, Chris Hofmann, Robert Kaiser
We could also simplify it further to:

Allow today
Allow forever

Either way, it feels like "forever" should be one word.


Matej Novak • Copy Director • Mozilla

+1.416.356.1926 • @matejnovak • matejnovak.com

On 22 April, 2014 at 5:27:49 PM, Chris Hofmann (chof...@mozilla.org) wrote:

On 4/22/14 1:51 PM, Matej Novak wrote:
It would definitely be helpful to know what the exact behaviour is.

If it is indeed just allowing it for the session, I would say something like "Allow this time" (both "Allow now" and "Allow for now" are ambiguous).


Thought I saw Kairo reply with exact behavior that is implimented, and it would be something like

Allow for the next hour.
and
Allow for the next 90 days


Seems like the intended friendlier sounding version of the exact implementation is

Allow for today
and
Allow for ever

these are a bit less wordy , but also less exact....

-chofmann




Matej Novak • Copy Director • Mozilla

+1.416.356.1926 • @matejnovak • matejnovak.com

On 20 April, 2014 at 2:37:09 PM, Chris Hofmann (chof...@mozilla.com) wrote:

On 4/20/14 7:20 AM, Axel Hecht wrote:
0 new messages