gmail problem

0 views
Skip to first unread message

Millwood

unread,
Mar 1, 2009, 8:39:20 AM3/1/09
to
I need a pointer to untangle a mystery. running latest shiretoko.

if I go to gmail->settings->fileters create/edit filter, and press test
search, the results don't display, and from there on things are messed
up, in that changes don't reliably display.

same experiment in safe-mode works correctly. so its something i've done?

create clean new profile. it fails! of course, safe-mode in new
profile works.

so - what are the differences between safe-mode and a completely new
profile?

Gijs Kruitbosch

unread,
Mar 1, 2009, 9:12:29 AM3/1/09
to Millwood

The first thing that comes to my mind is app-wide add-ons. I think those are not
enabled in safemode, but are definitely there in new profiles. Check for those?
(anti-virus scanners and the like often use these, and if they mess with script
that'd be an excellent reason as to why gmail doesn't work)

~ Gijs

Millwood

unread,
Mar 1, 2009, 11:05:03 AM3/1/09
to
Gijs Kruitbosch wrote:

>
> The first thing that comes to my mind is app-wide add-ons. I think those
> are not enabled in safemode, but are definitely there in new profiles.
> Check for those?
> (anti-virus scanners and the like often use these, and if they mess with
> script that'd be an excellent reason as to why gmail doesn't work)
>
> ~ Gijs

Where are they?

Harlequin99

unread,
Mar 1, 2009, 11:26:44 AM3/1/09
to
What you are seeing is probably bug 477101
https://bugzilla.mozilla.org/show_bug.cgi?id=477101

The reason it doesnt happen in safe mode is the tracemonkey engine, (the new
javascript optimiser) is turned off. In a new profile the preference
javascript.options.jit.content is true.


"Millwood" <marcs...@optonline.net> wrote in message
news:2KqdnZB1b5yXDTfU...@mozilla.org...

Millwood

unread,
Mar 1, 2009, 11:34:50 AM3/1/09
to
You nailed it. thanks.

I've been turning jit off everytime I got suspicious - but somehow
missed it for this one. sigh. you wouldn't believe how much time I
spend breaking stuff trying to diagnose it.

Reply all
Reply to author
Forward
0 new messages