Firefox 3 - Config error -No package 'gtk+-unix-print-2.0' found

58 views
Skip to first unread message

Shailendra Jain

unread,
Feb 2, 2008, 4:47:25 AM2/2/08
to dev-apps...@lists.mozilla.org
Hi ,

I am running firefox trunk build ( firefox3 ) on AIX. But I am getting the below error.

checking for gtk+-2.0 >= 1.8.0 gtk+-unix-print-2.0 gdk-x11-2.0 glib-2.0 gobject-2.0... Package gtk+-unix-print-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gtk+-unix-print-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gtk+-unix-print-2.0' found
configure: error: Library requirements (gtk+-2.0 >= 1.8.0 gtk+-unix-print-2.0 gdk-x11-2.0 glib-2.0 gobject-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

I have installed rpms gtk2-2.8.3-9 & gtk2-devel-2.8.3-9 in tinder build AIX machine.

I have also posted this question in IRC and someone suggested to me to upgrade gtk2-2.8.3.9 to gtk2-2.10.x to have `gtk+-unix-print-2.0.pc' added to KG_CONFIG_PATH

At this moment I will not be able to upgrade gtk2 rpm, Can someone provide me an alternate solution to overcome the above error ?

Thanks,
Shailendra


---------------------------------
Looking for last minute shopping deals? Find them fast with Yahoo! Search.

Boris Zbarsky

unread,
Feb 2, 2008, 9:41:46 AM2/2/08
to
Shailendra Jain wrote:
> Package gtk+-unix-print-2.0 was not found in the pkg-config
> search path.

...

> I have installed rpms gtk2-2.8.3-9& gtk2-devel-2.8.3-9 in tinder build AIX
> machine.

The new print dialog requires gtk2-2.10.

> At this moment I will not be able to upgrade gtk2 rpm, Can someone provide me
> an alternate solution to overcome the above error ?

The only solutions I can think of offhand are to either fix the above hard
dependency or to build something from no later than 2008-01-20.... Or to wait
for someone else to fix the dependency, I guess.

-Boris

Reply all
Reply to author
Forward
0 new messages