jpm fails on "run" after "init"

162 views
Skip to first unread message

Kara

unread,
Aug 11, 2015, 3:53:29 AM8/11/15
to mozilla-labs-jetpack
Hi, Jetpackers,


I'm new to Firefox Addon development. I installed node.js, installed jpm with "npm install jpm -g," created project with "jpm init," and tried testing the code with "jpm run."
I'm running Windows XP SP3 with Firefox 39.

All I got was this:
 
JPM undefined Starting jpm run on AddOnOne X
Creating XPI
JPM undefined XPI created at E:\xxxx\@addonone-0.0.1.xpi (157ms)
Created XPI at E:\xxxx\@addonone-0.0.1.xpi
JPM undefined Creating a new profile
I:\Documents and Settings\xx\Application Data\npm\node_modules\jpm\node_mod
ules\fx-runner\lib\utils.js:86
        return (err) ? reject() : resolve(key.value);
                                             ^
TypeError: Cannot read property 'value' of null
    at I:\Documents and Settings\xx\Application Data\npm\node_modules\jpm\n
ode_modules\fx-runner\lib\utils.js:86:46
    at ChildProcess.<anonymous> (I:\Documents and Settings\xx\Application Data\npm\node_modules\jpm\node_modules\fx-runner\node_modules\winreg\lib\registry.js:374:7)
   at ChildProcess.emit (events.js:110:17)
   at maybeClose (child_process.js:1015:16)
   at Process.ChildProcess._handle.onexit (child_process.js:1087:5)

------------

Thanks in advance , folks, for the resolution, so I can proceed forward.


Kara

unread,
Aug 16, 2015, 11:46:34 AM8/16/15
to mozilla-labs-jetpack
So, Firefox programmers, it's been 6 days now, and nobody figured out what's wrong with my JPM installation? So, is there any other way to develop for Firefox?

Please help. I don't want to stop using Firefox because it can't be tweaked by me.
 

Agam Karnoaji

unread,
Sep 3, 2015, 7:37:02 AM9/3/15
to mozilla-labs-jetpack
Try to run using binary option and full path where the firefox app installation. For example: jpm test -b "C:\Program Files\Mozilla Firefox\firefox.exe"

herochip

unread,
Sep 25, 2015, 4:58:50 AM9/25/15
to mozilla-labs-jetpack
Try this run command to update jpm: npm install jpm -g 

Vào 22:46:34 UTC+7 Chủ Nhật, ngày 16 tháng 8 năm 2015, Kara đã viết:

pink...@gmail.com

unread,
Nov 11, 2015, 6:31:16 AM11/11/15
to mozilla-labs-jetpack
I don't know if you have already solved but I had the same issue.

Your system is 32 bit, I think it's a bug of jpm.
64 bit systems there's no problem.

To bypass I applied a patch to utils.js and then all work fine however I don't use 32 bit as development machine.

 Bye.

Hy Sonic

unread,
Dec 24, 2015, 8:52:52 AM12/24/15
to mozilla-labs-jetpack
I have the same problem ,how you solve ?

在 2015年8月11日星期二 UTC+8下午3:53:29,Kara写道:

Shawn

unread,
Feb 7, 2016, 12:16:26 AM2/7/16
to mozilla-labs-jetpack
I was able to fix this by changing line 360 in %appdata%\npm\node_modules\jpm\node_modules\fx-runner\node_modules\winreg\lib\registry.js

From this:
var item = items[0] || ''

To this:
var item = items[1] || ''

I'm not sure if changing that will break anything else but it's been working for me so far.
Reply all
Reply to author
Forward
0 new messages