"Number found where operator expected"

119 views
Skip to first unread message

Oleg Moskvin

unread,
Mar 15, 2016, 3:28:38 PM3/15/16
to MOSAiCS User Group

Hello all,

After upgrading to mosaics 2.4.0, I see the following error while running mosaicsRunAll():

##############
Number found where operator expected at XXXX_IP_CSEM.bed line 12772, near "chr12    16975214"
    (Do you need to predeclare chr12?)
##############

This error appears for every line of the bed file and is reproduced with the 2 systems:

- Red Hat Linux / R 3.2.2
- Debian 7 Linux / R 3.1.2

(the mosaics was installed from source in both cases)

head of the input file:
chr15   59109725        59109776        DBYGT8Q1:236:C5TYPACXX:8:1101:1387:1981 1000.00 -
chr19   30168272        30168323        DBYGT8Q1:236:C5TYPACXX:8:1101:1354:1973 1000.00 -
chr5    171784518       171784569       DBYGT8Q1:236:C5TYPACXX:8:1101:1506:1928 1000.00 -
chr7    51484005        51484056        DBYGT8Q1:236:C5TYPACXX:8:1101:1570:1975 1000.00 +
chr10   114642611       114642662       DBYGT8Q1:236:C5TYPACXX:8:1101:1859:1937 1000.00 -
chr13   37817185        37817236        DBYGT8Q1:236:C5TYPACXX:8:1101:1656:1980 1000.00 -
chr1    38523205        38523256        DBYGT8Q1:236:C5TYPACXX:8:1101:2197:1967 1000.00 -
chr12   72033383        72033434        DBYGT8Q1:236:C5TYPACXX:8:1101:2028:1970 1000.00 +
chr20   30169714        30169765        DBYGT8Q1:236:C5TYPACXX:8:1101:2161:1970 1000.00 -

The command (in usual format that worked before):
mosaicsRunAll(chipFile = "XXXX_IP_CSEM.bed", chipFileFormat = "csem", controlFile = "XXXX_input_CSEM.bed", controlFileFormat = "csem", binfileDir = "bin", peakFile = "XXXX.Mosaics.bed", peakFileFormat = "bed")

Thank you for your insights,

Oleg

Oleg Moskvin

unread,
Mar 18, 2016, 11:43:53 AM3/18/16
to MOSAiCS User Group
P.S. I've double checked that my CSEM BED files are OK by re-running older CSEM BED files (which were processed just fine in June last year) with mosaics 2.4.0 using exactly the same code that was used in June successfully, and the error is exactly the same ("Number found where operator expected").

Peng

unread,
Mar 26, 2016, 2:27:57 PM3/26/16
to MOSAiCS User Group
Hi Oleg,

I got the similar error message as yours. I think it is probably because mosaics cannot find one of its own perl scripts, most likely due to Bioconductor setup. Maybe you can try to re-install mosaics by:


and then under the same folder, run R and use:

library(devtools)
install('mosaics')

this will install the same source code of mosaics without using Bioconductor. I found it solved my problem.

Best,
Peng
Reply all
Reply to author
Forward
0 new messages