Howto install Moonlight

95 views
Skip to first unread message

schoend...@gmail.com

unread,
Sep 19, 2007, 10:23:11 AM9/19/07
to Mono Olive - developing 3.0, 3.5 and Silverlight
Hi,

i have been trying to install moonlight for about 4 weeks. Everytime i
fix an error a new one appears.
I tried using Ubuntu Feisty Fawn and Debian Lenny.

Is it possible that someone can write a step by step Howto that shows
me which packages i need and which sourcecode i have to compile in the
right order.
For example I installed mono from SVN as mentioned on the Moonlight-
Page but somebody after i got an error somebody told me that there is
a bug in the SVN and i first had to install Mono 1.2.5. How should i
know that? On Debian Lenny configuring mono brought the error that the
Mozilla NSS Development package was missing, although i had libnss3-
dev installed.

PS: which distribution are you using?


Thanks,

Michael Schoendorfer

Shawn Wildermuth

unread,
Sep 19, 2007, 11:11:55 AM9/19/07
to mono-...@googlegroups.com
I am in the same boat and I wish I had better news to tell but if anyone can
help us, I'd be eternally grateful. I do a lot of Silverlight
training/talks and would love to show it working (even in its preminiary
form) to developers to get them excited about it on Linux!

Thanks,

Shawn Wildermuth
http://adoguy.com
http://wildermuthconsulting.com
Microsoft MVP (C#), MCSD.NET, Author and Speaker

chris....@gmail.com

unread,
Sep 24, 2007, 5:57:48 PM9/24/07
to Mono Olive - developing 3.0, 3.5 and Silverlight
Hello All,
I've spent some time messing with silverlight on feisty, and
have some notes I wrote down while getting it to work. See if these
help. They replace the built in mono stack with one from svn, and
install everything needed from svn.

Let me know if it works for you guys.

--Chris Hamons

Install Ubuntu 7.4 onto your test machine or VMware image. [link
http://www.ubuntu.com/getubuntu/download]
Update using build in updater.
This prepares a base to build our moonlight stack upon. Any ubuntu
7.4 machine could be used here instead.
sudo apt-get update
sudo apt-get install subversion
mkdir mono
cd mono
svn co svn://anonsvn.mono-project.com/source/trunk/mcs
svn co svn://anonsvn.mono-project.com/source/trunk/mono
svn co svn://anonsvn.mono-project.com/source/trunk/gtk-sharp
svn co svn://anonsvn.mono-project.com/source/trunk/gnome-sharp
svn co svn://anonsvn.mono-project.com/source/trunk/olive
svn co svn://anonsvn.mono-project.com/source/trunk/moon
svn co svn://anonsvn.mono-project.com/source/trunk/monodoc
sudo apt-get install libavcodec0d libavformat0d libgtk2.0-dev libnspr-
dev firefox-dev libavcodec-dev libavformat-dev libasound2-dev librsvg2-
dev
sudo apt-get install autoconf automake libtool build-essential bison
sudo apt-get install prevu
Little bit of explanation here. One of the required libraries
(libswscale-dev) does not exist under 7.4. 7.10 has a copy, but it's
not part of the traditional backports repository. Prevu is an
application which creates a self-contained build environment (similar
to gentoo's emerge) to build a .deb file of a 7.10 program/library for
7.4.
sudo prevu-init
Sets up the build environment. This could take awhile. Answer
yes when asked
Edit /etc/apt/sources.list as root and add "deb-src http://us.archive.ubuntu.com/ubuntu
gutsy main universe restricted multiverse"
Add the repository for gutsy (7.10)
sudo apt-get update
prevu libswscale-dev
cd /var/cache/prevu/feisty-debs
sudo dpkg -i *.deb
This installs all the packages build by prevu. Ignore the ones about
ffmpeg not being able to be installed
cd ~
sudo apt-get install mono-mcs (we're bootstrapping mono with the
ubuntu version of mcs)
cd mono
Download patch found at www.mono-project.com/Moonlight to mono/mono
cd mono/mono
patch -p0 < mono-delegate-appdomain-patch
./autogen.sh --prefix=/usr --with-moonlight=yes
make
sudo apt-get remove mono-mcs
sudo apt-get autoremove
sudo make install
cd ../olive
./configure --prefix=/usr
make
sudo make install
cd gtk-sharp
./boostrap-2.10 --prefix=/usr
make
sudo make install
cd ../monodoc
./autogen.sh --prefix=/usr
make
make install
cd ../gnome-sharp
./bootstrap-2.16 --prefix=/usr
make
sudo make install
cd ../moon
./autogen.sh --prefix=/usr
sudo make install
cd /usr/local/lib/moon/plugin
sudo cp *.so moonlight.exe /usr/lib/mozilla-firefox/plugins
Install the firefox plugin
sudo ln -s /usr/local/lib/mono /usr/lib/mono/3.0
Install a symbolic link to fix an install issue
firefox
Launch Firefox
In the address bar, about:plugins
Confirm WPFe plugin is there
Woot! You should be good.

Shawn Wildermuth

unread,
Sep 24, 2007, 6:05:35 PM9/24/07
to mono-...@googlegroups.com
I'll try this out tonight...thanks! This looks great!

Thanks,

Shawn Wildermuth
http://adoguy.com
http://wildermuthconsulting.com
Microsoft MVP (C#), MCSD.NET, Author and Speaker


-----Original Message-----
From: mono-...@googlegroups.com [mailto:mono-...@googlegroups.com] On
Behalf Of chris....@gmail.com
Sent: Monday, September 24, 2007 5:58 PM
To: Mono Olive - developing 3.0, 3.5 and Silverlight

Shawn Wildermuth

unread,
Sep 25, 2007, 1:01:06 AM9/25/07
to mono-...@googlegroups.com
Quick note, you mentioned Ubuntu 7.4, do you mean 7.04?

Thanks,

Shawn Wildermuth
http://adoguy.com
http://wildermuthconsulting.com
Microsoft MVP (C#), MCSD.NET, Author and Speaker


-----Original Message-----
From: mono-...@googlegroups.com [mailto:mono-...@googlegroups.com] On

Behalf Of chris....@gmail.com
Sent: Monday, September 24, 2007 5:58 PM

To: Mono Olive - developing 3.0, 3.5 and Silverlight

chris....@gmail.com

unread,
Sep 25, 2007, 11:40:09 AM9/25/07
to Mono Olive - developing 3.0, 3.5 and Silverlight
Yep. Typo FTW.

--Chris


On Sep 25, 12:01 am, "Shawn Wildermuth" <swilderm...@adoguy.com>
wrote:


> Quick note, you mentioned Ubuntu 7.4, do you mean 7.04?
>
> Thanks,
>

> Shawn Wildermuthhttp://adoguy.comhttp://wildermuthconsulting.com


> Microsoft MVP (C#), MCSD.NET, Author and Speaker
>
> -----Original Message-----
> From: mono-...@googlegroups.com [mailto:mono-...@googlegroups.com] On
>

> Behalf Of chris.ham...@gmail.com


> Sent: Monday, September 24, 2007 5:58 PM
> To: Mono Olive - developing 3.0, 3.5 and Silverlight
> Subject: Re: Howto install Moonlight
>
> Hello All,
> I've spent some time messing with silverlight on feisty, and
> have some notes I wrote down while getting it to work. See if these
> help. They replace the built in mono stack with one from svn, and
> install everything needed from svn.
>
> Let me know if it works for you guys.
>
> --Chris Hamons
>

> Install Ubuntu 7.4 onto your test machine or VMware image. [linkhttp://www.ubuntu.com/getubuntu/download]

> Edit /etc/apt/sources.list as root and add "deb-srchttp://us.archive.ubuntu.com/ubuntu


> gutsy main universe restricted multiverse"
> Add the repository for gutsy (7.10)
> sudo apt-get update
> prevu libswscale-dev
> cd /var/cache/prevu/feisty-debs
> sudo dpkg -i *.deb
> This installs all the packages build by prevu. Ignore the ones about
> ffmpeg not being able to be installed
> cd ~
> sudo apt-get install mono-mcs (we're bootstrapping mono with the
> ubuntu version of mcs)
> cd mono

> Download patch found atwww.mono-project.com/Moonlightto mono/mono

Manfred Linzner

unread,
Sep 25, 2007, 11:44:34 AM9/25/07
to mono-...@googlegroups.com
thanks for your effort ;)

i'am currently trying to compile moonlight according to your howto.

looks well




----------
LinMan

Christian López Espínola

unread,
Sep 25, 2007, 1:18:15 PM9/25/07
to mono-...@googlegroups.com
Hi Chris, list:

At first, thanks Chris for this great tutorial. I followed it and all went OK.
But when I open a Silverlight site, like Silverlight.net or
Tafiti.net, my computer is very slow, and can't use those sites.
What are the supposed minimal requirements for a great experience with
Moonlight?

Thanks in advance.


--
Regards,

Christian López Espínola

chris....@gmail.com

unread,
Sep 25, 2007, 2:42:34 PM9/25/07
to Mono Olive - developing 3.0, 3.5 and Silverlight
I honestly have no idea, maybe someone else around here could answer
that? Moonlight is still pretty alpha, and lots of things don't work.
I mainly built it just to check out the progress being done, and so I
don't know much outside of how to build it.

--Chris

On Sep 25, 12:18 pm, "Christian López Espínola" <penyask...@gmail.com>
wrote:


> Hi Chris, list:
>
> At first, thanks Chris for this great tutorial. I followed it and all went OK.
> But when I open a Silverlight site, like Silverlight.net or
> Tafiti.net, my computer is very slow, and can't use those sites.
> What are the supposed minimal requirements for a great experience with
> Moonlight?
>
> Thanks in advance.
>

> > Edit /etc/apt/sources.list as root and add "deb-srchttp://us.archive.ubuntu.com/ubuntu


> > gutsy main universe restricted multiverse"
> > Add the repository for gutsy (7.10)
> > sudo apt-get update
> > prevu libswscale-dev
> > cd /var/cache/prevu/feisty-debs
> > sudo dpkg -i *.deb
> > This installs all the packages build by prevu. Ignore the ones about
> > ffmpeg not being able to be installed
> > cd ~
> > sudo apt-get install mono-mcs (we're bootstrapping mono with the
> > ubuntu version of mcs)
> > cd mono

> > Download patch found atwww.mono-project.com/Moonlightto mono/mono

> Christian L?pez Esp?nola

Shawn WIldermuth (adoguy.com)

unread,
Sep 25, 2007, 4:05:48 PM9/25/07
to Mono Olive - developing 3.0, 3.5 and Silverlight
These are not working for me. I get stuck here:

me@mymachine:~$ sudo apt-get install mono-mcs
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
ffmpeg: Depends: libimlib2 but it is not going to be installed
mono-mcs: Depends: libmono-peapi1.0-cil (>= 1.0) but it is not going
to be installed
Depends: libmono-relaxng1.0-cil (>= 1.0) but it is not
going to be installed
Depends: libmono-security1.0-cil (>= 1.0) but it is not
going to be installed
Depends: libmono-sharpzip0.84-cil (>= 1.0) but it is not
going to be installed
Depends: libmono-system-data1.0-cil (>= 1.0) but it is not
going to be installed
Depends: libmono-system-runtime1.0-cil (>= 1.0) but it is
not going to be installed
Depends: libmono-system-web1.0-cil (>= 1.0) but it is not
going to be installed
Depends: libmono1.0-cil (>= 1.2.3) but it is not going to
be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
specify a solution).

I Tried with the -f option but that didn't do anything. Ideas?

On Sep 24, 5:57 pm, "chris.ham...@gmail.com" <chris.ham...@gmail.com>
wrote:


> Hello All,
> I've spent some time messing with silverlight on feisty, and
> have some notes I wrote down while getting it to work. See if these
> help. They replace the built in mono stack with one from svn, and
> install everything needed from svn.
>
> Let me know if it works for you guys.
>
> --Chris Hamons
>

> Install Ubuntu 7.4 onto your test machine or VMware image. [linkhttp://www.ubuntu.com/getubuntu/download]

> Edit /etc/apt/sources.list as root and add "deb-srchttp://us.archive.ubuntu.com/ubuntu


> gutsy main universe restricted multiverse"
> Add the repository for gutsy (7.10)
> sudo apt-get update
> prevu libswscale-dev
> cd /var/cache/prevu/feisty-debs
> sudo dpkg -i *.deb
> This installs all the packages build by prevu. Ignore the ones about
> ffmpeg not being able to be installed
> cd ~
> sudo apt-get install mono-mcs (we're bootstrapping mono with the
> ubuntu version of mcs)
> cd mono

> Download patch found atwww.mono-project.com/Moonlightto mono/mono

Michael Schöndorfer

unread,
Sep 25, 2007, 4:28:05 PM9/25/07
to mono-...@googlegroups.com
I had the same error.

I did this:

sudo apt-get remove ffmpeg
sudo apt-get -f install
sudo apt-get install mono-mcs

2007/9/25, Shawn WIldermuth ( adoguy.com) <swild...@adoguy.com>:

Shawn Wildermuth

unread,
Sep 25, 2007, 5:19:01 PM9/25/07
to mono-...@googlegroups.com

Thanks, I’ll try it!

 

Thanks,

 

Shawn Wildermuth

http://adoguy.com

http://wildermuthconsulting.com

Microsoft MVP (C#), MCSD.NET, Author and Speaker

 

From: mono-...@googlegroups.com [mailto:mono-...@googlegroups.com] On Behalf Of Michael Schöndorfer
Sent: Tuesday, September 25, 2007 4:28 PM
To: mono-...@googlegroups.com
Subject: Re: Howto install Moonlight

 

I had the same error.

Shawn WIldermuth (adoguy.com)

unread,
Sep 26, 2007, 2:30:13 AM9/26/07
to Mono Olive - developing 3.0, 3.5 and Silverlight
I've edited the original to address several issues with the original
instructions. Hopefully these are a bit more accurate. I've got it
running (though it is an Alpha so its not running very smoothly, but
that's all i'd expect!)

---------------------------------------

Install Ubuntu 7.04 onto your test machine or VMware image. [link


http://www.ubuntu.com/getubuntu/download]
Update using build in updater.
This prepares a base to build our moonlight stack upon. Any
ubuntu

7.04 machine could be used here instead.


sudo apt-get update
sudo apt-get install subversion
mkdir mono
cd mono
svn co svn://anonsvn.mono-project.com/source/trunk/mcs
svn co svn://anonsvn.mono-project.com/source/trunk/mono
svn co svn://anonsvn.mono-project.com/source/trunk/gtk-sharp
svn co svn://anonsvn.mono-project.com/source/trunk/gnome-sharp
svn co svn://anonsvn.mono-project.com/source/trunk/olive
svn co svn://anonsvn.mono-project.com/source/trunk/moon
svn co svn://anonsvn.mono-project.com/source/trunk/monodoc
sudo apt-get install libavcodec0d libavformat0d libgtk2.0-dev libnspr-
dev firefox-dev libavcodec-dev libavformat-dev libasound2-dev
librsvg2-
dev
sudo apt-get install autoconf automake libtool build-essential bison
sudo apt-get install prevu
Little bit of explanation here. One of the required libraries
(libswscale-dev) does not exist under 7.4. 7.10 has a copy, but it's
not part of the traditional backports repository. Prevu is an
application which creates a self-contained build environment (similar
to gentoo's emerge) to build a .deb file of a 7.10 program/library for

7.04.


sudo prevu-init
Sets up the build environment. This could take awhile. Answer
yes when asked

Edit /etc/apt/sources.list as root and add "deb-src http://us.archive.ubuntu.com/ubuntu


gutsy main universe restricted multiverse"
Add the repository for gutsy (7.10)
sudo apt-get update
prevu libswscale-dev
cd /var/cache/prevu/feisty-debs
sudo dpkg -i *.deb
This installs all the packages build by prevu. Ignore the ones
about
ffmpeg not being able to be installed
cd ~

sudo apt-get remove ffmpeg
sudo apt-get -f install
sudo apt-get install mono-mcs

(we're bootstrapping mono with the ubuntu version of mcs)
cd mono

Download patch found at www.mono-project.com/Moonlight to mono/mono


cd mono/mono
patch -p0 < mono-delegate-appdomain-patch
./autogen.sh --prefix=/usr --with-moonlight=yes
make
sudo apt-get remove mono-mcs
sudo apt-get autoremove
sudo make install
cd ../olive
./configure --prefix=/usr
make
sudo make install
cd gtk-sharp
./boostrap-2.10 --prefix=/usr
make
sudo make install
cd ../monodoc
./autogen.sh --prefix=/usr
make

sudo make install


cd ../gnome-sharp
./bootstrap-2.16 --prefix=/usr
make
sudo make install
cd ../moon
./autogen.sh --prefix=/usr

make
sudo make install
cd /usr/lib/moon/plugin


sudo cp *.so moonlight.exe /usr/lib/mozilla-firefox/plugins
Install the firefox plugin
sudo ln -s /usr/local/lib/mono /usr/lib/mono/3.0
Install a symbolic link to fix an install issue

firefox about:plugins

Manfred Linzner

unread,
Sep 26, 2007, 10:18:45 AM9/26/07
to mono-...@googlegroups.com
i finished compiling moonlight! works perfectly with your howto.

never heard the program prevu before, but nevertheless works very good.

2007/9/26, Shawn WIldermuth (adoguy.com) <swild...@adoguy.com>:

Manfred Linzner

unread,
Sep 26, 2007, 2:06:51 PM9/26/07
to mono-...@googlegroups.com
by the way,...

use aptitude instead of apt-get, to avoid the problem mentioned by
shawn and then it's also unnecessary to run "sudo apt-get autoremove".


manfred

2007/9/26, Manfred Linzner <manfred...@gmail.com>:

skabaas

unread,
Oct 3, 2007, 12:58:03 PM10/3/07
to Mono Olive - developing 3.0, 3.5 and Silverlight
After doing this I get the following error message when I fire up my
Swiftfox browser:

bart@Bananenboom:/opt/swiftfox$ swiftfox_start

(swiftfox-bin:8190): Gtk-WARNING **: Locale not supported by C
library.
Using the fallback 'C' locale.
LoadPlugin: failed to initialize shared library /opt/swiftfox/plugins/
libmoonloader.so [/opt/swiftfox/plugins/libmoonloader.so: wrong ELF
class: ELFCLASS64]
LoadPlugin: failed to initialize shared library /opt/swiftfox/plugins/
libmoonplugin.so [/opt/swiftfox/plugins/libmoonplugin.so: wrong ELF
class: ELFCLASS64]
LoadPlugin: failed to initialize shared library /opt/swiftfox/plugins/
libmoonloader.so [/opt/swiftfox/plugins/libmoonloader.so: wrong ELF
class: ELFCLASS64]
LoadPlugin: failed to initialize shared library /opt/swiftfox/plugins/
libmoonplugin.so [/opt/swiftfox/plugins/libmoonplugin.so: wrong ELF
class: ELFCLASS64]

This has probabely something to do with me running Ubuntu 7.04 Feisty
(AMD64), but how can I fix this?!

On Sep 24, 11:57 pm, "chris.ham...@gmail.com" <chris.ham...@gmail.com>
wrote:


> Hello All,
> I've spent some time messing with silverlight on feisty, and
> have some notes I wrote down while getting it to work. See if these
> help. They replace the built in mono stack with one from svn, and
> install everything needed from svn.
>
> Let me know if it works for you guys.
>
> --Chris Hamons
>

> Install Ubuntu 7.4 onto your test machine or VMware image. [linkhttp://www.ubuntu.com/getubuntu/download]

> Edit /etc/apt/sources.list as root and add "deb-srchttp://us.archive.ubuntu.com/ubuntu


> gutsy main universe restricted multiverse"
> Add the repository for gutsy (7.10)
> sudo apt-get update
> prevu libswscale-dev
> cd /var/cache/prevu/feisty-debs
> sudo dpkg -i *.deb
> This installs all the packages build by prevu. Ignore the ones about
> ffmpeg not being able to be installed
> cd ~
> sudo apt-get install mono-mcs (we're bootstrapping mono with the
> ubuntu version of mcs)
> cd mono

> Download patch found atwww.mono-project.com/Moonlightto mono/mono

Chris Toshok

unread,
Oct 3, 2007, 2:18:57 PM10/3/07
to mono-...@googlegroups.com
are you running a 32bit browser against a 64bit moonlight?

skabaas

unread,
Oct 4, 2007, 3:24:11 PM10/4/07
to Mono Olive - developing 3.0, 3.5 and Silverlight
Yup... I'm running a 32 bit browser against a 64 bit moonlight I
guess... How do I get moonlight to be 32 bit?

On Oct 3, 8:18 pm, "Chris Toshok" <tos...@gmail.com> wrote:
> are you running a 32bit browser against a 64bit moonlight?
>

Chris Toshok

unread,
Oct 4, 2007, 8:38:08 PM10/4/07
to mono-...@googlegroups.com
I actually have no idea..  why not run a 64 bit browser if you're running a 64 bit os?

> > > ./boostrap- 2.10 --prefix=/usr

skabaas

unread,
Oct 5, 2007, 8:09:34 AM10/5/07
to Mono Olive - developing 3.0, 3.5 and Silverlight
Because then I can't use Flash...

On 5 okt, 02:38, "Chris Toshok" <tos...@gmail.com> wrote:
> I actually have no idea.. why not run a 64 bit browser if you're running a
> 64 bit os?
>

> > > > > ./boostrap-2.10 --prefix=/usr

Chris Toshok

unread,
Oct 5, 2007, 4:12:32 PM10/5/07
to mono-...@googlegroups.com
Isn't there some weird 64bit shim to use the 32bit flash plugin?

Igor Guerrero

unread,
Oct 5, 2007, 4:25:46 PM10/5/07
to mono-...@googlegroups.com
ndispluginwrapper
--
:::lxuser 391715:::
http://igordevlog.blogspot.com/

Björn Carlsson

unread,
Oct 16, 2007, 6:32:22 PM10/16/07
to Mono Olive - developing 3.0, 3.5 and Silverlight
It worked fine, thank you.
But the last few lines about the plugin could be simplified:

>cd /usr/lib/moon/plugin
>sudo cp *.so moonlight.exe /usr/lib/mozilla-firefox/plugins
> Install the firefox plugin
>sudo ln -s /usr/local/lib/mono /usr/lib/mono/3.0
> Install a symbolic link to fix an install issue
Could be replaced by:
make test-plugin

Silje R

unread,
Oct 28, 2007, 4:27:26 AM10/28/07
to Mono Olive - developing 3.0, 3.5 and Silverlight
Hello,

I have finished compiling moonlight, but I still can't see for example
this site: http://halo3.msn.com/videos.aspx
The silverlight-plugin is there when I type about:plugins in firefox.

How can I fix this..?

- Silje :)

Shawn Wildermuth

unread,
Oct 28, 2007, 4:44:01 AM10/28/07
to mono-...@googlegroups.com
Have you tried a simplier example? (for example the local clock example that
comes with the build?) It might be that the Halo 3 example is using features
still not available in the build.

Thanks,

Shawn Wildermuth
http://adoguy.com
http://wildermuthconsulting.com
Microsoft MVP (C#), MCSD.NET, Author and Speaker

The Silverlight Tour is coming to a city near you!


-----Original Message-----
From: mono-...@googlegroups.com [mailto:mono-...@googlegroups.com] On

Behalf Of Silje R
Sent: Sunday, October 28, 2007 4:27 AM
To: Mono Olive - developing 3.0, 3.5 and Silverlight

Subject: Re: Howto install Moonlight

Silje R

unread,
Oct 28, 2007, 8:35:39 AM10/28/07
to Mono Olive - developing 3.0, 3.5 and Silverlight
hmm.. I tried the clock, but I just got a stop, pause and play button.

- Silje

On Oct 28, 9:44 am, "Shawn Wildermuth" <swilderm...@adoguy.com> wrote:
> Have you tried a simplier example? (for example the local clock example that
> comes with the build?) It might be that the Halo 3 example is using features
> still not available in the build.
>
> Thanks,
>

> Shawn Wildermuthhttp://adoguy.comhttp://wildermuthconsulting.com

rolfbjarne

unread,
Oct 29, 2007, 7:36:08 AM10/29/07
to Mono Olive - developing 3.0, 3.5 and Silverlight

There is a bug in the halo website (we've reported it to MS, but no
response yet).

The workaround is to install the firebug extension and enable it for
the halo website.

Rolf

> - Silje :)

Silje R

unread,
Oct 30, 2007, 8:08:00 AM10/30/07
to Mono Olive - developing 3.0, 3.5 and Silverlight

Okay, thanx:)

with firebug I'm able to view http://halo3.msn.com/videos.aspx
but e.g. this site: http://www.etonline.com/emmys/ do not work
properly. The plugin is installed, but I can't see any video. (I've
tested it in Windows)

I also can't view streams(e.g. mms://....). Does anyone know when this
will be possible?

- Silje :)

Silje R

unread,
Oct 30, 2007, 8:34:00 AM10/30/07
to Mono Olive - developing 3.0, 3.5 and Silverlight

.. and when I'm watching videos(e.g http://www.discoverychannelasia.com/nevermissdiscovery/)
and close the tab, firefox shuts down with this message:

[wmv2 @ 0xaeb92ac8]J-type picture is not supported
[wmv2 @ 0xaeb92ac8]J-type picture is not supported
Rendered 69 frames in 1.012s = 68.184 FPS
Rendered 69 frames in 1.009s = 68.354 FPS
Rendered 69 frames in 1.007s = 68.543 FPS
Rendered 63 frames in 1.004s = 62.719 FPS
Destroying the surface: 0x9e9baf8, plugin: 0x9e9d160
Segmentation fault (core dumped)

Silje

rolfbjarne

unread,
Oct 30, 2007, 9:20:09 AM10/30/07
to Mono Olive - developing 3.0, 3.5 and Silverlight

On Oct 30, 1:08 pm, Silje R <rosv...@gmail.com> wrote:
> On Oct 29, 12:36 pm, rolfbjarne <rolfbja...@gmail.com> wrote:
>
>
>
> > On Oct 28, 9:27 am, Silje R <rosv...@gmail.com> wrote:
>
> > > Hello,
>
> > > I have finished compiling moonlight, but I still can't see for example
> > > this site: http://halo3.msn.com/videos.aspx
> > > The silverlight-plugin is there when I type about:plugins in firefox.
>
> > > How can I fix this..?
>
> > There is a bug in the halo website (we've reported it to MS, but no
> > response yet).
>
> > The workaround is to install the firebug extension and enable it for
> > the halo website.
>
> Okay, thanx:)
>

> with firebug I'm able to viewhttp://halo3.msn.com/videos.aspx
> but e.g. this site:http://www.etonline.com/emmys/do not work


> properly. The plugin is installed, but I can't see any video. (I've
> tested it in Windows)
>

I'd say at least 75-80% of the more complex Silverlight sites have
some kind of problems with Moonlight, we're working as fast as we can,
but there's still a lot of code to write :)

> I also can't view streams(e.g. mms://....). Does anyone know when this
> will be possible?
>

As I said, hopefully in December :)

Rolf

> - Silje :)

Sean Middleditch

unread,
Nov 14, 2007, 6:01:25 PM11/14/07
to Mono Olive - developing 3.0, 3.5 and Silverlight
On Oct 5, 3:25 pm, "Igor Guerrero" <igf...@gmail.com> wrote:
> ndispluginwrapper

I think you mean nspluginwrapper. The ndiswrapper thing is for
running Windows network drivers on Linux.

There is absolutely no reason to use a 32-bit Firefox on a 64-bit
system anymore. None. Every 32-bit-only plugin that you might need
(which is basically just Flash) can and will work perfectly in a 64-
bit Firefox now.

desantis.marco

unread,
Dec 10, 2007, 4:56:27 PM12/10/07
to Mono Olive - developing 3.0, 3.5 and Silverlight
HI! I'm trying to install the environment for moonlight but I have
some problems:
when I try the comand: prevu libswscale-dev

the result is: (last lines):

Traceback (most recent call last):
File "/usr/bin/prevu", line 178, in <module>
BackportFromAPT(sys.argv[1],DIST).backport()
File "/usr/bin/prevu", line 116, in backport
self.do_compile()
File "/usr/bin/prevu", line 97, in do_compile
raise ValueError("Build failed.")
ValueError: Build failed.
Error in sys.excepthook:
Traceback (most recent call last):
File "/var/lib/python-support/python2.5/apport_python_hook.py", line
42, in apport_excepthook
binary = os.path.realpath(os.path.join(os.getcwdu(), sys.argv[0]))
OSError: [Errno 2] No such file or directory

Original exception was:
Traceback (most recent call last):
File "/usr/bin/prevu", line 178, in <module>
BackportFromAPT(sys.argv[1],DIST).backport()
File "/usr/bin/prevu", line 116, in backport
self.do_compile()
File "/usr/bin/prevu", line 97, in do_compile
raise ValueError("Build failed.")
ValueError: Build failed.


and then when I try

>sudo dpkg -i *.deb

dpkg: errore processando *.deb (--install):
impossibile accedere all'archivio: No such file or directory
Sono occorsi degli errori processando:
*.deb

I have Ubuntu 7.10 Gutsy...


Help me!!!

Andrew Jorgensen

unread,
Dec 10, 2007, 5:15:58 PM12/10/07
to mono-...@googlegroups.com
On Dec 10, 2007 2:56 PM, desantis.marco <djd...@gmail.com> wrote:
>
> HI! I'm trying to install the environment for moonlight but I have
> some problems:
> when I try the comand: prevu libswscale-dev

At the moment moonlight requires a specific revision of ffmpeg.
Please check out from svn as specified in the instructions
http://mono-project.com/Moonlight

svn co -r 9167 svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg

Reply all
Reply to author
Forward
0 new messages