SSL not working 'No Such Option'

110 views
Skip to first unread message

paul.c...@base2s.com

unread,
Jan 19, 2015, 12:20:06 PM1/19/15
to mongoos...@googlegroups.com
Trying to start the Mongoose w/ PHP Binary using SSL and am receiving an error "failed to set option [ssl_certificate] to ... no such option".  The path to the PEM file is correct in the error message.  This is a Windows 7 64-bit machine and the HTTP port is up and running with no issues.  Only when adding a listening port for SSL (443) and adding the ssl_certificate option in the conf file do I get the error. 

Message boards indicate I have to download the source and recompile with the -NS-ENABLE-SSL flag.  Is this true?  Does your binary not support SSL by default?  I have the free edition downloaded at the moment.  If one of the other editions has SSL supported by default, let me know that as well.

Thanks,
Paul

paul.c...@base2s.com

unread,
Jan 19, 2015, 3:01:09 PM1/19/15
to mongoos...@googlegroups.com
After reviewing the other comments, I can see that the ssl_certificate option was removed and the listening_port option was enhanced to include ssl.  However, when I changed to the new configuration, the server loads successfully, but an error is returned in the web browser "ssl_error_rs_record_too_long".  Does this indicate there is something wron with the ssl certificate?  It is a self-signed certificate

Sergey Lyubka

unread,
Jan 21, 2015, 10:31:06 AM1/21/15
to mongoose-users
Mongoose binary that is shipped by cesanta.com does not support SSL.
You need to recompile with SSL support.

--
You received this message because you are subscribed to the Google Groups "mongoose-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mongoose-user...@googlegroups.com.
To post to this group, send email to mongoos...@googlegroups.com.
Visit this group at http://groups.google.com/group/mongoose-users.
For more options, visit https://groups.google.com/d/optout.

TTK Droid

unread,
Jul 6, 2015, 9:56:50 PM7/6/15
to mongoos...@googlegroups.com

Hey Paul,

Did you end up resolving this issue? I'm facing the same problem of "ssl_error_rs_record_too_long"
Reply all
Reply to author
Forward
0 new messages