Mongoid Master and upcoming Mongoid 5

565 views
Skip to first unread message

Durran Jordan

unread,
May 26, 2015, 10:05:42 AM5/26/15
to mon...@googlegroups.com

For the upcoming 5.0.0 release, the repository will be getting moved to the MongoDB organization. Please pay special attention to the following information with regards to this move:

  • 5.0.0 and higher releases of Mongoid will be officially supported by MongoDB with a dedicated team.
  • Issues tagged 5.0.0 and higher in Github will be migrated to the Mongoid Jira project upon the release. There will be no more Github issues. Users on master from this point forward please put new issues in that Jira project.
  • 4.x and 3.x releases will no longer be supported. Fixes to these branches will need to be maintained in community forks, although not recommended.
  • 5.0.0 release will still be supporting Rails 4.x, although there will be some backwards incompatible changes with respect to the configuration options. The Mongoid public API itself will not be changed.

For those of you pointing at master, I am merging in the changes today that put us on the official Ruby driver... There are some backwards incompatible changes, see the changelog for details: https://github.com/mongoid/mongoid/blob/master/CHANGELOG.md

If you aren't ready for this yet, your last safe commit before the merge is d0c460a7fe5601d52bccedf228242ff6f5665ba0


Jon

unread,
Jul 24, 2015, 9:16:02 AM7/24/15
to Mongoid, dur...@gmail.com
Durran, do you have an updated timeline for the first Mongoid 5 release? We're very eager to start testing MongoDB 3.0 but this is the blocker for us.

Durran Jordan

unread,
Jul 24, 2015, 10:27:43 AM7/24/15
to Jon, Mongoid
The beta is already out, the official should be the end of next week. The docs are already up here:

http://docs.mongodb.org/ecosystem/tutorial/ruby-mongoid-tutorial/#ruby-mongoid-tutorial

Daniel Doubrovkine

unread,
Jul 24, 2015, 11:38:46 AM7/24/15
to mon...@googlegroups.com, Jon
There's also a number of related gems that could use your help with the upgrade! I did two and started a list here: http://code.dblock.org/2015/07/24/getting-things-done-with-mongoid-5.html

--

---
You received this message because you are subscribed to the Google Groups "Mongoid" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mongoid+u...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Reply all
Reply to author
Forward
0 new messages