anyone using nscala-time 2.0.0 with casbah 2.8.0?

11 views
Skip to first unread message

John Sullivan

unread,
Jul 24, 2015, 3:58:43 PM7/24/15
to mongodb-casbah-users
Hi there!

I see casbah is using nscala-time 1.0.0. I'm running with nscala-time 2.0.0 and I'm getting the following "evicted" warning from SBT:

[warn] There may be incompatibilities among your library dependencies.

[warn] Here are some of the libraries that were evicted:

[warn]  * com.github.nscala-time:nscala-time_2.11:1.0.0 -> 2.0.0

[warn] Run 'evicted' to see detailed eviction warnings


So SBT is kicking out nscala-time 1.0.0 in favor of nscala-time 2.0.0.


I've been running a few tests and casbah seems to be working fine against nscala-time 2.0.0, but I don't want to get bit by this later on. Does anyone have any experience running casbah against this later version of nscala-time? Should I back down to the earlier version just in case?


Any plans to update version of this casbah dependency?


Thanks! -John

Reply all
Reply to author
Forward
0 new messages