minion worker and docker as non-root - help

21 views
Skip to first unread message

Scott Harpster

unread,
Jun 26, 2020, 2:02:22 PM6/26/20
to Mojolicious
I am creating a medium sized mojolicious web application, I was going to mention it this morning in the BOF Mojo at the virtual conference but with 40 people+ didn't think it would have been appropriate. I <3 Mojo and after diving from frameworks to frameworks and different languages over the years, mojo is so flexible and light, its awesome. Huge thanks.

My system is using Minion and Hypnotoad and I have a supervisord config file that spawns both of those services. I set up them to run as a non-root user, chown the web path just in case to that non-root user. Hypnotoad runs expected but minion just stalls. If i attach to the container and attempt to run it manually, same thing. ./script/app minion worker -j 4 -m production

If i set it as root or attach as root and manually run it, it works...I tried looking for a debug environment variable but didnt see anything. Looking for any suggestions.

Worst case is i run minion as root...and web as non-root...
Reply all
Reply to author
Forward
0 new messages