Undefined symbol: notification_reason_name

13 views
Skip to first unread message

Bruce Smith

unread,
May 16, 2017, 3:57:44 AM5/16/17
to mod_gearman
Hello

I am attempting to use this combination of packages:

  • CentOS 6.9 64-bit
  • Nagios 3.5.1
  • Gearmand 0.33
  • mod_gearman 3.0.2-1

Gearmand and mod_gearman were installed from the consol labs repository after adding the repo file as described at  https://labs.consol.de/repo/stable/#_6 

In the Nagios main configuration, I have the simple broker_module statement:

broker_module=/usr/lib64/mod_gearman/mod_gearman_nagios3.o config=mod_gearman.conf

That configuration file contains:

perfdata=yes
perfdata_mode=1
keyfile=/usr/local/pnp4nagios/etc/secret.key
server=localhost
eventhandler=no
hosts=no
services=no
notifications=no

When Nagios is restarted, I get this message in the Nagios log

 Error: Could not load module '/usr/lib64/mod_gearman/mod_gearman_nagios3.o' -> /usr/local/nagios/var/spool/checkresults/nebmodLOHUBV: undefined symbol: notification_reason_name

Should the above combination of software levels work? If not, please give me your best estimate of a working combination of gearmand and mod_gearman for Nagios 3.5.1.

Regards
Bruce

Sven Nierlein

unread,
May 16, 2017, 4:09:22 AM5/16/17
to mod_g...@googlegroups.com
On 16/05/17 9:57, Bruce Smith wrote:
> When Nagios is restarted, I get this message in the Nagios log
>
> Error: Could not load module '/usr/lib64/mod_gearman/mod_gearman_nagios3.o' -> /usr/local/nagios/var/spool/checkresults/nebmodLOHUBV: undefined symbol: notification_reason_name

That sounds like it looks for some nagios4/naemon symbols which would indicate a build error.

> Should the above combination of software levels work? If not, please give me your best estimate of a working combination of gearmand and mod_gearman for Nagios 3.5.1.

Yes, it should work just fine. Could you try the previous release from: https://mod-gearman.org/pkg/v3.0.1/rhel6/x86_64/

Bruce Smith

unread,
May 16, 2017, 4:56:46 AM5/16/17
to mod_gearman
Hello Sven

Thank you for your very prompt response. I have reverted to 3.0.1 and that has loaded without error. Indeed appears as if 3.0.2-1 has some problem.

Best Regards
Bruce

Sven Nierlein

unread,
May 16, 2017, 5:02:10 AM5/16/17
to mod_g...@googlegroups.com
On 16/05/17 10:56, Bruce Smith wrote:
> Thank you for your very prompt response. I have reverted to 3.0.1 and that has loaded without error. Indeed appears as if 3.0.2-1 has some problem.

I will have a look. Besides that, there are no issues in the 3.0.1 afaik... The only thing changed is the support of notifications.


Sven Nierlein

unread,
May 16, 2017, 2:45:35 PM5/16/17
to mod_g...@googlegroups.com
On 16/05/17 10:56, Bruce Smith wrote:
> Hello Sven
>
> Thank you for your very prompt response. I have reverted to 3.0.1 and that has loaded without error. Indeed appears as if 3.0.2-1 has some problem.
>
> Best Regards
> Bruce

Thanks for your report, i just fixed it:
https://github.com/sni/mod_gearman/commit/df8aac9b27ea5dec9c748ef1b6e155ebe9f9b022
Will be ok in the next release again.

Cheers,
Sven

Reply all
Reply to author
Forward
0 new messages