mod_spdy Debian and RPM packages launched!

345 views
Skip to first unread message

Bryan McQuade

unread,
Apr 17, 2012, 3:28:49 PM4/17/12
to mod-spdy-discuss
Thanks everyone for testing out the preview packages we sent links to
earlier. Earlier today we sent out an announcement to launch Debian
and RPM packages.

Here's a blog post with the announcement:
http://googledevelopers.blogspot.com/2012/04/add-spdy-support-to-your-apache-server.html
and here's a page with links to download the packages:
https://developers.google.com/speed/spdy/mod_spdy/

Please give the packages a try and let us know how they work for you.
Thanks!

Alexander Sibert

unread,
Apr 17, 2012, 5:14:57 PM4/17/12
to mod-spdy...@googlegroups.com
Will be mod_spdy the official release for apache2 Webserver or launch company apache a own solution in near future?

Kuno Woudt

unread,
Apr 17, 2012, 9:28:53 PM4/17/12
to mod-spdy...@googlegroups.com
Hello,
 Just installed this on a VPS with Debian Squeeze.  In general things worked out of the box for me, I didn't have to make any configuration changes.  So, that's very promising so far.

However, my piwik install isn't working with mod_spdy installed, I see the following in the logs:

==> access.log <==
186.xx.xx.xx - - [18/Apr/2012:01:25:18 +0000] "GET /piwik/ HTTP/1.1" 200 0 "-" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.66 Safari/535.11"

==> error.log <==
[Wed Apr 18 01:25:18 2012] [warn] [client 186.xx.xx.xx] [1436:1436:WARNING:spdy_session.cc(367)] Client sent RST_STREAM with PROTOCOL_ERROR for stream 1.  Aborting stream and sending GOAWAY.

I thought it might be a general php problem, but a simple "<?php phpinfo(); ?>" in an info.php works without trouble on the same host, inside the piwik directory. Please let me know if there's anything I can do on my end to debug this issue.

-- Kuno.

Michael Pfister

unread,
Apr 18, 2012, 4:14:01 AM4/18/12
to mod-spdy...@googlegroups.com
Up and running on Ubuntu Server 11.04 / Zend Server without any issues so far, all applications work as expected.

Thanks for this release :)

Lars Kneschke

unread,
Apr 18, 2012, 6:34:05 AM4/18/12
to mod-spdy...@googlegroups.com
Hello!

I can confirm the same problem.

Accessing a script with phpinfo() only works as expected.

Trying to access our groupware (Tine 2.0) loads all JavaScript and CSS files, but breaks when trying to access a .php file.

That's from my error_log if it breaks completely:

... [stream 993] [13175:14938:WARNING:http_to_spdy_filter.cc(113)] HttpToSpdyFilter is not the last filter in the chain: http_to_spdy
... [stream 997] [13175:14960:ERROR:spdy_to_http_filter.cc(267)] Invalid SYN_STREAM header block on stream 997
... [13175:13217:WARNING:spdy_session.cc(230)] Client sent DATA (length=72) for nonexistant stream 997
... [13175:13217:WARNING:spdy_session.cc(230)] Client sent DATA (length=0) for nonexistant stream 997

I'm running Ubuntu 11.10.

Lars

Stefan Häck

unread,
Apr 18, 2012, 6:52:38 AM4/18/12
to mod-spdy...@googlegroups.com
Hello,

I also can confirm this problem.

Debian 6
PHP Version 5.3.3-7+squeeze8
Linux 2.6.32-5-amd64

Loaded Modules
core mod_log_config mod_logio prefork http_core mod_so mod_alias mod_auth_basic mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_dav mod_dav_fs mod_dav_svn mod_authz_svn mod_deflate mod_dir mod_env mod_expires mod_headers mod_mime mod_negotiation mod_php5 mod_reqtimeout mod_rewrite mod_setenvif mod_ssl mod_status
 
 
[Wed Apr 18 08:12:23 2012] [notice] child pid 8470 exit signal Segmentation fault (11)
[Wed Apr 18 08:12:23 2012] [notice] child pid 8473 exit signal Segmentation fault (11)
[Wed Apr 18 08:12:23 2012] [notice] child pid 8476 exit signal Segmentation fault (11)

[Wed Apr 18 08:16:53 2012] [warn] [client 192.168.10.1] [stream 1] [9179:9180:WARNING:http_to_spdy_filter.cc(113)] HttpToSpdyFilter is not the last filter in the chain: http_to_spdy
[Wed Apr 18 08:16:53 2012] [warn] [client 192.168.10.1] [stream 1] [9179:9180:WARNING:http_to_spdy_filter.cc(113)] HttpToSpdyFilter is not the last filter in the chain: http_to_spdy

Stefan

James Brown

unread,
Apr 18, 2012, 7:51:46 AM4/18/12
to mod-spdy...@googlegroups.com

When's the Mac OS X package going to be released?

:-)

James.

Kuno Woudt

unread,
Apr 18, 2012, 4:04:53 PM4/18/12
to mod-spdy...@googlegroups.com
Hello,

I just tried mydomain/piwik with a different client machine.

On 17/04/12 20:28, Kuno Woudt wrote:
> However, my piwik install isn't working with mod_spdy installed, I see
> the following in the logs:
>
> ==> access.log <==
> 186.xx.xx.xx - - [18/Apr/2012:01:25:18 +0000] "GET /piwik/ HTTP/1.1" 200
> 0 "-" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.11 (KHTML, like
> Gecko) Chrome/17.0.963.66 Safari/535.11"

my piwik install works on this client, but the request doesn't show up
in chrome://net-internals/#spdy, so for some reason spdy isn't enabled
for this particular connection even though spdy is working for other
urls on the same domain (and other domains on the same host).

This is a log entry:

186.xx.xxx.xx - - [18/Apr/2012:19:50:50 +0000] "POST /piwik/ HTTP/1.1"
302 948 "https://frob.nl/piwik/" "Mozilla/5.0 (X11; Linux x86_64)
AppleWebKit/536.6 (KHTML, like Gecko) Chrome/20.0.1096.1 Safari/536.6"

-- Kuno.
ps, my apache2ctl -M output:

Loaded Modules:
core_module (static)
log_config_module (static)
logio_module (static)
mpm_prefork_module (static)
http_module (static)
so_module (static)
alias_module (shared)
auth_basic_module (shared)
auth_pam_module (shared)
auth_sys_group_module (shared)
authn_file_module (shared)
authz_default_module (shared)
authz_groupfile_module (shared)
authz_host_module (shared)
authz_user_module (shared)
autoindex_module (shared)
cgi_module (shared)
deflate_module (shared)
dir_module (shared)
env_module (shared)
fcgid_module (shared)
geoip_module (shared)
headers_module (shared)
mime_module (shared)
negotiation_module (shared)
php5_module (shared)
reqtimeout_module (shared)
rewrite_module (shared)
setenvif_module (shared)
spdy_module (shared)
ssl_module (shared)
status_module (shared)
Syntax OK

Leonid Batizhevsky

unread,
Apr 28, 2012, 5:50:35 AM4/28/12
to mod-spdy...@googlegroups.com
I has problem too:

CentOS release 5.8 (Final)
apache 2.2.4-9
proxy_ajp

to every spdy request I've got:
[Sat Apr 28 13:44:19 2012] [notice] child pid 9656 exit signal Segmentation fault (11)



среда, 18 апреля 2012 г., 14:52:38 UTC+4 пользователь Stefan Häck написал:
Reply all
Reply to author
Forward
0 new messages