Ubuntu 22.04 Jammy Jellyfish cards not shown

29 views
Skip to first unread message

Lucas Eichhorn

unread,
May 24, 2022, 1:56:24 AMMay 24
to mnemosyne-proj-users
See the attached screenshot. Mnemosyne starts but the card is not shown. Only a blank page with “Answer” in the left middle part. I already installed mnemosyne manually.
Anyone else experience this? What could I do?
Bildschirmfoto vom 2022-05-24 06-24-49.png

Peter Bienstman

unread,
May 24, 2022, 2:49:57 AMMay 24
to mnemosyne-proj-users
What happens if you (re)move config.db? It could be that an upgrade of the GUI library caused the saved window sizes to become invalid...

Is the problem solved if you use Ubuntu's official Mnemosyne package? If not, then you should contact the Ubuntu developers of the Mnemosyne package.

Cheers,

Peter

Lucas Eichhorn

unread,
May 24, 2022, 4:23:43 AMMay 24
to mnemosyne-proj-users
Removing config.db does not change anything. I had the problem when I upgraded to 22.04. But the problem persits when I removed the folder, uninstalled mnemosyne and reinstalled it both from official packages or manually.

Peter Bienstman

unread,
May 24, 2022, 4:26:55 AMMay 24
to mnemosyne-proj-users
If you also have it with the official Ubuntu packages, then I suggest you contact the Ubuntu developers. I suspect an upgrade to Qt broke things in 22.04. Perhaps there is a message in the console which is suspicious and gives a clue. Alternatively, downgrading Qt might also help.

Peter

Lucas Eichhorn

unread,
May 30, 2022, 12:36:49 AMMay 30
to mnemosyne-proj-users
The message that shows up when I lauch mnemosyne from the console is only:
Warning: Could not import OpenGL. Might cause a black screen on some Linux distributions. Try installing python3-opengl in that case.
And I don't think that's a clue here. (?)

Quick question: How do I properly uninstall a manually installed version? I want to install the official package version to then maybe file an official bug with it.

Thanks!

Peter Bienstman

unread,
May 30, 2022, 11:04:37 AMMay 30
to mnemosyne-proj-users
The files are stored in the site-packages directory of your Mnemosyne install. If you want to know exactly where that is on your particular system, just reinstall from source, and it will print all the files it installs.

Peter

--
You received this message because you are subscribed to the Google Groups "mnemosyne-proj-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mnemosyne-proj-u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/mnemosyne-proj-users/28ba75b8-0299-412a-98a1-1d187ddae910n%40googlegroups.com.

Lucas Eichhorn

unread,
Jun 2, 2022, 2:37:17 AMJun 2
to mnemosyne-proj-users
I filed a bug report after installing it from official packages. Waiting.

I also installed version 2.7.3 (after removing the official package version). Before I had some problem with 2.8 (didn't look too much into it) and then it worked with version 2.7.3. Now the problem still persists, even with the older version. Seems to me like it has to do with the Ubuntu version. I'm curious if anybody else with Ubuntu 22.04 has this problem.

Lucas Eichhorn

unread,
Jul 13, 2022, 9:28:32 AMJul 13
to mnemosyne-proj-users
Hi,
no sign yet from developers, and I would really like to have mnemosyne back. You mentioned Qt. Do you have an idea towards that?

Or an alternative solution of what I can do instead to get some version of mnemosyne running?

Regarding Qt: the python packages I have installed are:
(mnemo) lucas@jarvis42:~$ pip list
Package              Version
-------------------- -----------
argon2-cffi          21.3.0
argon2-cffi-bindings 21.2.0
certifi              2022.5.18.1
cffi                 1.15.0
chardet              3.0.4
charset-normalizer   2.0.12
cheroot              8.6.0
click                8.1.3
cycler               0.11.0
fonttools            4.33.3
googletrans          3.0.0
gTTS                 2.2.4
h11                  0.9.0
h2                   3.2.0
hpack                3.0.0
hstspreload          2021.12.1
httpcore             0.9.1
httpx                0.13.3
hyperframe           5.2.0
idna                 2.10
jaraco.functools     3.5.0
kiwisolver           1.4.3
matplotlib           3.5.2
Mnemosyne            2.9
more-itertools       8.13.0
numpy                1.22.4
packaging            21.3
Pillow               9.1.1
pip                  21.2.4
pycparser            2.21
pyparsing            3.0.6
PyQt5                5.15.6
PyQt5-Qt5            5.15.2
PyQt5-sip            12.9.0
PyQtWebEngine        5.15.5
PyQtWebEngine-Qt5    5.15.2
python-dateutil      2.8.2
requests             2.28.0
rfc3986              1.5.0
setuptools           59.4.0
sip                  6.4.0
six                  1.16.0
sniffio              1.2.0
toml                 0.10.2
urllib3              1.26.9
WebOb                1.8.7
wheel                0.37.1

And the Ubuntu packages I have installed regarding qt are:
(mnemo) lucas@jarvis42:~$ apt list --installed | grep qt
WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
avidemux-plugins-qt/jammy,now 1:2.8.0-2~xtradeb2 amd64  [Installiert,automatisch]
avidemux-qt-data/jammy,jammy,now 1:2.8.0-2~xtradeb2 all  [Installiert,automatisch]
avidemux-qt/jammy,now 1:2.8.0-2~xtradeb2 amd64  [installiert]
gnuplot-qt/jammy,now 5.4.2+dfsg2-2 amd64  [Installiert,automatisch]
libavidemux6-qt/jammy,now 1:2.8.0-2~xtradeb2 amd64  [Installiert,automatisch]
libpoppler-qt5-1/jammy,now 22.02.0-2 amd64  [Installiert,automatisch]
libqt5concurrent5/jammy,now 5.15.3+dfsg-2 amd64  [Installiert,automatisch]
libqt5core5a/jammy,now 5.15.3+dfsg-2 amd64  [Installiert,automatisch]
libqt5dbus5/jammy,now 5.15.3+dfsg-2 amd64  [Installiert,automatisch]
libqt5gui5/jammy,now 5.15.3+dfsg-2 amd64  [Installiert,automatisch]
libqt5network5/jammy,now 5.15.3+dfsg-2 amd64  [Installiert,automatisch]
libqt5printsupport5/jammy,now 5.15.3+dfsg-2 amd64  [Installiert,automatisch]
libqt5sql5-sqlite/jammy,now 5.15.3+dfsg-2 amd64  [Installiert,automatisch]
libqt5sql5/jammy,now 5.15.3+dfsg-2 amd64  [Installiert,automatisch]
libqt5svg5/jammy,now 5.15.3-1 amd64  [Installiert,automatisch]
libqt5widgets5/jammy,now 5.15.3+dfsg-2 amd64  [Installiert,automatisch]
libqt5x11extras5/jammy,now 5.15.3-1 amd64  [Installiert,automatisch]
libqt5xml5/jammy,now 5.15.3+dfsg-2 amd64  [Installiert,automatisch]
qt5-gtk-platformtheme/jammy,now 5.15.3+dfsg-2 amd64  [Installiert,automatisch]
qttranslations5-l10n/jammy,jammy,now 5.15.3-1 all  [Installiert,automatisch]
transmission-qt/jammy,now 3.00-2ubuntu2 amd64  [installiert]

Thanks!

Peter Bienstman

unread,
Jul 13, 2022, 10:47:12 AMJul 13
to mnemosyne-proj-users
You could try to downgrade Qt to the version that was used in the previous Ubuntu release, but that's probably tricky. 

Alternatively, perhaps the Windows installer runs under Wine? 

Peter 

You received this message because you are subscribed to a topic in the Google Groups "mnemosyne-proj-users" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/mnemosyne-proj-users/fc-4oSxX72g/unsubscribe.
To unsubscribe from this group and all its topics, send an email to mnemosyne-proj-u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/mnemosyne-proj-users/545a59a8-e97c-4f10-861a-a2cccddb3f2en%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages