Attemp to install 2.9 failed

14 views
Skip to first unread message

Jim Ivy

unread,
Jul 12, 2022, 1:30:55 AMJul 12
to mnemosyne-proj-users
2.7 was working fine from my distribution installation (AVL-MX21). But I wanted to update to 2.9, so I downloaded the file and followed the instructions.

Now I get this when I try to run mnemosyne:

An unexpected error has occurred.

Please forward the following info to the developers:


Traceback (innermost last):

File "/usr/local/bin/mnemosyne", line 4, in <module>

__import__('pkg_resources').run_script('Mnemosyne==2.9', 'mnemosyne')

File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 651, in run_script

self.require(requires)[0].run_script(script_name, ns)

File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 1448, in run_script

exec(code, namespace, namespace)

File "/usr/local/lib/python3.9/dist-packages/Mnemosyne-2.9-py3.9.egg/EGG-INFO/scripts/mnemosyne", line 278, in <module>

mnemosyne.initialise(data_dir=data_dir, filename=filename,

File "/usr/local/lib/python3.9/dist-packages/Mnemosyne-2.9-py3.9.egg/mnemosyne/libmnemosyne/__init__.py", line 411, in initialise

self.register_components()

File "/usr/local/lib/python3.9/dist-packages/Mnemosyne-2.9-py3.9.egg/mnemosyne/libmnemosyne/__init__.py", line 476, in register_components

importlib.import_module(module_name), class_name)

File "/usr/lib/python3.9/importlib/__init__.py", line 127, in import_module

return _bootstrap._gcd_import(name[level:], package, level)

File "<frozen importlib._bootstrap>", line 1030, in _gcd_import

File "<frozen importlib._bootstrap>", line 1007, in _find_and_load

File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked

File "<frozen importlib._bootstrap>", line 680, in _load_unlocked

File "<frozen importlib._bootstrap_external>", line 790, in exec_module

File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed

File "/usr/local/lib/python3.9/dist-packages/Mnemosyne-2.9-py3.9.egg/mnemosyne/pyqt_ui/qt_sync_server.py", line 15, in <module>

from mnemosyne.libmnemosyne.sync_server import SyncServer

File "/usr/local/lib/python3.9/dist-packages/Mnemosyne-2.9-py3.9.egg/mnemosyne/libmnemosyne/sync_server.py", line 9, in <module>

from argon2 import PasswordHasher

ModuleNotFoundError: No module named 'argon2'


When I tried to reinstall the distribution 2.7 version, I still get the same message. How do I completely remove the failed 2.9 installation and go back to the 2.7 version?

Peter Bienstman

unread,
Jul 12, 2022, 1:32:34 AMJul 12
to mnemosyne-proj-users

--
You received this message because you are subscribed to the Google Groups "mnemosyne-proj-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mnemosyne-proj-u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/mnemosyne-proj-users/83e7d60f-dacc-47bb-8749-92e9441d9509n%40googlegroups.com.

Jim Ivy

unread,
Jul 14, 2022, 12:57:12 AMJul 14
to mnemosyne-proj-users
Thank you for the reply. I was able to remove enough to get 2.7 working again. I will probably wait until 2.9 hits the repo since 2.7 works quite well on my system.
Mnemosyne is really an excellent tool for musicians.
Reply all
Reply to author
Forward
0 new messages