Unified Magic Lantern - new release (now with 50D and 500D)

5689 views
Skip to first unread message

Alex

unread,
Oct 27, 2011, 6:48:30 AM10/27/11
to ml-d...@googlegroups.com
New update (still experimental and not thoroughly tested):

DOWNLOAD (550D, 60D, 600D, 500D and 50D):
https://bitbucket.org/hudson/magic-lantern/downloads/magiclantern-2011Oct27.550D.60D.600D.50D.500D.zip

* As you know, 500D joined the unified tree a few days ago. For more
details, check Coutts' messages here http://bit.ly/ml-500d-alpha and
here http://bit.ly/ml-oct26-t1i .
- Since the source code is unified, all other cameras now benefit from
his fixes (of course, as long as they are in the common section).
- For 500D, it should be 99% identical to the one posted by Coutts
(only a few minor adjustments were made, but not tested).

* Important change in audio meters:
- they are red over -3 dB, yellow over -12 dB, and green over -25 dB.
Let me know if those numbers make sense.
- they no longer display average level, but a decayed peak level, it's
much more accurate IMO.
- I'm not an expert in audio, so if you have dedicated equipment,
please test it and report the results.

* Powersaving
- fixed ERR80 which could appear when turning display off and then
holding the shutter pressed halfway
- when you cover the LCD sensor, timeouts will drop to 3 seconds (550D/500D)

* Bulb exposure:
- fixed bulb timer/ramping on 600D (I can't believe only one user
tried it since August; according to the user who reported the problem,
it was only working in July version)
- bulb ramping now obeys Auto ISO limit from Canon menu (recommended
setting is 6400, otherwise it will be forced to underexpose)
- calibration should be more robust regarding tricky scenes
- delays used when computing exposure for next shot are much smaller now

* Other changes:
- red cross notification enabled by default [!]
- bracketing can be cancelled by turning the mode dial or by opening the menu
- silent timelapse with powersaving should no longer result in
corrupted images (I couldn't reproduce the crash though)
- ISO on HDMI should work now (not tested)
- changed audio trigger formula (should react a bit faster)
- 50D contains some screen layout changes from 500D (not tested, but
their screen layouts are similar)

Side note: I've noticed a little slowdown (around 1 second) when
loading the big autoexec for all cameras with the class2 card
(compared to the smaller autoexec for a single camera). No slowdown at
all with the class10 card. This only happens at the first LED blink
(after that, only the part specific to your camera part is kept in
memory, the rest is discarded).

Johnby

unread,
Oct 27, 2011, 7:53:30 AM10/27/11
to Magic Lantern firmware development
This is a required parameter. I work in television and digital audio
-12db value is important.
If possible, make it possible to move the indicator level.
For example, the user can adjust the level. For example yellow was at
-10db, and the green at -20db

"- red cross notification" - I love this feature !!!!!!!!!!!!

Ash McKenzie

unread,
Oct 27, 2011, 6:25:50 PM10/27/11
to Magic Lantern firmware development
I Agree the audio meters are looking great, there is a wee bug that
has bee poping up now in then in the 600d and is a big bug in this
lastest experimental, the flash shortcut stick with almost every
record, as soon as you hit record it pops up and you can tap one to
remove but as soon as you press record again (standby) its back

On Oct 27, 11:48 pm, Alex <broscutama...@gmail.com> wrote:
> New update (still experimental and not thoroughly tested):
>
> DOWNLOAD (550D, 60D, 600D, 500D and 50D):https://bitbucket.org/hudson/magic-lantern/downloads/magiclantern-201...

Jan Larmann

unread,
Oct 27, 2011, 7:11:19 PM10/27/11
to Magic Lantern firmware development
audio not working 600d,

Ash McKenzie

unread,
Oct 27, 2011, 10:34:27 PM10/27/11
to Magic Lantern firmware development
do you mean the audio menu??? Cause the audio record is fine on my
600d

On Oct 28, 12:11 pm, Jan Larmann <larmann...@gmail.com> wrote:
> audio not working 600d,

Alex

unread,
Oct 28, 2011, 1:55:27 AM10/28/11
to ml-d...@googlegroups.com
> I Agree the audio meters are looking great, there is a wee bug that
> has bee poping up now in then in the 600d and is a big bug in this
> lastest experimental, the flash shortcut stick with almost every
> record, as soon as you hit record it pops up and you can tap one to
> remove but as soon as you press record again (standby) its back

10 days ago, I wrote:

"""
600d: hopefully fixed issue 688 (problem with rode videomic) - not
tested, let me know if it works
"""
No reply received.

Also here: https://bitbucket.org/hudson/magic-lantern/issue/688/600d-disp-profile-issue-with-hotshoe
Again, no feedback received.

> audio not working 600d
This comment does not help me at all in locating/fixing the problem.

I'm sorry, but I can't continue supporting the 600D without having a
camera for testing.

> --
> http://magiclantern.wikia.com/
>
> To post to this group, send email to ml-d...@googlegroups.com
> To unsubscribe from this group, send email to ml-devel+u...@googlegroups.com
> For more options, visit this group at http://groups.google.com/group/ml-devel?hl=en
>

Scotty

unread,
Oct 28, 2011, 2:58:09 PM10/28/11
to Magic Lantern firmware development
Audio IS working just fine on 600d. Maybe reinstall or look through
your settings. Thank you SO MUCH for all of the work, Alex. I've been
away from here for a little bit , but so far with this update I
haven't found anything askew with the 600d. I will be using my camera
quite a bit this weekend so I will report back with any issues.

On Oct 27, 11:55 pm, Alex <broscutama...@gmail.com> wrote:
> > I Agree the audio meters are looking great, there is a wee bug that
> > has bee poping up now in then in the 600d and is a big bug in this
> > lastest experimental, the flash shortcut stick with almost every
> > record, as soon as you hit record it pops up and you can tap one to
> > remove but as soon as you press record again (standby) its back
>
> 10 days ago, I wrote:
>
> """
> 600d: hopefully fixed issue 688 (problem with rode videomic) - not
> tested, let me know if it works
> """
> No reply received.
>
> Also here:https://bitbucket.org/hudson/magic-lantern/issue/688/600d-disp-profil...

Stifa

unread,
Oct 28, 2011, 4:05:17 PM10/28/11
to Magic Lantern firmware development
Why am I getting new folders DCIM/100CANON , 101CANON, 102CANON on
the card...I have all three ?

Justin Williamson

unread,
Oct 28, 2011, 4:52:38 PM10/28/11
to Magic Lantern firmware development
You either shot a lot of pics, video, or both.
When the camera gets to 9999 it creates a new directory. (Default
Canon feature)

Stifa

unread,
Oct 29, 2011, 2:59:44 AM10/29/11
to Magic Lantern firmware development
To be honest , I have 550d for a year , and before that I had 450d for
couple of years with 9k shots and it seems crazy that I have 20k shots
a year, Could this be related to ML ? What is your shutter count? Is
there a way to reset the shutter count?

Cheers

mart

unread,
Oct 29, 2011, 6:37:55 PM10/29/11
to ml-d...@googlegroups.com
Thank you, Alex ! Awesome work !


- when you cover the LCD sensor, timeouts will drop to 3 seconds (550D/500D)
Now, taking night photo (when phase autofocus and optical viewfinder are useless) became more handy.

One more thing, in terms of user experience (correct me if I'm wrong):
100% zoom should be enabled only after a photo was taken, and disabled if user has no intention to check the focus.
It's annoying when you already want to navigate through the photos and simulate some slight crop in play mode, and it goes to 100% each time.

And again (of course, hopefully) this can be implemented in a simple fashion, like this:
- if a photo was taken - enable 100% zoom
- in play mode, after any operation has been completed - disable 100% zoom
- optionally: in shooting mode, if any external event was triggered, expect playmode button and shot button "complete press" -  disable 100% zoom.

Of course, all these are only for 100% zoom mode selected from settings.


Redkite Bart

unread,
Oct 30, 2011, 3:40:01 PM10/30/11
to Magic Lantern firmware development
> I'm sorry, but I can't continue supporting the 600D without having a
> camera for testing.

Hi Alex,

I'll try to give more feedback on the 600d. I worked through some new
features and really love the HDR Exposurefusion preview in play mode.
I finally found the kelvin/iso shortcuts. Flashbutton is not on a
convenient spot, the new DISP button (coming from 550d) would be much
better but not for the 550d. Since the DISP button has no function in
video mode it might be programmed the same as flash. That's better for
600d and 550d can use flash as well.
About the audio the meters only show in record mode, not in standby.
You can set record level in the canon menu while monitoring. Adjusting
levels during recording is not possible. I think this is already known
and has to do with the new soundchip. The default audiolevel seems to
work great in many cases and never gave me distortion.
I was confused about the bulb mode and just found out it exists only
in M mode when dialing shutterspeed below 30 sec. I love to try this
feature but we have so much city light pollution there are only few
stars in the sky at best. The time set in ML bulb mode works fine. I
will try the bulb ramping soon and let you know my reults

Bart

All the rest I tried worked fine and again superb work. Thanks

Ash McKenzie

unread,
Nov 1, 2011, 4:08:11 PM11/1/11
to Magic Lantern firmware development
Man the audio meters are good now, when I send -12db tone to camera
the metre previous would vary about -/+ 7db now its like -/+ 3db and
they feel real solid
Message has been deleted

Andrew Coutts

unread,
Nov 1, 2011, 6:06:48 PM11/1/11
to Magic Lantern firmware development
start studying how audio file buffers are created/used during video
recording ;)


On Nov 1, 5:01 pm, Zibri <zib...@gmail.com> wrote:
> I have a killer feature for the next release:
>
> Since the 550D (for example) as a microphone, it would be GREAT to be
> able to do this:
>
> While reviewing a photo, press a key and record a short memo. The memo
> should be saved with the pic name and wav or other extension.
>
> What do you think?
Message has been deleted

Zibri

unread,
Nov 1, 2011, 6:08:20 PM11/1/11
to Magic Lantern firmware development
I have a killer feature for the next release:
Since the 550D (for example) has a microphone, it would be GREAT to

RedKiteMedia

unread,
Nov 3, 2011, 6:57:20 AM11/3/11
to Magic Lantern firmware development
I tried the version from yesterday (2nov) on 600d with the shortcut
button for ISO/WB moved from flash to disp. This is nice.
But I noticed something else.
If you select WhiteBalance in the ML menu with Q you get into a nice
looking menu with a bar on the bottom displaying ISO and Kelvins. In
this menu the shortcut button DISP works as well. Only here you can't
see the mini iso[+][-] kelvin[+][-] but you see the exact iso/kelvin
values.
What would be great is when you hold DISP outside the ML menu to get
into that exact same menu as straight from the ML menu with the mini
iso[+] and so on displayed. I will use this a lot in the future.

RedKiteMedia

unread,
Nov 3, 2011, 7:03:08 AM11/3/11
to Magic Lantern firmware development
Oh one more thing.
I don't have the camera right now but I think you get into the nice
menu in ML with the [SET] button instead of the [Q]
With normal use of the [DISP] button (flash on others) you can't see
the kelvin and exact iso values. Only the canon default isos.

Andy P

unread,
Nov 4, 2011, 1:09:09 PM11/4/11
to ml-d...@googlegroups.com
RedKiteMedia: I think I understand what you're saying but isn't the bottom bar always showing the shutter speed, ISO and Kelvin? It is on mine, with or without using the shortcut.

Alex: Moving the shortcut to the DISP button feels much better (the previous flash button shortcut was very fiddly while shooting).

The latest update also seems to have completely stabilized magic zoom and it doesn't flicker anymore (at least on my 600d).

BTW, this is my first post/reply in the group. I'm using ML on my 600d and I'll try to contribute and test as much as possible.

Andy

Redkite Bart

unread,
Nov 4, 2011, 6:22:56 PM11/4/11
to Magic Lantern firmware development
Hi Andy,
The version from today (4nov evening) has everything fixed it works
great now as well as the two ml menu modes. The only problem is
finding it back in this messy forum.
Oh and I seem to have two accounts the one above lives only in a
portable firefox version@work

scrax

unread,
Nov 5, 2011, 10:19:29 AM11/5/11
to ml-d...@googlegroups.com
Hi all, I'm reporting all the little bugs I've found in the 4 nov build in the issue tracker, and so please all the 600d tester here to check it and confirm or not the problems so to give Alex the best we can do to report those bug.

After resetting the camera to default settings and reinstalled ML from the bootflag with the last released fir, I've tested all the function in ML one by one in each mode Video, Photo and LiveView and that showed some problem i've never noticed.

Here the links:

Also I've found some things that maybe can be improved, tell what you think:

-Zebra edited with the scroolwheel is not a lot usable maybe switching Q with -SET will be better, focuspeak and MagicZoom are more usable. The question is: is the scrollwheel used at all to change values? Maybe it can be auto-enabled only on scrollable value like ISO for example and disabled for all the entrie that have 3 value or only a on and off switch.
-EXPO -> ISO & WB can't be set back to Auto.
-In Movie mode at 60fps MagicZoom flikers a lot, it looks transparent so maybe it flicks at nearly 20fps or more.
-DOF not working in movie mode (Is this a bug or not?).
-During REC digital zoom (3x 10x) is working even when the shortcut is enabled.
-Bulb timer sometimes shows an overlay with motion detect active (I didn't find out a pattern or something to reproduce this but seems related to the next)
-When an autotrigger events is enabled sometimes bulb timer with a "random" settings starts for tacking the pic instead of the value set.
-AutoBurst not useful in RAW, after 6 pics camera stops a lot before taking another one, the change from RAW to L need to be made earlier (after 4 pic maybe).
-In movie mode Flashlight enabled with Q don't goes off after pressing halfshutter.

Someone tried the stress test? Any problem?

All other functions are working good, but I have not tested Bulb ramping for the shutdown problem, flash exposure compensation, and bulb timer was tested only with a few minutes shot so really long time are not tested but they should work ok.

Don't click me was not clicked ;-)

 

scrax

unread,
Nov 6, 2011, 9:41:04 AM11/6/11
to ml-d...@googlegroups.com
A little update, I've tested again ML with the new build with Easy/Advanced menu and some problems are already solved, like the Ghost Image flickering and the Flashlight problem in LiveView.

-Magic Zoom flickerin video: http://youtu.be/xq32Zs_ZtiM I think that this issue is already known.

Alex

unread,
Nov 6, 2011, 4:59:30 PM11/6/11
to ml-d...@googlegroups.com
Thanks Scrax, I'll take a look at the reports.

Focus peak: I'll send you test builds where you will be able to align it from menu. If I remember well, 600D crops the image in movie mode a bit.
Ghost image: it flickered on first test, but not on subsequent tests. Need to test more.
Defish: fixed, but probably broken in 500D now.
799: I'll try to reproduce here
800: confirmed (on other cameras, calibration is much faster so it doesn't happen).

Scrollwheel is not reliable with all items (it just presses SET and PLAY). After implementing menu with submenus, it will be.
In 720p you should have a warning for magic zoom.
DOF makes no sense in movie mode.

Here's today's bleeding edge (with some significant changes, so be careful, there may be problems):
- On 60D I was able to enable wheel navigation in ML menu in LiveView
- In movie mode, photo functions are hidden from ML menu; same for photo mode.
- Special menu for PLAY mode (press MENU to enable it)

--
Magic Lantern needs you



On Sun, Nov 6, 2011 at 4:41 PM, scrax <scr...@gmail.com> wrote:
A little update, I've tested again ML with the new build with Easy/Advanced menu and some problems are already solved, like the Ghost Image flickering and the Flashlight problem in LiveView.

-Magic Zoom flickerin video: http://youtu.be/xq32Zs_ZtiM I think that this issue is already known.

--
autoexec.bin

Ash McKenzie

unread,
Nov 6, 2011, 7:13:06 PM11/6/11
to Magic Lantern firmware development
Can't wait to try this bulid, did you get my video Alex?? Sorry i pmed
it to your vimeo mailbox.

On Nov 7, 10:59 am, Alex <broscutama...@gmail.com> wrote:
> Thanks Scrax, I'll take a look at the reports.
>
> Focus peak: I'll send you test builds where you will be able to align it
> from menu. If I remember well, 600D crops the image in movie mode a bit.
> Ghost image: it flickered on first test, but not on subsequent tests. Need
> to test more.
> Defish: fixed, but probably broken in 500D now.
> 799: I'll try to reproduce here
> 800: confirmed (on other cameras, calibration is much faster so it doesn't
> happen).
>
> Scrollwheel is not reliable with all items (it just presses SET and PLAY).
> After implementing menu with submenus, it will be.
> In 720p you should have a warning for magic zoom.
> DOF makes no sense in movie mode.
>
> Here's today's bleeding edge (with some significant changes, so be careful,
> there may be problems):
> - On 60D I was able to enable wheel navigation in ML menu in LiveView
> - In movie mode, photo functions are hidden from ML menu; same for photo
> mode.
> - Special menu for PLAY mode (press MENU to enable it)
>
> --
> Magic Lantern needs you <http://goo.gl/79JgB>
>
>
>
>
>
>
>
> On Sun, Nov 6, 2011 at 4:41 PM, scrax <scri...@gmail.com> wrote:
> > A little update, I've tested again ML with the new build with
> > Easy/Advanced menu and some problems are already solved, like the Ghost
> > Image flickering and the Flashlight problem in LiveView.
>
> > -Magic Zoom flickerin video:http://youtu.be/xq32Zs_ZtiMI think that
> > this issue is already known.
>
> > --
> >http://magiclantern.wikia.com/
>
> > To post to this group, send email to ml-d...@googlegroups.com
> > To unsubscribe from this group, send email to
> > ml-devel+u...@googlegroups.com
> > For more options, visit this group at
> >http://groups.google.com/group/ml-devel?hl=en
>
>
>
>  autoexec.bin
> 1334KViewDownload

Arthur_Dn

unread,
Nov 6, 2011, 9:44:27 PM11/6/11
to Magic Lantern firmware development
Hi Alex,

i just installed the lastest build.

the scrollwheel trough the magic lantern menu isnt working on LV mode
but its cool to use it when it works out of LV mode.

the simplified menu with hidden features is nice too. i dont think the
play mode menu will be useful, unless it isnt working properly with
me. i thought it would come with new features but we can access it
from the ML standart menu. i see no reason to override the canon play
mode menu with this, but the build overall is cool. well done.

Alex

unread,
Nov 7, 2011, 12:40:09 PM11/7/11
to ml-d...@googlegroups.com
Today's update:

- Enabled scrollwheel in 550D's LiveView (yesterday this was only working on 60D)
- SET+scrollwheel changes values in ML menu
- Reworked menu event handler and fixed issue 799
- Fixed waveform accuracy on external monitors (from Ash's video)
- Fixed some small issues (800, 803)
- Disabled startup logo (it seems to create problems with some monitors, not 100% sure yet)
- On HDMI-VGA, ML menu is only resized in 16:9 and 16:10 screen layouts
- A few minor adjustments (see the changeset history for more details)

... and an easter egg at "Don't click me", in 550D only (try it in photo mode). This time, the 550D will be transformed into a 10000 yuan camera :)

The new menu event handler was not tested yet on other cameras. For users of 600D/500D/50D, please check:
- menu navigation (wheel should work in photo mode, but it's not enabled in LiveView)
- when you press SET, menu items should turn green; when you de-press SET, menu items should turn blue
- half-shutter should close ML menu
- erase button (or picturestyle on 50D) should close ML menu
- check menu navigation in the following modes: photo, LiveView, movie standby and recording
- camera should not crash if recording stops due to buffer overflow with ML menu active

For aligning focus peaking, here is a binary which allows you to adjust parameters from the menu until it looks right:
https://bitbucket.org/hudson/magic-lantern/issue/796/600d-focus-peak-issues

For Play mode, ML should only display the options which can be used there (the Play menu, zebras, histogram, false colors...)

As usual, this was only tested on 550D and 60D. That's it for today :)
autoexec.bin

Giovanni Di Cello

unread,
Nov 7, 2011, 1:34:46 PM11/7/11
to Magic Lantern firmware development
For 50D
Zebras and false colors are ok with bm2lv=0 in tx and -40 in ty.
In another try it was good with 0 and 0, i can't understand how it
works.
> parameters from the menu until it looks right:https://bitbucket.org/hudson/magic-lantern/issue/796/600d-focus-peak-...
>
> For Play mode, ML should only display the options which can be used there
> (the Play menu, zebras, histogram, false colors...)
>
> As usual, this was only tested on 550D and 60D. That's it for today :)
>
> --
> Magic Lantern needs you <http://goo.gl/79JgB>
>
> On Mon, Nov 7, 2011 at 4:44 AM, Arthur_Dn <meunomeunderlin...@gmail.com>wrote:
>
>
>
>
>
>
>
> > Hi Alex,
>
> > i just installed the lastest build.
>
> > the scrollwheel trough the magic lantern menu isnt working on LV mode
> > but its cool to use it when it works out of LV mode.
>
> > the simplified menu with hidden features is nice too. i dont think the
> > play mode menu will be useful, unless it isnt working properly with
> > me. i thought it would come with new features but we can access it
> > from the ML standart menu. i see no reason to override the canon play
> > mode menu with this, but the build overall is cool. well done.
>
> > --
> >http://magiclantern.wikia.com/
>
> > To post to this group, send email to ml-d...@googlegroups.com
> > To unsubscribe from this group, send email to
> > ml-devel+u...@googlegroups.com
> > For more options, visit this group at
> >http://groups.google.com/group/ml-devel?hl=en
>
>
>
>  autoexec.bin
> 1329KViewDownload

Benny

unread,
Nov 7, 2011, 1:58:08 PM11/7/11
to Magic Lantern firmware development
cant seem to find the dont click me on 550D
> parameters from the menu until it looks right:https://bitbucket.org/hudson/magic-lantern/issue/796/600d-focus-peak-...
>
> For Play mode, ML should only display the options which can be used there
> (the Play menu, zebras, histogram, false colors...)
>
> As usual, this was only tested on 550D and 60D. That's it for today :)
>
> --
> Magic Lantern needs you <http://goo.gl/79JgB>
>
> On Mon, Nov 7, 2011 at 4:44 AM, Arthur_Dn <meunomeunderlin...@gmail.com>wrote:
>
>
>
>
>
>
>
> > Hi Alex,
>
> > i just installed the lastest build.
>
> > the scrollwheel trough the magic lantern menu isnt working on LV mode
> > but its cool to use it when it works out of LV mode.
>
> > the simplified menu with hidden features is nice too. i dont think the
> > play mode menu will be useful, unless it isnt working properly with
> > me. i thought it would come with new features but we can access it
> > from the ML standart menu. i see no reason to override the canon play
> > mode menu with this, but the build overall is cool. well done.
>
> > --
> >http://magiclantern.wikia.com/
>
> > To post to this group, send email to ml-d...@googlegroups.com
> > To unsubscribe from this group, send email to
> > ml-devel+u...@googlegroups.com
> > For more options, visit this group at
> >http://groups.google.com/group/ml-devel?hl=en
>
>
>
>  autoexec.bin
> 1329KViewDownload

Chris71

unread,
Nov 7, 2011, 2:04:54 PM11/7/11
to Magic Lantern firmware development
Hi Alex,

thanks for the many small, but very useful improvements to the menu
system etc.

I noticed that my 550D now also is earlier responsive when starting
the camera. With the previous versions (including yesterdays), it
showed "BUSY" for 2-3 seconds (but only if logo.bmp wasn't present,
otherwise it showed the logo.) With today's version, it doesn't show
"BUSY" anymore but instead already responds to button presses. :-)
> parameters from the menu until it looks right:https://bitbucket.org/hudson/magic-lantern/issue/796/600d-focus-peak-...
>
> For Play mode, ML should only display the options which can be used there
> (the Play menu, zebras, histogram, false colors...)
>
> As usual, this was only tested on 550D and 60D. That's it for today :)
>
> --
> Magic Lantern needs you <http://goo.gl/79JgB>
>
> On Mon, Nov 7, 2011 at 4:44 AM, Arthur_Dn <meunomeunderlin...@gmail.com>wrote:
>
>
>
>
>
>
>
> > Hi Alex,
>
> > i just installed the lastest build.
>
> > the scrollwheel trough the magic lantern menu isnt working on LV mode
> > but its cool to use it when it works out of LV mode.
>
> > the simplified menu with hidden features is nice too. i dont think the
> > play mode menu will be useful, unless it isnt working properly with
> > me. i thought it would come with new features but we can access it
> > from the ML standart menu. i see no reason to override the canon play
> > mode menu with this, but the build overall is cool. well done.
>
> > --
> >http://magiclantern.wikia.com/
>
> > To post to this group, send email to ml-d...@googlegroups.com
> > To unsubscribe from this group, send email to
> > ml-devel+u...@googlegroups.com
> > For more options, visit this group at
> >http://groups.google.com/group/ml-devel?hl=en
>
>
>
>  autoexec.bin
> 1329KViewDownload

Andy P

unread,
Nov 7, 2011, 2:48:57 PM11/7/11
to ml-d...@googlegroups.com
Hi Alex. Just tested the latest build on my 600d


The new menu event handler was not tested yet on other cameras. For users of 600D/500D/50D, please check:
- menu navigation (wheel should work in photo mode, but it's not enabled in LiveView) Working only in photo mode as stated
- when you press SET, menu items should turn green; when you de-press SET, menu items should turn blue Working ok but the green is a bit dull/greyish
- half-shutter should close ML menu Works
- erase button (or picturestyle on 50D) should close ML menu Not tested
- check menu navigation in the following modes: photo OK, LiveView OK, movie standby and recording Working - Menu items show red background - no problems that I can see :)
- camera should not crash if recording stops due to buffer overflow with ML menu active Not had a buffer overflow yet to test


For Play mode, ML should only display the options which can be used there (the Play menu, zebras, histogram, false colors...) Only relevant options shown :)

Andy

scrax

unread,
Nov 7, 2011, 4:16:15 PM11/7/11
to ml-d...@googlegroups.com
I'm using the test build attached to the focus peak issue, so I think it's older than the one attached to this message:


Il giorno domenica 6 novembre 2011 22:59:30 UTC+1, Alex ha scritto:
Thanks Scrax, I'll take a look at the reports.

Focus peak: I'll send you test builds where you will be able to align it from menu. If I remember well, 600D crops the image in movie mode a bit.
Yes, i'm testing it right now...
Ghost image: it flickered on first test, but not on subsequent tests. Need to test more.
Defish: fixed, but probably broken in 500D now.
This is ok now. 
799: I'll try to reproduce here
800: confirmed (on other cameras, calibration is much faster so it doesn't happen).

Scrollwheel is not reliable with all items (it just presses SET and PLAY). After implementing menu with submenus, it will be.
In 720p you should have a warning for magic zoom.
Yes but is visible only with the Easy menu because with the Advanced it gets overwritten by "Audio Meters" so at first I didn't noticed it.
DOF makes no sense in movie mode.
Agree, but only if you don't have ML installed ;) with ML I found it not enabled because I can't clear the screen with it like in photo mode. For sure this is not a really big issue at all, there are other way to keep the screen clean like halfshutter sticky  

Here's today's bleeding edge (with some significant changes, so be careful, there may be problems):
- On 60D I was able to enable wheel navigation in ML menu in LiveView
- In movie mode, photo functions are hidden from ML menu; same for photo mode.
Only with the Easy menu, and to me in that way you are doing a great job as usual in finding a good way to make all happy (who wants all the feat and who want only video or photo features). 
- Special menu for PLAY mode (press MENU to enable it)
ML start's from the PLAY menu in PLAY mode pressing menu, if ML was Easy there is only PLAy and LiveV menu, either it is full so it's ok.  


I'll make some test now and will update the issue tracker and post a little report here later

scrax

unread,
Nov 7, 2011, 4:45:30 PM11/7/11
to ml-d...@googlegroups.com
And here some report about this one (note i'm using the build made only for 600D)


Il giorno lunedì 7 novembre 2011 18:40:09 UTC+1, Alex ha scritto:
Today's update:

- Enabled scrollwheel in 550D's LiveView (yesterday this was only working on 60D)
- SET+scrollwheel changes values in ML menu
OK on my 600D 
- Reworked menu event handler and fixed issue 799
Confirmed also for 600D 
- Fixed waveform accuracy on external monitors (from Ash's video)
- Fixed some small issues (800, 803)
800 confirmed fixed but only the camera off problem, I need to understand better your comment because for me too there is the problem of camera never finishing calibration. 
- Disabled startup logo (it seems to create problems with some monitors, not 100% sure yet)
- On HDMI-VGA, ML menu is only resized in 16:9 and 16:10 screen layouts
- A few minor adjustments (see the changeset history for more details)

... and an easter egg at "Don't click me", in 550D only (try it in photo mode). This time, the 550D will be transformed into a 10000 yuan camera :)

The new menu event handler was not tested yet on other cameras. For users of 600D/500D/50D, please check:
- menu navigation (wheel should work in photo mode, but it's not enabled in LiveView)
Ok for me too 
- when you press SET, menu items should turn green; when you de-press SET, menu items should turn blue
Yes a good dark green that makes contrast with the light green ISO values
- half-shutter should close ML menu
Yes again 
- erase button (or picturestyle on 50D) should close ML menu
Yes 
- check menu navigation in the following modes: photo, LiveView, movie standby and recording
selected items red when in rec, (nice this one). 
- camera should not crash if recording stops due to buffer overflow with ML menu active
Yes also for this fix. By the way to force a full buffer just push the CBR value up until your card can't manage it.

Cri

unread,
Nov 8, 2011, 4:16:01 AM11/8/11
to ml-d...@googlegroups.com
Hey Alex, few issue i found: 
- focus peak on hdmi one or two pixel offset. Very little
- when you have 16:9 cropmarks the bottom bar flicks a bit

Just wandering...when you use the VGA option to see the monitor at 720 how do you go back to the full hd? At the moment after you put it back to hdmi i does not change unless you reboot the camera. I suppose that s the only way right?
--

Alex

unread,
Nov 8, 2011, 4:48:59 PM11/8/11
to ml-d...@googlegroups.com
Today's update has a bunch of fixes:

- fixed issues 797, 804, 805, 807
- less aggressive redraws => less flicker
- focus peaking aligned on 50D, standby+recording -> confirmed
- focus peaking aligned on 500D -> confirmed in standby, not tested during record
- fixed err70 on 500D related to clear screen

And an experimental feature: ML menu can be turned upside-down (on cameras without built-in support for this, like 550D).

Attached is the easter egg from yesterday. It's still present in today's version (you may need to read the help text before enabling it).
http://www.itechnews.net/2010/04/26/canon-eos-550d-dslr-jackie-chan-edition/