5D2-style movie restart works in 50D

136 views
Skip to first unread message

Tom Worster

unread,
Jul 24, 2012, 2:48:22 PM7/24/12
to ml-d...@googlegroups.com
The attached diff shows the simple changes I used to test movie restart on
50D using the same method as 5D2.

It seems to work fine. I recorded three .mov files in a row. The first two
are 4.28GB and about 13m20s each, the third shorter as I stopped it after
1m.

How should I submit the changes? Pull request?

Tom

movtweaks.diff

Alex

unread,
Jul 24, 2012, 2:50:50 PM7/24/12
to ml-d...@googlegroups.com
You also need to set "movie_was_stopped_by_set" somewhere - take it
from 5D2's gui.c and see if it works as expected.
> --
> --
> http://magiclantern.wikia.com/
>
> To post to this group, send email to ml-d...@googlegroups.com
> To unsubscribe from this group, send email to ml-devel+u...@googlegroups.com
> For more options, visit this group at http://groups.google.com/group/ml-devel?hl=en
>
>

Alex

unread,
Jul 24, 2012, 2:51:19 PM7/24/12
to ml-d...@googlegroups.com
You can also test movie restart by recording at very high bitrate.

Tom Worster

unread,
Jul 24, 2012, 3:00:22 PM7/24/12
to ml-d...@googlegroups.com, Alex
50D's gui.c was doing that already. no change needed, afaict.

Alex

unread,
Jul 24, 2012, 3:04:37 PM7/24/12
to Tom Worster, ml-d...@googlegroups.com
Applied - didn't expect it to work right out of the box.

Probably the same fix can be used in 500D too.

Oscar Moreno

unread,
Jul 24, 2012, 7:50:27 PM7/24/12
to ml-d...@googlegroups.com

Wow. That will be pretty cool. Just wondering... Will there be a delay in between movie files? Just wondering how many frames will be dropped between the end and start of a new movie file....

Tom Worster

unread,
Jul 25, 2012, 11:52:34 AM7/25/12
to ml-d...@googlegroups.com, Oscar Moreno
looks like it's about 1.25 seconds gap on my camera.

using 1.5x cbr and a transcend x400 32g cf i pointed the camera at
http://www.online-stopwatch.com/ and let it run through two restarts.
comparing the time in the last frame of a movie with the first frame of
the next movie i got gaps of 1266 and 1268 ms.

Oscar Moreno

unread,
Jul 25, 2012, 9:04:09 PM7/25/12
to ml-d...@googlegroups.com
What bit rate was it shooting at? I wonder how much of it has to do with the speed of the card. I use my 50D with a 32GB 600x Lexar Professional. I could probably test it on my card to se if there's any difference . . .

> Date: Wed, 25 Jul 2012 11:52:34 -0400
> Subject: Re: [ML] 5D2-style movie restart works in 50D
> From: f...@thefsb.org
> To: ml-d...@googlegroups.com; oscar-...@live.com

Tom Worster

unread,
Jul 26, 2012, 9:02:47 AM7/26/12
to ml-d...@googlegroups.com, Oscar Moreno
60.0 Mbps
Reply all
Reply to author
Forward
0 new messages