Webviewer and fusion table columns are different

83 views
Skip to first unread message
Assigned to shadow...@gmail.com by taifu...@gmail.com

lshor...@gmail.com

unread,
Mar 4, 2014, 6:41:12 PM3/4/14
to mitappinv...@googlegroups.com
App Inv 2, Win 8.1, Chrome

I downloaded the source code for pizza party, and got it working. So I tried adding a column to the table called crust. I added the additional blocking, but the only thing that isn't working is the webviewer. The table updates correctly, and the webviewer updates, but it doesn't display the new column. Any ideas?

Screenshot_2014-03-04-18-39-12.png
Capture.JPG

Enis

unread,
Mar 4, 2014, 6:54:49 PM3/4/14
to mitappinv...@googlegroups.com, lshor...@gmail.com
You need to post either the aia file, or some screenshots of your blocks for us to see...

Taifun

unread,
Mar 4, 2014, 7:02:41 PM3/4/14
to mitappinv...@googlegroups.com, lshor...@gmail.com
try it in 10 minutes again, this might take a few minutes... 
Taifun

lshor...@gmail.com

unread,
Mar 5, 2014, 10:03:48 AM3/5/14
to mitappinv...@googlegroups.com, lshor...@gmail.com

Here is my aia file.
PizzaParty_MIT_2014 (1).aia

Enis

unread,
Mar 5, 2014, 4:59:05 PM3/5/14
to mitappinv...@googlegroups.com, lshor...@gmail.com
Lance...

I have very little experience wit Fusion Tables, so I've asked someone if they could take a look at this and hopefully they'll be able to see what the issue is.  I suspect it's your formatting of the output, but I honestly don't know.  Just be a little patient and we'll have an answer for you.

Taifun

unread,
Mar 5, 2014, 5:08:51 PM3/5/14
to mitappinv...@googlegroups.com, lshor...@gmail.com
did you get displayed the new column after trying again after a while?

I you are asking for help, I recommend you to make it as easy for others to be able to help you ...

You probably will get more feedback then...

which means in your case post a screenshot of your relevant blocks...

To download the aia file, upload it to  App Inventor, open it, do some bug hunting for you, etc...
this takes time, and most people will not do that...
Thank you.

Taifun

Trying to push the limits of App Inventor! Snippets and Tutorials from Pura Vida Apps by  Taifun.

Lance Shore

unread,
Mar 6, 2014, 2:18:10 PM3/6/14
to mitappinv...@googlegroups.com, lshor...@gmail.com
I waited and tried again, but nothing happened.  I uploaded my aia file, and I already uploaded 2 screen shots.  I'm waiting on someone to look at the code and see if there is an issue.

Taifun

unread,
Mar 6, 2014, 2:35:52 PM3/6/14
to
this is the URL to your table
https://www.google.com/fusiontables/embedviz?viz=GVIZ&t=TABLE&q=select+col0%2C+col1%2C+col2%2C+col3+from+1YnBNGM56ZfwPlqbB3L3Fm_Xe3194iIFogEvpftc&containerId=googft-gviz-canvas

as you can see you are selecting col0, 1, 2 and 3 so if you add another column I suggest you to add a col4 in your url ...
https://fusiontables.googleusercontent.com/fusiontables/embedviz?viz=GVIZ&t=TABLE&q=select+col0,+col1,+col2,+col3,+col4+from+1YnBNGM56ZfwPlqbB3L3Fm_Xe3194iIFogEvpftc&containerId=googft-gviz-canvas

Taifun

Taifun

unread,
Mar 6, 2014, 2:37:48 PM3/6/14
to mitappinv...@googlegroups.com

Lance Shore

unread,
Mar 13, 2014, 4:29:44 PM3/13/14
to mitappinv...@googlegroups.com
Sorry for the delay, I'm working on this in between work.  I added the 4th column to the table url manually, but it didn't work. So I went back to the table and re-copied and pasted the url into the blocking and that worked.  Thanks for the help!
Reply all
Reply to author
Forward
0 new messages