Error while connecting to companion

552 views
Skip to first unread message
Assigned to andrew.f...@gmail.com by halatmi...@gmail.com

unknown

unread,
Mar 8, 2014, 11:30:51 AM3/8/14
to mitappinv...@googlegroups.com
          
MIT APP INVENTOR SUPPORT FORM

Use this form to report problems or to request technical support or programming help.   Also check out the reference material at appinventor.mit.edu and at the App Inventor troubleshooting page.   Please provide ALL of the information requested in blue below BEFORE entering your issue.   We will make every attempt to answer your request or post rapidly.  Please return the courtesy and respond back to the forum promptly to let us know if your issue was resolved.   We might request additional information; we'll close the issue after three days if there has been no reply.  If you would prefer to start a discussion instead, change the drop-down above from "Ask a question" to "Start a discussion" and the form below will disappear.

Thank you - The MIT AI Support Team

MITAIMITAIMITAIMITAIMITAIMITAIMITAIMITAIMITAI


Are you Working Under Windows or a Mac or other?

Windows version: 
window 7 starter                     Mac OS version:              Other (e.g., GNU/Linux):                  

What Internet Browser are you using?   Firefox version:          Chrome version:          Other Browser:          chrome 32
(Please note: Currently IE is not supported.)

Which version of AppInventor are you using?
    MIT AI 2: Yes         MIT AI Classic:            Other:                     

How are you testing your app?

          Emulator:  Yes                                   Tablet/Phone Make, Model & Android Version:                

          Connection type: (WiFi or USB):                

Are you a Teacher or a Student Using App Inventor in Your School?   Teacher:         Student:            

If this is an issue with a specific project, please include the name of your project below:

Name of your project:                            

Please Describe Your Issue Below: (Please be specific.  "My Blocks Disappeared" is not enough for us to go on!)  Give us as much information as possible about what happened, what you were doing at the time, and what you expected to happen.  The more information you provide, the better we can help you. 

My Issue Is (Enter your issue below):

I get this error while connecting to  the emulator and it alway happening so now it impossible to update the companion
here the error
 App Inventor is unable to connect to the Android emulator. Please see this web page for help in dealing with this issue
I looked throught the web page and try everything there but i still got this error
It was working before until I accidently pressed Hard Reset and now i can't update the companion for it work again
Is there anything else i could do







Scott Ferguson

unread,
Mar 8, 2014, 11:36:50 AM3/8/14
to mitappinv...@googlegroups.com
I think you need the latest AICompanion.apk to be reinstalled on the emulator.
Try opening the web browser on the emulator and navigating to this page: http://appinventor.mit.edu/explore/ai2/setup-device-wifi.html
There under the APK file barcode click the link text 'or click this link' to try installing it.
Reply here if that works.
---
Scott

unknown

unread,
Mar 8, 2014, 1:53:17 PM3/8/14
to mitappinv...@googlegroups.com
to install the companion to the emulator, is it  the adb -e install -r companionfile method


Enis

unread,
Mar 8, 2014, 2:23:54 PM3/8/14
to mitappinv...@googlegroups.com
Most of the emulator connection problems we have seen are a result of not having the most current version of the App Inventor setup software, or that software having been incompletely installed.

Still, there can be many other issues that could cause the connection to the emulator to fail.  Please read and follow the document below on connection issues:

Click here for Emulator Setup and Trouble Shooting Instructions

If you still cannot get the emulator running after following that document, please post in the forum and we'll try to help you out.

unknown

unread,
Mar 8, 2014, 6:31:48 PM3/8/14
to mitappinv...@googlegroups.com
i said in a previous comment that i tried everything on the page and still got the error and follow the correct installion process
uninstall
reboot
install the setup package(i already have it download)
reboot
this is the installation process i use and i think it is the proper way
any other suggestions

Hal Abelson

unread,
Mar 8, 2014, 6:44:43 PM3/8/14
to mitappinv...@googlegroups.com
I didn't see your previous comment, but did you do a hard reset?

unknown

unread,
Mar 8, 2014, 7:57:34 PM3/8/14
to mitappinv...@googlegroups.com


yes, i accidently hard reset when it was working and now i have the problem

Enis

unread,
Mar 8, 2014, 8:05:51 PM3/8/14
to mitappinv...@googlegroups.com
If you did a Hard Reset, then you have the early Companion on your Emulator.  The emulator should try to update itself.  Are you getting any Companion update notices?

Enis

unread,
Mar 8, 2014, 8:08:17 PM3/8/14
to mitappinv...@googlegroups.com
You can try the adb thing... I think you did that before, but I remember that you were having issues because it was the Win 7 Starter edition.

Do you need some instructions on the adb apk installation thing again thing again???

unknown

unread,
Mar 8, 2014, 9:32:22 PM3/8/14
to mitappinv...@googlegroups.com


nope i don't need the instruction again, i looked question where you gave me them but it seem not to work whenever the companion not on and it never reached the companion point, it also stop updating and giving the error in the first post. 
 

Enis

unread,
Mar 8, 2014, 9:49:54 PM3/8/14
to mitappinv...@googlegroups.com
The companion must be on the Emulator... A hard reset actually returns the Emulator to it's original install state, with the original install companion for that setup set.

What version of the Companion is showing on the Emulator???

You CAN run the Companion on the emulator... just click on it.  But after doing so, you should "Reset Connection" because the software should start that when it tries to connect.

Run it and tell me what the version is please...

unknown

unread,
Mar 9, 2014, 6:10:08 PM3/9/14
to mitappinv...@googlegroups.com


2.15ai2zx1 is my version

Enis

unread,
Mar 9, 2014, 11:17:55 PM3/9/14
to mitappinv...@googlegroups.com
The current one is 2.16ai2zx1.

Does the emulator want to update that?  Are you getting messages that you need to update?  You should be...


On Sunday, March 9, 2014 6:10:08 PM UTC-4, unknown wrote:


2.15ai2zx1 is my version
Message has been deleted

unknown

unread,
Mar 10, 2014, 3:56:54 PM3/10/14
to


the error  come right after the companion opens so it never  update because it stop connecting to the emulator right after  the companion opens

unknown

unread,
Mar 10, 2014, 8:55:44 PM3/10/14
to mitappinv...@googlegroups.com


i cannot conect to port 8001 anymore since today, any suggestion of programs or firewall i should check first if it using the port 

Andrew McKinney

unread,
Mar 12, 2014, 9:03:11 AM3/12/14
to mitappinv...@googlegroups.com
If you delete the companion from the emulator I have seen this problem. Doing a hard reset should reset everything back to the factory default meaning your .appinvemtor/emulator/emulator-user-data file is deleted. If you do a rest connection from the connect menu and run the emulator again it should work. However, you will need to update the companion on the emulator by following the directions given. This should get you back and running. If you still are having problems I would reinstall the setup tools, again you will need to update the companion, but should work afterwards. If you are still having problems please post again with information on the outcome of the above solutions.

Andrew McKinney
Technical Lead, MIT App Inventor

unknown

unread,
Mar 12, 2014, 5:10:46 PM3/12/14
to mitappinv...@googlegroups.com


ok now the companion works but  it said the activity update is not responding so that my problem now

Andrew McKinney

unread,
Mar 13, 2014, 10:03:45 AM3/13/14
to mitappinv...@googlegroups.com
Thank you for the update on your issue. Just to clarify I image your situation is you have done the hard rest and are now trying to update the companion and you are getting an error message (a screenshot of the emulator would be very helpful to see) this seems that you cannot connect to the download server to get the updated companion. This is downloaded and then installed into the emulator. If it is failing at install then perhaps you are running out of space on your phone. Can you free up some space and try again? If this doesn't work please attach a screenshot to help us better diagnose your issue.

Andrew McKinney
Technical Lead, MIT App Inventor Project


On Saturday, March 8, 2014 11:30:51 AM UTC-5, unknown wrote:

Enis

unread,
Mar 18, 2014, 7:22:43 PM3/18/14
to mitappinv...@googlegroups.com
No response... am closing this issue.
Reply all
Reply to author
Forward
0 new messages