Skip to first unread message
Assigned to halatmi...@gmail.com by me

bric...@gmail.com

unread,
Mar 8, 2014, 5:13:19 AM3/8/14
to mitappinv...@googlegroups.com
          
MIT APP INVENTOR SUPPORT FORM

Use this form to report problems or to request technical support or programming help.   Also check out the reference material at appinventor.mit.edu and at the App Inventor troubleshooting page.   Please provide ALL of the information requested in blue below BEFORE entering your issue.   We will make every attempt to answer your request or post rapidly.  Please return the courtesy and respond back to the forum promptly to let us know if your issue was resolved.   We might request additional information; we'll close the issue after three days if there has been no reply.  If you would prefer to start a discussion instead, change the drop-down above from "Ask a question" to "Start a discussion" and the form below will disappear.

Thank you - The MIT AI Support Team

MITAIMITAIMITAIMITAIMITAIMITAIMITAIMITAIMITAI


Are you Working Under Windows or a Mac or other?

Windows version:   7                  Mac OS version:              Other (e.g., GNU/Linux):                  

What Internet Browser are you using?   Firefox version:   27       Chrome version:          Other Browser:         
(Please note: Currently IE is not supported.)

Which version of AppInventor are you using?
    MIT AI 2:  X       MIT AI Classic:             Other:                     

How are you testing your app?

          Emulator:      X                               Tablet/Phone Make, Model & Android Version:                

          Connection type: (WiFi or USB):                

Are you a Teacher or a Student Using App Inventor in Your School?   Teacher:         Student:    X       

If this is an issue with a specific project, please include the name of your project below:

Name of your project:                            

Please Describe Your Issue Below: (Please be specific.  "My Blocks Disappeared" is not enough for us to go on!)  Give us as much information as possible about what happened, what you were doing at the time, and what you expected to happen.  The more information you provide, the better we can help you. 

My Issue Is (Enter your issue below):


Hi, I'm trying to make a simple WebView, everything works perfect in the emulator but when I try to create the apk I've got this error:

App Inventor is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Determining permissions
________Generating manifest file
________Attaching native libraries
________Copying native libraries
________Attaching component assets
________Compiling source files

I don't see the way to fix that, please help.
Thank you






Enis

unread,
Mar 8, 2014, 5:27:27 AM3/8/14
to mitappinv...@googlegroups.com, bric...@gmail.com
Dear Brichette...

How big is your AIA file (the exported backup file)?  If it's too big, AI won't be able to compile the app.

The App Inventor limit is 5MB (the size of the AIA file).  If you ARE near that upper limit, and you have a lot of unused graphics, photographs, media sound and video files, delete what you don't need.

Projects that are too large are often the result of having large images or other assets.  Search the forums for tips on how to decrease the size of the project.

Here are some solutions from Hossein & Taifun on Taifun's pages: http://puravidaapps.com/filebyfile.php

If this is NOT the case, please report back so we can resolve the issue with you.

bric...@gmail.com

unread,
Mar 8, 2014, 5:44:36 AM3/8/14
to mitappinv...@googlegroups.com, bric...@gmail.com
Hi, the only element that my app has is a WebView, no images, no text... I just want to make a simple app (you press the icon in the mobile devide then you enter the website)
Thank you for your answer.

Hal Abelson

unread,
Mar 8, 2014, 7:22:41 AM3/8/14
to mitappinv...@googlegroups.com, bric...@gmail.com
Hi Brichette,

What is the name of your project?   I'll try to investigate.

== Hal

bric...@gmail.com

unread,
Mar 8, 2014, 7:32:46 AM3/8/14
to mitappinv...@googlegroups.com, bric...@gmail.com
Hi, the name of the project is definitivo_copy Do you have access to my projects?
Best regards.

Hal Abelson

unread,
Mar 8, 2014, 8:12:44 AM3/8/14
to mitappinv...@googlegroups.com, bric...@gmail.com
I took a look at your project and I don't see anything wrong with it.  I was able to compile it and run it on my phone with no problem.
Please try again.  I'm not sure what to suggest if it fails.   The project is simple enough that you could just try rebuilding it.

bric...@gmail.com

unread,
Mar 8, 2014, 6:13:56 PM3/8/14
to mitappinv...@googlegroups.com
Nah, I can't maybe something in my computer is blocking this feature, I've tried in Firefox and Chrome and I had the same issue in both browsers. I give up. Thank you all for your support!

Enis

unread,
Mar 8, 2014, 7:09:09 PM3/8/14
to
Brichette...

Are you able to make ANYTHING work in AI on your phone?  If you take another AI project, can you compile that and run it on your phone???

Attached is a very simple, do nothing project.  The only thing it does is put text into the label when you click it. Download this project, import it into AI (My Projects, Then Project, then Import).

Can you create an APK from this???
Brichette.aia

bric...@gmail.com

unread,
Mar 8, 2014, 7:23:39 PM3/8/14
to mitappinv...@googlegroups.com

Hi, still the same, I can open and run the emulator, works fine but I can't create an apk of the project. Do I need any plugin to be enabled in the browser/computer? I think maybe the answer is over there.
Thank you!


El domingo, 9 de marzo de 2014 01:00:16 UTC+1, Enis escribió:
Brichette...

Are you able to make ANYTHING work in AI on your phone?  If you take another AI project, can you compile that and run it on your phone???

Attached is a very simple, do nothing project.  The only thing it does is put text into the label when you click it. Download this project, import it into AI (My Projects, Then Project, then Import).

Can you create an APK from this???


On Saturday, March 8, 2014 6:13:56 PM UTC-5, bric...@gmail.com wrote:

Enis

unread,
Mar 8, 2014, 8:44:32 PM3/8/14
to
OK, I need to think about this a bit, but I DON'T want you to give up... No special plug-ins that I know of... But current versions of browsers are very important.

What versions of Chrome & Firefox are you using?

Also, what are you using for Anti-Virus on your machine???

The reason I ask about the Anti-Virus is that depending upon the program, it may be blocking the compile.  Also, it's possible that you have a virus on your machine.  When was the last time you did a system scan?  We've seen issues where viruses caused all sorts of havoc.

bric...@gmail.com

unread,
Mar 9, 2014, 5:20:05 AM3/9/14
to mitappinv...@googlegroups.com
Hi, problem "fixed" it came with the keystore, I 've deleted the keystore and worked fine, I can create the apks without keystore. The keystore I've used was created in Eclipse, I've tried to create a new one through MsDos but I couldn't so my apps will be withuot keystore. Is there a problem with that? Sorry for my dumb question, what is the point of the keystore signed apps?
Best regards.


El domingo, 9 de marzo de 2014 01:33:43 UTC+1, Enis escribió:
OK, I need to think about this a bit, but I DON'T want you to give up... No special plug-ins that I know of... But current versions of browsers are very important.

What versions of Chrome & Firefox are you using?

Also, what are you using for Anti-Virus on your machine???

The reason I ask about the Anti-Virus is that depending upon the program, it may be blocking the compile.  Also, it's possible that you have a virus on your machine.  When was the last time you did a system scan?  We've seen issues where viruses caused all sorts of havoc.


On Saturday, March 8, 2014 7:23:39 PM UTC-5, bric...@gmail.com wrote:

Hal Abelson

unread,
Mar 9, 2014, 8:55:32 AM3/9/14
to mitappinv...@googlegroups.com, bric...@gmail.com, Jeff Schiller
Thanks for letting us know you found that.  I don't think we would have guessed that this was the issue.
Keytores are use by Google Play when someone tried to update an app they publshed there.   App Inventor creates keystores automtically.  See

http://appinventor.mit.edu/explore/ai2/support/troubleshooting.html#Keystores

and also

http://appinventor.mit.edu/explore/ai2/google-play.html

bric...@gmail.com

unread,
Mar 9, 2014, 9:27:37 AM3/9/14
to mitappinv...@googlegroups.com, bric...@gmail.com, Jeff Schiller
Thank you!

Suyodhan Mali w

unread,
Mar 14, 2015, 5:26:10 AM3/14/15
to mitappinv...@googlegroups.com, bric...@gmail.com, j...@mit.edu
Hi guys,
i have problem in save .apk
as i tried  100 times the only message comes that file will save in download folder but wheras file is not saved their.
please help me

suyodhan mali

unread,
Mar 14, 2015, 5:27:20 AM3/14/15
to mitappinv...@googlegroups.com, bric...@gmail.com

Enis

unread,
Mar 14, 2015, 5:31:58 AM3/14/15
to mitappinv...@googlegroups.com, bric...@gmail.com
What OS are you on?  Have you changed the location of your downloads folder?

Sort your Downloads folder by Date, descending, and give us a screenshot of the top few lines of your window...

If that doesn't work, try Firefox instead...

Suyodhan Mali w

unread,
Mar 14, 2015, 6:03:30 AM3/14/15
to mitappinv...@googlegroups.com, bric...@gmail.com
windows 7 Ultimate 32 bit
yes i changed location of download folder
browser using Chrome

t1.png

Enis

unread,
Mar 14, 2015, 12:40:18 PM3/14/15
to mitappinv...@googlegroups.com, bric...@gmail.com
Check the regular Windows Download Folder... I see HelloPurr.apk in your screenshot.

Also, if there are no files in your regular Windows D/L folder, please try using Firefox instead of chrome and see if it fixes your problem.

I would alo do a search on your system for *.apk and search the entire computer... that'll show you where they're ending up...
Reply all
Reply to author
Forward
0 new messages