Emulator won't download companion update

369 views
Skip to first unread message

mexsc...@gmail.com

unread,
Feb 12, 2014, 10:33:21 AM2/12/14
to mitappinv...@googlegroups.com
My emulator reports that it can't download the companion update. Nor can I use the internet on the emulator. How do I fix this please?

jeffrey.schiller

unread,
Feb 12, 2014, 11:23:13 AM2/12/14
to mitappinv...@googlegroups.com, mexsc...@gmail.com
Make sure you don't have a firewall blocking connections to "dl.qyv.me" (which is where the companion update is coming from). We will be moving this later today to "download.appinventor.mit.edu").

-Jeff

mrrac...@gmail.com

unread,
Feb 13, 2014, 7:43:38 AM2/13/14
to mitappinv...@googlegroups.com, mexsc...@gmail.com
On Wednesday, February 12, 2014 3:33:21 PM UTC, mexsc...@gmail.com wrote:
> My emulator reports that it can't download the companion update. Nor can I use the internet on the emulator. How do I fix this please?

None of those sites work. The first just says Foo Bar and is redirecting, the second just fails and says there is no DNS entry or something.

This actually is a nightmare for us. I have 33 computers, and a GCSE class (UK) doing an OCR controlled assessment based on app inventor (set by the exam board not us) - this has to be done in a set time, under controlled conditions for students to get their qualification. They were all working happily, and then last lesson, the Companion file needed updating. As there is no MSI, I had to manually remove then install this on all the machines.

Finally after a lot of work I got Version 2.11ai2 working. But that now hangs and want to try to update the companion file to 2.15. Nothing happens. The sites don't appear to be blocked but no update occurs. A message flashes up for a bit saying the site cant be accessed in a timely fashion.

As if you make your applications fail, when they are used in an educational setting. This is a MAJOR problem.


mrrac...@gmail.com

unread,
Feb 13, 2014, 7:44:19 AM2/13/14
to mitappinv...@googlegroups.com, mexsc...@gmail.com, mrrac...@gmail.com
This is the message you when when you try to access the website mentioned above


Error: The web filter could not find the address for the requested site
Why you are seeing this:
The system is unable to determine the IP address for download.appinventor.mit.edu

Possible reasons could be:
The site name has been entered incorrectly or does not exist. Please double check you have entered the correct URL.
The Domain Name Server (DNS) is unable to resolve the IP address for this domain.
If this problem persists, please ask your administrator to:
Check your DNS services are operating correctly.

jeffrey.schiller

unread,
Feb 13, 2014, 10:25:17 AM2/13/14
to mitappinv...@googlegroups.com, mexsc...@gmail.com, mrrac...@gmail.com
The new Companion is on http://dl.qyv.me/MITAI2Companion.apk Can you reach that address? (We'll be moving it to download.appinventor.mit.edu later today, but it doesn't exist as I type this).

-Jeff

create.e...@gmail.com

unread,
Feb 13, 2014, 10:41:18 AM2/13/14
to mitappinv...@googlegroups.com, mexsc...@gmail.com, mrrac...@gmail.com
Our firewall is definitely not blocking http://dl.qyv.me/MITAI2Companion.apk because I can type it into our browser and download the apk to the desktop. It's just that the emulator gives an error

Jeff, can you simply update the img in the emulator download package AppInventor_Setup_Installer_v_2_2.exe so at least we can get the newest version without having to rely on the in-app emulator autoupdate?

I have a class of 30 students dead in the water because we can't get the emulator to work anymore. (Is there an offline version of appinventor 2?)

I've attached the error screen:

emulatorerror.jpg

Hal Abelson

unread,
Feb 16, 2014, 11:22:17 AM2/16/14
to mitappinv...@googlegroups.com, mexsc...@gmail.com, mrrac...@gmail.com, create.e...@gmail.com
Reply all
Reply to author
Forward
0 new messages