Rishi

unread,
Jul 25, 2014, 7:28:22 PM7/25/14
to mitappinv...@googlegroups.com
Hello,
I am currently using http://eixerits.wordpress.com/2013/02/03/a-login-template/ as the login template which I have used to recreate on App Inventor 2, but my issue is that I cannot seem to register after entering my name, password, confirm password, and email.
The errors for the user input (Not same password and repeat password, username cannot contain '@', etc.) occur as the template specifies, but when I press "Register," nothing happens.
I am modifying this template and submitting it for a contest, and the contest specifies that the app must be developed in AI2.
Any and all help would be greatly appreciated ASAP!
I have attached the *.aia file of the app for reference.
Thanks a lot,
Rishi.
TymesApp.aia

SteveJG

unread,
Jul 25, 2014, 10:02:42 PM7/25/14
to mitappinv...@googlegroups.com
It stops for me to at  "Register" .... took a while to figure that is the ButtonOK_Reg block.  I guess it stops here because I see no code here other than the TinyWebDB call.  Trying a DoIt, after properly filling in the fields, it does not appear the fields are transferring data.

So, I would start the hunt here Rishi ..... I can not test your TinyWebDB   calls.   I put the Screen1.TitleBlock there to give an indication the button gets pressed.   It definitely does get pressed.
I also deleted the Sound.Click as events of that type can sometimes inhibit the events in the blocks following them.



















Regards,

Steve

Stephen Zipprich

unread,
Jul 26, 2014, 12:03:31 AM7/26/14
to mitappinv...@googlegroups.com
If you're looking for a login template designed in AI2, and utilizing the TinyWebDB, check out my tutorial on this very thing.
Reply all
Reply to author
Forward
0 new messages