RUNTIME ERROR:.. button component but got a yaillist instead

1131 views
Skip to first unread message

Sebastian Crespo

unread,
Feb 3, 2018, 2:41:54 PM2/3/18
to MIT App Inventor Forum
I've got a runtime error while i am executing my memorama , this error appears: "problem with application, property getter was expecting a com.google.appinventor.components.runtime.button component but got a yaillist instead"
BLOQUEERROR.jpg
BLOQUEPARTE.jpg
BLOQUEPARTEBOTON.jpg
BLOQUEPARTEI.jpg
BLOQUEPARTEII.jpg

Italo

unread,
Feb 3, 2018, 2:58:15 PM2/3/18
to MIT App Inventor Forum
In one of your ANY BUTTON blocks, you connected a variable with a list instead of a BUTTON component id .
I guess you wanted to select one button id from a list. If that's the case, use the SELECT block from the LISTS section to specify which one you want to use.
I don't see where you assign a value to Botones. 

Sebastian Crespo

unread,
Feb 3, 2018, 3:54:09 PM2/3/18
to MIT App Inventor Forum

sorry I do not understand well, which block is the one that has the error? and what block is the correct one to change it?

Bernal Albarez

unread,
Dec 4, 2019, 2:05:46 PM12/4/19
to MIT App Inventor Forum
buenas tardes, tengo el mismo problema, alguien ya lo soluciono?, y que pueda auxiliarme.

Saludos

Taifun

unread,
Dec 4, 2019, 2:37:30 PM12/4/19
to MIT App Inventor Forum
It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

Taifun

Trying to push the limits of App Inventor! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun. 

Reply all
Reply to author
Forward
0 new messages