Kilian Pouderoux

unread,
Mar 18, 2019, 3:42:35 PM3/18/19
to MIT App Inventor Forum
Hi everybody !
For a project at school I have to create an app with AppInventor and I am actually facing some problems I hope you could help me with.
My app is totally finished and it runs perfectly with the Companion when I scan the code with an Android phone, I mean it does what it should do.
But when I try to build it as an .apk file and run the app without the Companion (when the app is dowloaded on the device), it doesn't work anymore.
For exemple, there is a screen where you can enter a phone number and then the app should send a new password to the phone number entered but the SMS just doesn't send.
Another problem is when I try to get connected to a Bluetooth device, it works with the Companion, I can get connected and send data but not with the .apk app.

Here is a little description of the app:

My app controls an automatic board eraser, which translates along the board, vertically.
The board is divided in four parts and the eraser should be able to erase the parts we decide to erase.
When the app is launched, there is a loading screen with the name of the project, then it goes to the screen where we can get connected to the Bluetooth device. To access the parts selection's screen, we have to enter the password, which is by default 1234. When we forget the password or if this is the first time we launch the app, we are sent to 2 different screens, one for the 1st connection and the other for the forgotten password.

I am working with an Arduino Uno card and a Bluetooth module HC-05, and sorry for that, some things in my code are written in French,  so don't hesitate asking me for a translation.

Thank you very much to those who can help me, and if you have any suggestion of how I could improve my app, I'm listening !

P.S, you can see my code in attachment in the .aia file.
SMS.aia
Reply all
Reply to author
Forward
0 new messages