Fledermaus model can't show up the seismicity in iView4D

63 views
Skip to first unread message

YONG CHIENZHENG

unread,
Jul 16, 2015, 11:29:46 PM7/16/15
to mir...@googlegroups.com
Dear Prof. Joaqium,

I'm having a problem when using the mirone250 (win64 matlab version) to plot the Fledermaus model where it doesn't show out the seismicity positions as expected. For your information, I'd used the gravimetry information (TOPEX) as based map, seismicity information from ISC catalog (re-formatted into lon,lat,dep,mag,yy,mm,dd) and the latest version of iView4D is the reader for the model.

Could Sir please give me possible suggestion which steps that I'd missed out to causing the problem? Grateful for your kindly reply.




Best regards,

Yong Chien Zheng

PhD Candidate
University of Otago, New Zealand

YONG CHIENZHENG

unread,
Jul 16, 2015, 11:32:00 PM7/16/15
to mir...@googlegroups.com

Attached with the screenshots of model in iView4D
001.jpg
002.jpg

Joaquim Luis

unread,
Jul 17, 2015, 6:55:11 AM7/17/15
to mir...@googlegroups.com, YONG CHIENZHENG
Maybe the hypocenters depth (sorry for the repetition) is too small as compared with the Earth radius to be visible in such figures?



Attached with the screenshots of model in iView4D
--
You received this message because you are subscribed to the Google Groups "mirone" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mirone+un...@googlegroups.com.
To post to this group, send email to mir...@googlegroups.com.
Visit this group at http://groups.google.com/group/mirone.
For more options, visit https://groups.google.com/d/optout.



YONG CHIENZHENG

unread,
Jul 17, 2015, 10:53:33 PM7/17/15
to mir...@googlegroups.com, yong.ch...@gmail.com
Dear Prof. Joaqium,

It still doesn't show up even though I'd magnify the depth for 1000 times (scale 1:1000 from the seismicity input file). The model is seems to be displaying the points on the surface of base map but not below it (not like the model from the mirone webpage). 

When I executing the Fleder 3D viewer in mirone, there is a command prompt window pop up and it shows "'iview3d' is not recognized as an internal or external command, operable program or batch file.". Is this the reason that causing it doesn't show the points' depth? 

Kind regards,
Yong

Joaquim Luis

unread,
Jul 19, 2015, 7:45:13 PM7/19/15
to mir...@googlegroups.com, YONG CHIENZHENG
Which data format did you use?
I just tried with an ISC file and it worked fine. But note also that fledermaus7 changed things in unknown ways and I get much less troubles when using the older, and way, way smaller, iview3d. If you update Mirone (the stand-alone version) you'll get the old iview3d. 
The message you got about is because it tried to call it and didn't find. No worries about that. Actually this issue of which fleder viewer to use is a bit messy but I can't control well what the compiled version decides to do. 

YONG CHIENZHENG

unread,
Jul 22, 2015, 1:09:34 AM7/22/15
to mirone
Dear Prof. Joaqium,

I'm using a re-formatted *.dat file (lon,lat,dep,mag,yy,mm,dd) to plot the seismicity, I bet it should works as it contains the necessary information. 
I'd installed the stand-alone version, but I'm wondering why it pop up an error message "Found corrupted block 2986 in table 2." 
Sorry for asking so many questions and thanks for your time. 
 


Kind regards,
Yong 

Joaquim Luis

unread,
Jul 22, 2015, 6:50:21 AM7/22/15
to mir...@googlegroups.com

Dear Yong,

I'm working on a new version that will use the yet-to-be-released GMT5.2 that will provide access to all GMT functionality via MEXs. When that is finished (and hopefully working) this mysterious problem will go away. Meanwhile edit you environment variables and change the name of the variable
GMT5_SHAREDIR
to
GMT_SHAREDIR


YONG CHIENZHENG

unread,
Jul 23, 2015, 2:12:40 AM7/23/15
to mirone, jl...@ualg.pt
Dear Prof. Joaqium,

I'd tried the standalone version and it works now. The position of seismicity is able to show up in iView4D, but it doesn't appear to be the same color as defined in mirone. I'd tried to remove black outline of dots (black outline by default), different size of magnitude with same color, different color of depth with same size and so on, but the saved *.SD file it still showing black color (seismicity) in iView4d. Could Sir suggest a clue to sort the color change? 


Thank you. 


Kind regards,

Yong

Joaquim Luis

unread,
Jul 23, 2015, 3:23:34 PM7/23/15
to mirone, YONG CHIENZHENG
Yong,

The spherical objects are more problematic. Run an example here and there were problems with spherical whilst the planar worked perfectly.
The only way to change symbol color and sizes is via Mirone where the cases I tested again worked. However, you have to understand that the Fledermaus format is not public and what Mirone does is based on my past hacks trying to reverse engeneering a binary format from very little documentation, so things don't all work well and have the tendency to fail more in newer Fleder versions (that I do not have). 
Reply all
Reply to author
Forward
0 new messages