PKGSRC Updates

Skip to first unread message

Lionel Sambuc

May 28, 2013, 10:52:10 AM5/28/13
Hello everyone,

The MINIX team has some great news regarding pkgsrc. With our continuous 
effort to improve MINIX and its userland, we have for the first time 
tried to compile every package available, rather than our usual 
restricted set. The result is a lot of new packages.

However, we need your help to check that all those newly available 
packages indeed run correctly! For that purpose, we have set up a new 
binary repository, which is also compiled using the latest improvement 
available on MINIX.

To be able to try those new packages, follow the procedure available on 
the wiki:

You can also find the current state of the repository, at any time, at:

If you wish to help us get even more software available on MINIX, please 
take a look at the MINIX wishlist:


Lionel Sambuc, on behalf of the MINIX team.

Thomas Cort

May 28, 2013, 1:24:25 PM5/28/13
Great work with the build! The next one should be even better as
devel/glib2 builds now and was blocking 2132 packages.

I've been trying out the critical packages (openssh, scmgit-base, vim,
etc) and they're working great. I've also been testing some new ones
like hunspell with good results and will add them to the
limited_list.pbulk file.

> However, we need your help to check that all those newly available
> packages indeed run correctly!

One package that doesn't run correctly is gnupg-1.4.13nb2.

If you run `gpg --gen-key`, it will go into an infinite loop printing
"select() error: bad file descriptor" after entering your passphrase
for the second time.


Ulrich Schmidt

Jun 1, 2013, 4:00:50 PM6/1/13
I tried the following packages:


Works like a charm.

But why is the x11 Port from bigports broken?
In Minix 3.2.1 Stable I could run "startx" and it started the twm window manager.
But after some seconds of using X the system freezes, so i had to do a Hardware Reset.
I tried to tracking current and rebuild the system.
Run "startx" and getting a Core Dump.

Thomas Cort

Jun 1, 2013, 4:39:13 PM6/1/13

> I tried the following packages:
> Works like a charm.

Thanks for testing the packages. I'll add them to the list of packages
that get included in the standard package builds:;a=blob;f=minix/limited_list.pbulk;hb=HEAD

> But why is the x11 Port from bigports broken?

Have you tried using the minix/x11 package from the pkgsrc testing
repository (i.e. `pkgin in x11`) with Minix current?

It seems to be working for me in qemu-kvm, but I'm running a fresh
install from a Minix-current install CD I made about 10 days ago. I
didn't install any packages from the 3.2.1 package set, just stuff
from the 'testing' package set, and nothing from bigports.


> --
> You received this message because you are subscribed to the Google Groups
> "minix3" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to
> For more options, visit

Ulrich Schmidt

Jun 1, 2013, 5:35:08 PM6/1/13
The x11-Package from the old Repository freezes my system after some seconds.
Im running Minix under VMWare Player.
I have only the testing-repository in the repositories.conf file of pkgin.
I commented the line with the old repository out.

This is how i installed x11 from testing repository.
# pkgin clean
# pkgin update
# pkgin remove x11
# pkgin install x11
# startx
Coredump after x11 says that it can't locate my xorg.conf.

Am Dienstag, 28. Mai 2013 16:52:10 UTC+2 schrieb Lionel Sambuc:

Lionel Sambuc

Jun 3, 2013, 3:39:07 AM6/3/13

I have been checking the x11 package from the testing repository, and I also have a coredump, but not because of the missing configuration file (I had a working one), but a bit later in the PCI discovery X11 do in order to find the video card(s).

This will require some debugging to find out exactly what changed between the current (3.2.1) package and the testing (3.2.1-testing) package.

Meanwhile, if you require X11, all I can propose is to install it from the current repository with the following commands:

1) Remove the testing package from the system
# pkgin rm x11
# rm /usr/var/db/pkgin/cache/x11-6.8.2.tgz

2) Manually install the package from the current repository
# pkg_add -f

Thank you for you report; I will update the wiki status page of pkgsrc on your behalf,
with a link back to this thread.


Lionel Sambuc


Jun 7, 2013, 8:45:03 AM6/7/13
Hi Lionel,
I'm currently quite busy to test anything that's out of scope for me. However, I changed my pkgin repositories.conf to point to the testing directory and upgraded my packages. As using vmware I did encounter the problem mentioned with X11 but haven't bumped into any other issues yet -even though I'm booting minix with Ben's recent mmap support:) The only thing about I can kind of make a statement is that the new openssh-6.2.1 coming from the testing repo, works just as well in my Eclipse RSE scenario as the 5.8.2 did. I hope I'll have some more time to test this and that. Thanks for the great work!

Ulrich Schmidt

Oct 26, 2013, 11:56:28 AM10/26/13
Anything changed with this bug?
I remember that I ran Minix 3.1.5 with stable X11 and Equinoxe Desktop Enviroment on my old Pentium 3 some years ago and X was very stable on that computer.

Since in the "Features"-Section at the Minix Website is written that Minix supports "X Window System" as a feature it would be good if X11 would work in a Virtual Machine.
Is the problem only when running Minix in VMWare Player or is Minix port of X11 broken in general?
Could it be a problem with the driver for the virtual graphic card of VMWare?

I remeber, that in old Minix releases was packages like nedit, jwm, some light-weight GUI toolkits Equinoxe Desktop Enviroment, a C64 emulator, QEmu,  MPlayer, xv, links2 browser with GUI and other software for X.

If I get X11 to work, would it be possible to compile these ports from old minix version without much trouble in the newest Minix release?
I'm in a training as programmer, but I have only limited experience in C and POSIX-programing.

Am Dienstag, 28. Mai 2013 16:52:10 UTC+2 schrieb Lionel Sambuc:
Reply all
Reply to author
0 new messages