the "older version" warning is not correct

10 views
Skip to first unread message

Victor Borda

unread,
Jan 11, 2014, 9:04:36 PM1/11/14
to minites...@googlegroups.com
Thanks for making the minitest-* gems available to the community. After recently adding it to an existing Rails 3.2.+ project, everything works fine, but this
message comes up. 

DEPRECATION WARNING: It looks like you are using test helper generated by an older version of minitest-rails.

The check that produces this warning is incorrect and I will file a bug for it. However, just in case anyone else is searching I thought I would post a note here that this is caused by a check for the inclusion "rails/test_helper", but that this check will evaluate to true if that is being included, even if not explicitly, by anything within the app, not just the test_helper.rb file.  
Reply all
Reply to author
Forward
0 new messages