no image window popped up (software)

101 views
Skip to first unread message

Yujin KIm

unread,
Mar 19, 2021, 12:24:10 AMMar 19
to Miniscope
Hi,

I ran "Miniscope-DAQ-QT-software" with miniscope v4 connected. 
It seemed that the computer recognized miniscope, since "Control Panel" showed "'Space Bar':screenshot of video stream. 'h': hides/shows video stream controls." with no error messages, except no image window popped up. 

It was strange, but I pressed 'Record' anyway, and got this message.

software error.png

It says, "Warning: already exists". I set the dataDrectory as "D:/Documents/miniscope/data", which, yes, already exists but shouldn't be a problem. directorySturcture has "date" and "time" (erased "researcherName" and "experimentName"), so it should create a folder named date with a subfolder named time, right? The /miniscope/data folder has nothing in it after the recording.                                

 Do you have any idea why this happens? 
I guess no image window when running the software is the fundamental problem, not the recording part.
The same system (DAQ + miniscope) worked well on another computer, so I know what it should be when everything is working fine. The computer that worked fine was a laptop, and the computer that I am having trouble with is a desktop PC with a better CPU, RAM, and etc. 

Thanks,

Yujin

Daniel Aharoni

unread,
Mar 23, 2021, 7:19:44 PMMar 23
to Miniscope
Hi Yujin,
Can you share your user configuration file here?

Yujin KIm

unread,
Mar 23, 2021, 10:32:26 PMMar 23
to Miniscope
Hi Daniel,

Here is the user configuration file that I used.

{
//    "researcherName": "Dr_Miniscope",
    "dataDirectory": "D:/Documents/miniscope/data",
"reserved terms for directoryStructure": ["time", "date"],
    "directoryStructure": [
//        "researcherName",
//        "experimentName",
        "animalID",
        "date",
        "time"
    ],
    "animalName": "testMouse",
"animalID": "ID42",
//    "experimentName": "Linear Track Test",
// "test": "TEST",
    "recordLengthinSeconds": 10,
    "experiment_Not_Implemented": {
        "type": "linearTrack",
        "units": "cm",
        "trackLength": 200
    },
    "behaviorTracker_Not_Implemented": {
        "type": "HSV",
        "hue": [0, 1],
        "saturation": [0, 1],
        "value": [0, 1]
    },
    "devices": {
        "miniscopes": [
            {
                "deviceName": "Miniscope",
                "deviceType": "Miniscope_V4_BNO",
                "imageRegistration": "Off",
"headOrientation": {
"enable": true,
"filterBadData": true
},
                "streamHeadOrientation_OLD": true,
                "deviceID": 0,
"showSaturation": true,
                "compressionOptions": ["MJPG","MJ2C","XVID","FFV1"],
                "compression": "FFV1",
                "framesPerFile": 1000,
                "windowScale": 1.5,
                "windowX": 800,
                "windowY": 100,
                "gain": "Medium",
                "ewl": 50,
                "led0": 30,
                "frameRate": "25FPS"
            }
        ]
    }
}

I have modified directory name, deviceID and some initial settings for image window (window Scale, gain, frameRate..).
The same file works well on my laptop, but not on PC (no image window popped up).

Thanks,
Yujin

Daniel Aharoni

unread,
Mar 24, 2021, 3:38:29 PMMar 24
to Miniscope
Thanks for posting your device config. I am not sure what is going on here since the same config works for you on a different computer. While I don't think this is the issue, make sure the "windowX" and "windowY" values are set to numbers that will have the window show up on the monitor (these values define where the top left corner of the Miniscope window shows up). 

There is maybe some weird compatibility issue with your video card or OpenGL. Can you click the "Help" button on the first window of the software and tell me what OpenGL version you have?

Yujin Kim

unread,
Mar 25, 2021, 12:56:39 AMMar 25
to Daniel Aharoni, Miniscope
Hi Daniel,

Yeah.. That is what I am frustrated with. The same set of files/hardware/software works fine on one computer, but not on the other. We wanted to run the program on the desktop PC (the one not working well with miniscope) because of its better performance, but maybe we have to stick with the original one. 

The OpenGL version is 4.6

Thanks,

Yujin

--
You received this message because you are subscribed to a topic in the Google Groups "Miniscope" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/miniscope/uD3U1qUMA5g/unsubscribe.
To unsubscribe from this group and all its topics, send an email to miniscope+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/miniscope/53f80e63-dd20-4eef-ae93-23bbad940b60n%40googlegroups.com.

Federico Sangiuliano

unread,
Mar 25, 2021, 3:22:07 AMMar 25
to Miniscope
Hello Yujin. Just to rule this out, are you using an USB 3 port? You can check it on the device manager to know for sure.

Yujin Kim

unread,
Mar 25, 2021, 6:21:02 AMMar 25
to Federico Sangiuliano, Miniscope
Hi Federico,

Yes, I have used an USB3 port. I actually tried multiple USB3 ports on the PC, yet no success.

Thanks for the feedback.

Yujin

Ana Gonçalves

unread,
Sep 13, 2021, 4:39:18 AMSep 13
to Miniscope
Hi everyone,

I have the same issue on another laptop (using USB3, OpenGL version 4.6). The computer runs windows 10 and has two GPUs, one integrated and a RTX 30 series for tracking. I've tried changing the windows settings in the userconfig file but with no success. Any idea how to solve this?

Ana

Fa Peng

unread,
Oct 11, 2021, 7:40:24 AMOct 11
to Miniscope
Hi Ana,
I think this will help(set 'DAQ software' using Nvidia GPU):
NVIDIA.png

Fa Peng.

Reply all
Reply to author
Forward
0 new messages