V4 miniscope retrieve frame failed - suddenly no scopes work

67 views
Skip to first unread message

Alex Jacob

unread,
Apr 4, 2024, 6:34:02 PMApr 4
to Miniscope
Hey there, this is a bit of a weird one. We've been happily imaging with a set of 3 Miniscope V4s for months now without major issue. However as of yesterday, all of our scopes which previously worked are now throwing a "V4 miniscope retrieve frame failed. Attempting to reconnect" error (see pic). I know this is a pretty generic error so I've tried a number of troubleshooting steps, none of which have worked.

Some basics about the setup: v4 miniscope (from Labmaker) attached via coax cable (from Labmaker) to a DAQ board (also Labmaker, version 3.2), connected via USB 3.0 cable (came with the Labmaker DAQ) to a USB 3.0 port of a laptop running Windows 10.  I'm running the Miniscope DAQ software, build 11.1. After connecting the miniscope, DAQ board and laptop:
- all 3 lights on the DAQ board are illuminated green (see pic)
- red indicator LED on top of the v4 scope is on, and the v4 board is warm
- Device Manager reports a MINISCOPE device under "cameras"

Despite this, I am getting the "retrieve frame failed" error consistently.

Some troubleshooting steps I have taken:
- I have tested 3 different Miniscope V4s. I also tested a fourth brand new flex PCB from Labmaker which had previously been verified to work when we first recieved it. Regardless of scope, I get the error
- I have tried several different coax cables which previously worked without issue. I also tried two brand new pre-assembled coax cables from Labmaker. Same issue regardless of coax cable.
- We have two DAQ boards. I repeated the above (different cables and scopes) with boxes. Same error.
- Tried replacing the 12V power supply to the DAQ box (three separate power supplies). Same error.
- Tried replacing the USB 3.0 cable from the DAQ box to the laptop (3 separate cables). Same error.
- Tried a total of 4 separate computers (3 running Windows 10, 1 running Windows 11). Same error on all machines.
- Tried a fresh install of the Miniscope DAQ software on the Windows 11 machine, and a brand new userConfig json file. Same error.
- Tried various fixes proposed in other threads including: disabling antivirus, double checking USB 3.0 connection stability (total of 7 different USB 3.0 ports across 4 machines), updating Windows, verifying position of the DAQ board jumper on K2 (see pic)

Things I haven't tried yet:
- Updating DAQ board firmware (since both these DAQs had previously been functioning correctly)

It's such a weird issue because as of a few days ago, all these scopes, DAQ boards, laptops etc. were working without issue! I'm totally at a loss for why our whole system suddenly can't seem to retrieve a frame. Any help is appreciated!
Message has been deleted

Daniel Robert Griffiths

unread,
Apr 4, 2024, 7:22:06 PMApr 4
to Miniscope
This may sound odd, but are the computers connected to a university network? We have had issues with university antivirus software preventing the miniscope software from running appropriately. If you have the option, try turning off the antivirus software... if you can't turn it off, try using a computer not on the university network. Good luck!

Alex Jacob

unread,
Apr 4, 2024, 10:12:04 PMApr 4
to Miniscope
They are connected to our institutional wifi, though the personal laptop I'm testing on right now isn't managed by the institution. I tried disabling antivirus and also turning off the wireless adapter (removing myself from the institution network), however this didn't resolve the issue sadly. I'll try taking a miniscope home and testing it on a totally different network to see if that has any effect. Thanks for the tip!
Reply all
Reply to author
Forward
0 new messages