miniscope cannot connect

Skip to first unread message


Aug 8, 2023, 2:26:19 AMAug 8
to Miniscope
Hi everyone,

I am having connection issues with the miniscope, with the error message "My miniscope V4 cannot connect to camera". It worked before but then stopped working.

All 3 status lights and the red light on the top of the miniscope were on, but not the blue light. We have tried the following but failed / did not work:
- Switching device ID with all combinations from {0,1,2} but cannot connect;
- changed a new coaxial cable (but the same problem remains);
- Firmware update: BUT the firmware updated failed in one computer and cannot be detected in FX3SDK for the other 2 computers;
- making sure the miniscope is connected to a USB3 port;
- tried different computers but none of them worked so far;

Does anyone happen to know what the problem could be?



Fa Peng

Aug 11, 2023, 5:20:35 AMAug 11
to Miniscope
Hi, there,
As for the device ID, it depends on how many computers the device is connected to. For example, if the device is connected to four cameras, it needs to test 0-3 {0,1,2,3}.
Firmware update, Set the DAQ Jumpers to "Boot from USB"。
Use a multimeter to test for a short circuit (positive and negative of the coaxial cable), from the DAQ to the miniscope.
Hope that this will help.
Fa Peng 


Aug 18, 2023, 4:56:31 AMAug 18
to Miniscope
Thanks for the reply, we have tested all the above but showed no issue. But we have discovered that we do not have a driver suited for the miniscope v4 (attached image).

Does anyone know which driver would we need to get the miniscope working again and/or where we could get it, or any potential underlying problems causing this (as it worked before)?

Thanks in advance.



Daniel Robert Griffiths

Oct 5, 2023, 5:49:07 PMOct 5
to Miniscope

Did you have any luck troubleshooting your problems? We just purchased several miniscopes v4.4 and are having similar issues.


Reply all
Reply to author
0 new messages