Miniscope V4 not triggering

329 views
Skip to first unread message

Fabio Marques Simoes Souza

unread,
Oct 3, 2022, 1:47:53 PM10/3/22
to mini...@googlegroups.com
Why is the trigger not working? I want to send an external TTL trigger into the miniscope for synchronizing it with my behavioral task. I selected the option Triggerable in the control panel, and then it shows the button Record (Ext. Trig. Enabled). However, if I click Record (Ext. Trig. Enabled), it starts recording the frames anyway without really waiting for the external trigger. I tried to input a 3.3V or 5V input coming from an external TTL source into the DAQ trigger input -soldered accordingly with the following link- and it did nothing.


Regards,

Fabio

Eric Melonakos

unread,
Oct 4, 2022, 8:14:05 AM10/4/22
to Miniscope
Hi Fabio, once you select the Triggerable option, you don't need to click on the Record button. Just send the 3.3 or 5V (constant) input, and it should start recording. Then bring it back to 0V to stop the recording. The Record button is still there in the software in case you want to click to start the recording, but it's not needed.
Good luck,
Eric

Daniel Aharoni

unread,
Oct 12, 2022, 1:52:11 PM10/12/22
to Miniscope
I second everything Eric said.

Once you select the triggerable option, the software will begin recording on a low-to-high input transition and will stop recording on a high-to-low trigger transition. We had multiple requests to still allow for manual starting and stopping of the recording so that is why the manual buttons are still enabled.

David Protter

unread,
Oct 18, 2022, 1:49:26 PM10/18/22
to Miniscope
Interestingly, I spent yesterday trying to trigger recording just for a minicam with no miniscope. Id already validated triggering (from a Raspberry Pi, so 3.3v high), but was unable to trigger just a minicam. Going back to a config file for a cam and scope worked fine. Copying that file and removing the scope again didnt work. For whatever reason, the scope was required for the software to trigger. 

Pascal Malkemper

unread,
Oct 26, 2023, 4:40:10 PM10/26/23
to Miniscope
Hi,

we are also having troubles getting the ttl triggering working and would appreciate some advice. We would like to use only the Minicam to record behavioral data and we want to start the recording by a 3.3V TTL signal coming from a pycontrol board. We connected the TTL to the Input trigger port of the MiniDAQ.
However, even when using a config filed for both cam and scope and setting the triggerable option in the software, the recordings do not start. Any advice on what we could try?

Another problem we are encountering is that the image if the camera appears to be cropped. It does only show a fraction of what we are seeing in the windows camera software. When we set the resolution to the highest possible 2592x1944 in the config file, the video does not even open in the miniscope software.

Thanks a lot for your help!

Pascal

Brenton Laing

unread,
Jan 8, 2024, 12:20:37 PMJan 8
to Miniscope
DAPR...@colorado.edu thank you very much for this work-around to trigger minicam. This worked on my end. 

For now I am needing the miniscope to trigger minicam by arduino TTL.

Best,
Brenton

Reply all
Reply to author
Forward
0 new messages